locked
Client installation problem on XP SP3 - WMI 0x80070057 RRS feed

  • Question

  • Good day. 

    We have a several clients pc`s (WinXP SP3) on which SCCM client installation fails. It fails with error:

    "Unable to connect to WMI on remote machine "", error = 0x80070057."

    I`ve found that DCOm on this machines was disabled, what have i already done:

    1. I`ve checked 135 port, from sccm i could connect to client on this port by telnet.

    2. I`ve turned on DCOM Component Services:

    2.1 My Computer Properties\Default Properties\Enable DCOM on this computer

    2.2 My Computer Properties\Default Protocols\Add\Connection-oriented TCP/IP

    2.3 On COM Security i`ve maded the same permission as on computer with SCCM client.

    3. Restart computer

    Also i`ve tried to test WMI from SCCM server, i`ve started wbemtest and tried to connect to client PC but it fails with error:

    Number: 0x80070057

    Facility: Win32

    Description: The parameter is incorrect

    It could not helps me. What else should i do?

    Wednesday, May 23, 2012 2:59 PM

Answers

  • Hello aaamoto,

    Did you try to get any information from that XP client via WMI query?

    Try to run this command on your XP computer and then try a WMI query again:

    netsh firewall set service RemoteAdmin enable

    Brgds.

    Tamas

    Friday, May 25, 2012 3:42 PM

All replies

  • You need more than port 135 open for a successful client push: http://technet.microsoft.com/en-us/library/gg682180.aspx


    Jason | http://blog.configmgrftw.com | Twitter @JasonSandys

    Wednesday, May 23, 2012 4:24 PM
  • Thank you for your answer, i know that i need to open not only 135 port. Client computer is in the same subnet where are computers with successfully installed SCCM client, all needed ports are opened. Promblem is in this computer, but i dont know where. There is some problem with DCOM-WMI but i could not resolve it...

    Today i`ve tried to do sfc /scannow it doesnot helps, after restar i`ve received the same error. I`ve took the CD with OS WinXP SP3 distrib and started the setup in upgrade option it helps. After installation completes the SCCM client successfully installed. So now i need to decide how to fix it without reinstalling OS in upgrade mode. Is there some way to reinstall only DCOM component? I have 30 clients with the same problem, maybe virus, maybe distrib was incorrect but i nedd to fix it...


    Moto



    • Edited by aaamoto Thursday, May 24, 2012 8:51 AM
    Thursday, May 24, 2012 2:07 AM
  • Are the clients located in the same network?

    Dennis de Roo

    Thursday, May 24, 2012 1:34 PM
  • Yes they are located in the same network.

    What else i`ve tried:

    1. I give all permissions to DCOM for Anonymous&Everyone

    2. I reregister WMI using this script:

    REM Check if WMI is functioning correctly or not
    REM Get computername from WMI
    wmic computersystem get name
    IF %ERRORLEVEL% EQU 0 goto success
    :failure
    net stop ccmexec /y
    net stop VMAuthdService /y
    net stop winmgmt /y
    c:
    cd %systemroot%\system32\wbem
    rd /S /Q repository
    regsvr32 /s %systemroot%\system32\scecli.dll
    regsvr32 /s %systemroot%\system32\userenv.dll
    mofcomp cimwin32.mof
    mofcomp cimwin32.mfl
    mofcomp rsop.mof
    mofcomp rsop.mfl
    for /f %%s in (‘dir /b /s *.dll’) do regsvr32 /s %%s
    for /f %%s in (‘dir /b *.mof’) do mofcomp %%s
    for /f %%s in (‘dir /b *.mfl’) do mofcomp %%s
    net start winmgmt
    net start VMAuthdService
    net start ccmexec
    goto end
    :success
    goto end
    :end

    Let me repeat one more time it is no firewall issue because the install OS in upgrade mode from distrib on problem machine helps me. SCCM client successfully installs, but i have 30 machines with this trouble it is unbelievable to reinstall OS on them...


    Moto

    Thursday, May 24, 2012 1:47 PM
  • Hello aaamoto,

    Did you try to get any information from that XP client via WMI query?

    Try to run this command on your XP computer and then try a WMI query again:

    netsh firewall set service RemoteAdmin enable

    Brgds.

    Tamas

    Friday, May 25, 2012 3:42 PM