locked
Debug error when trying to run Server Cleanup Wizard, or anything that invokes Server Cleanup Wizard RRS feed

  • Question

  • I have this problem in both the WSUS MMC and in a PowerShell script that I got to clean up WSUS.

    Here's the error:

    An unhandled Microsoft .NET Framework exception occurred win w3wp.exe [59520].

    The Just-In-Time debugger was launched without necessary security permissions.  To debug this process, the Just-In-Time debugger must be run as an Administrator.  Would you like to debug this process?

    I have two options:  Yes, debug w3wp.exe or No, cancel debugging.

    If I choose no, then the process just aborts. If I choose yes, then I get a UAC prompt.  Then I get a Visual Studio Just-In-Time debugger windows that shows possible debugbgers: with "New instance of Microsoft Visual Studio 2010."

    If I choose Yes, then I get a window that says "Invalid license data.  Reinstall is required."  Then I get a window that says: "The debugger you selected cannot be started.  Would you like to choose another?"

    That is pretty much as far as I can go.  I can't find a way to fix this freaking thing.

    I'd love some suggestions and/or fixes.

    Thanks!

    Thursday, November 17, 2016 1:27 AM

All replies

  • Hi BoomSchtick,

    Generally, Server Cleanup Wizard and re-index WSUS database script is suggested to run regularly as a common maintenance.

    If we don't do it regularly and after WSUS old and expired files to occupy much drive space, then Server Cleanup Wizard will fail to run. You may check if this situation applies to yours.

    If yes, then you may try manually delete some expired data, then run Server Cleanup Wizard again. You may also try C:\program files\update services\tools>wsusutil reset, to re-download WSUS content file, check if it could help.

    Also increase Private Memory Limit:

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 18, 2016 9:40 AM
  • Hi,

    Have you got any progress with your issue? Could the above replies be of help? If yes, please mark related reply as answer, if not feel free to feed back.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 23, 2016 2:21 AM