locked
Spell-check check randomly not working despite features being on RRS feed

  • Question

  • I am using Microsoft Office 365 Plus which I got through the college I attend.  I write on my computer both for fun and for school.  A few days ago, I noticed that some things weren't being underlined as misspelled such as chemical names and a few person-names that I got tired of adding to the dictionary.  I thought at the time that the software updated their dictionary and would now include more scientific words and such.  However, then I noticed that nothing was being underlined as incorrect.  I knew that had to be wrong because I'm very far from a queen of spelling.  Once I experimented with a few documents, I noticed that even purposefully-misspelled words were being underlined.  This is not for all open documents.  It's not a certain length, either.  There does not seem to be a pattern at all for when the spellcheck is going out but, when it does, it's for the entire document.  Saving and reopening doesn't fix the issue, nor does restarting the computer. Copying entire document over to a freshly-opened document doesn't locate any errors, either, including purposefully-done ones.  

    Any help would be appreciated!

    Wednesday, August 9, 2017 8:47 AM

All replies

  • Hi,

    Please make sure the “check spelling as you type” feature is on

    To verify Spelling and Grammar Checkers are on,
    1.From the Review tab, click Spelling & Grammar
    2.In the Spelling and Grammar: dialog, click the Options… button.
    3.In the Word Options dialog, check the boxes for Check spelling as you type and Mark grammar errors as you type.
    4.Click OK.

    I also suggest you check if the support article will work for you:

    https://support.office.com/en-us/article/The-spelling-and-grammar-checker-isn-t-working-as-expected-36a52ba2-147c-4adf-a4d6-6f40fa747be1


    Regards,
    Emi Zhang
    TechNet Community Support

    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 10, 2017 9:42 AM
  • There is a troublesome feature in Word that allows you to mark text to not be checked. It is very useful for many purposes but when people don't know about it, it causes problems.

    This is under the Review tab under language. Set proofing language.

    This is not a setting for a document or for Word but rather is like character or font formatting in that it can be applied to a single character. It can also be part of a Style. When you copy text

    Start by selecting a word that you know is misspelled but not showing as problematic. Review > Language > Proofing language.

    Is the box for "do not check" checked?

    If so, uncheck it and see what happens.

    If that helps, begin by pressing Ctrl+A and then unchecking the box for that.

    Write back for longer-term solutions.


    Charles Kenyon Madison, WI

    Thursday, August 10, 2017 11:44 AM