Symantec have posted their Registry clean-up tool

All replies

  • Symantec have added a web page:

    "FAQ: Upgrading to Windows XP Service Pack 3 or Windows Vista Service Pack 1 with your Norton 2008 product installed"


    The tool is still available for download directly at:


    If you just launch this tool normally (e.g. by double-clicking on its icon after download) then the tool will only clean up known Symantec/Norton areas of the Windows Registry.  However, if you launch the tool from a Command Prompt window and add the parameter /override then the tool will clean up all of the "CurrentControlSet" area of the Registry, including areas relevant to other anti-malware vendors.  For instance, if the Command Prompt window is open with the current directory being the one in which SymRegFix was downlaoded into, then just type:


    symregfix  /override


    So it appears that this tool can be used as a general clean-up tool after misoperation of the fixccs.exe component of SP3, regardless of which anti-malware product provoked fixccs.exe into producing all the garbage registry entries.
    Friday, June 06, 2008 9:01 AM
  • Robin,


    This is simply to confirm that you are quite right in that Symantec's SymRegFix tool appears to remove all of the invalid registry keys completely and not just those associated with Norton products.  Of 3 machines that I have run it on this morning, it removed nearly 5,000 each from the first two and 5,500 from the third.  Everything now seems to be working fine on all 3 machines (none being HP with AMD processors - that, as we all know, is a very different issue!).


    Thanks, Robin, for all of the help and guidance that you have provided in these forums over the past few weeks.


    P.S. for those interested, I took my copy of the tool from:


    "FAQ: Upgrading to Windows XP Service Pack 3 or Windows Vista Service Pack 1 with your Norton product installed"


    Best of luck, everyone - do not hesitate with this.

    Friday, June 06, 2008 9:40 AM
  • I ran this tool last night and it deleted almost 5000 invalid entries. I re-booted and found that I still have nothing in device manager and my i-Pod still won't show up in my i-Tunes (the problem I first noticed after upgrading to SP3). I then looked at the manual process that was posted by Symantec earlier in the week and searched the registry for $%&'()*+ as per the instructions. I had many many hits on this search, but didn't take the time last night to delete them. I'm left unsure as to why the tool deleted so many invalid entries, but left in place the ones the manual process instructed be deleted??? I'm hoping that when I manually delete these entries that were left, my problems are indeed solved.



    Friday, June 06, 2008 4:45 PM
  • Could you tell us in which Registry branches the surviving $%& key names are?


    Did you run the tool with the additional /override parameter, or without?

    Friday, June 06, 2008 5:07 PM
  • It looks like they're all in:




    I ran the tool simply by double clicking it from the desktop.


    I'm going to delete these entries now and will post my results.




    Friday, June 06, 2008 9:52 PM
  •  Bish Music wrote:
    It looks like they're all in:


    You should find that the keys in the ControlSetNNN branches disappear automatically after two or three Windows re-boots.

    Friday, June 06, 2008 10:13 PM
  • I did re-boot several times to no avail...


    I just finished manually deleting all of the offending registry entries (there were a lot of them) and that seems to have done the trick. For the first time in two weeks I can see my device manager and my i-Pod conncected properly. Hopefully this will be the last of these difficulties.






    Friday, June 06, 2008 11:38 PM
  • Okay, I did the Symantec reg fix with the command prompt thing.  I rebooted and now windows is asking me for a driver for something called an HIDClass!  What is it and what do I do??


    Sunday, June 08, 2008 4:10 AM
  • TJX, I suggest that you allow the "New Hardware" wizard to proceed, selecting the options for "install automatically" and also permitting it to obtain drivers from "Windows Update".

    Sunday, June 08, 2008 12:44 PM
  • NVM, I figured out that HID was refering to Human Interface Device which meant that was my Wacom graphics tablet.  I reinstalled the latest driver and that new hardware wizard stopped popping up.  But the more important news is that I got my Hardware list back and all the hardware listed has none of the '!' symbols on them.


    Sunday, June 08, 2008 6:21 PM
  • Microsoft have also posted their own registry clean-up tool, fixccs.exe, which needs to be run in Safe Mode.  See


    Device Manager may not show any devices and Network Connections may not show any network connections after you install Windows XP Service Pack 3 (SP3) 


    Edit: corrected URL:


    Tuesday, June 10, 2008 4:49 PM
  • Robin (and everyone else),


    Sorry to be pedantic but Fixccs.exe is part of the problem and not Microsoft's registry clean-up tool for the numerous $%& invalid registry keys.


    What Microsoft have done (at is simply publish a drawn-out method, not a tool, for deleting these invalid keys post SP3 installation.


    The SymRegFix tool from Symantec is much simpler and more straightforward to use (as per rdhw/Robin's second post, above).

    Tuesday, June 10, 2008 5:13 PM
  • I seem to have jumped the gun on this one (apologises to Robin) as Microsoft have now issued their own tool to resolve the invalid registry key issue.  The confusion is that this "hotfix" carries the same name, i.e. Fixccs.exe but with a later version number 5.1.2600.5614.  It can be found at



    Apologises to anyone that I have confused/misled during the time since my 5:13 post, above.

    Tuesday, June 10, 2008 5:36 PM
  • But those of use who have already run "symregfix /override" and have our device manager list working don't need to run the MS tool right?


    Tuesday, June 10, 2008 5:41 PM
  •  eejaybee wrote:
    Sorry to be pedantic but Fixccs.exe is part of the problem and not Microsoft's registry clean-up tool

    I've corrected my post above to point to the Microsoft fix tool rather than to the manual instructions you found.  Thanks!

    Tuesday, June 10, 2008 7:10 PM

    Hi Robin,


    For me the SymRegFix by itself did not cure my problem, but the SymRegFix /override worked great.

    Also, for those that are having problems with Microsoft Streets & Trips 2008 (the program stopped working and wanted me to re-register; howver that did not work and just gave me an 0x8007000D Error), this solved the problem. The program now runs just fine again. BTW, Microsoft Tech Support didn't have a solution lilke this; they suggested uninstalling Norton Antivirus, etc.


    Hmm, I wonder what else was broken by the SP3.


    Thanks for posting this!



    Sunday, August 10, 2008 11:52 PM
  • I've tried clicking on it and it sends me here...from here I am unable to do anything....?!  Help!

    Index of

    Up to higher level directory

    Monday, September 15, 2008 4:58 PM
  •  MurphyD wrote:
    I've tried clicking on it and it sends me here...

    I cannot tell what you mean by "it".  The link you want is:


    If something adds an extra trailing slash to this when you click this link, then you have some nasty third-party download accelerator or something like that which is interfering with the correct operation of your web browser.

    Monday, September 15, 2008 5:48 PM