none
Installing Service Pack 2 on SQL Server 2012 RRS feed

  • Question

  • Hi

    I tried to install SP 2 on a server with SQL Server 2012. The first time I tried it I used the download provided by MS. What I didn't realize was that Windows Updates also have SP2 with in its updated so both got installed and something got hosed up. We had to uninstall SP2 and the database engine was able to come up.

    The second time I tried to install SP2 I tried the Windows Update SQL Server SP2 and I received error message that said msdb110_upgrade.sql encountered error 2714, state 6, severity 25. Also the log has and Error: 2714, Severity 16, State 6 and says "There is already an object named 'DatabaseMailUserRole' in the database.' Then Error:2759, Severity:16, State 0.

    'Create Schema failed due to previour errors and then it includes the failed batch of t-sql statements:

    --------------------------------------------------------------
    -- Database Mail roles and permissions
    --------------------------------------------------------------

    -- Create the DatabaseMailUserRole role
    IF (EXISTS (SELECT *
                FROM msdb.dbo.sysusers
                WHERE (name = N'DatabaseMailUserRole')
                  AND (issqlrole = 1)))
    BEGIN
      -- If there are no members in the role, then drop and re-create it
      IF ((SELECT COUNT(*)
           FROM msdb.dbo.sysusers   su,
                msdb.dbo.sysmembers sm
           WHERE (su.uid = sm.groupuid)
             AND (su.name = N'DatabaseMailUserRole')
             AND (su.issqlrole = 1)) = 0)
      BEGIN
        EXECUTE msdb.dbo.sp_droprole @rolename = N'DatabaseMailUserRole'
        EXECUTE msdb.dbo.sp_addrole @rolename = N'DatabaseMailUserRole'
      END
    END
    ELSE
      EXECUTE msdb.dbo.sp_addrole @rolename = N'DatabaseMailUserRole'  

    I tried to back out the install and the only successful component that was successful was the database engine. I was able to get the db engine back and the version is MS SQL Server 2012 - 11.0.2100.60[x64] but  the other components were not successfully uninstalled. Does any one know what I have to do to get this service pack installed successfully? Thanks

    Monday, March 2, 2015 1:48 PM

Answers