none
Unable to install dplyrXdf RRS feed

  • Question

  • Hi,

    I am trying to install using the following and it fails:

    > devtools::install_github("RevolutionAnalytics/dplyrXdf")
    Downloading GitHub repo RevolutionAnalytics/dplyrXdf@master
    from URL https://api.github.com/repos/RevolutionAnalytics/dplyrXdf/zipball/master
    Installing dplyrXdf
    Skipping 2 unavailable packages: RevoPemaR, RevoScaleR
    Skipping 3 packages ahead of CRAN: BH, R6, Rcpp
    "C:/PROGRA~1/MICROS~1/RCLIEN~1/R_SERVER/bin/x64/R" --no-site-file --no-environ --no-save --no-restore CMD INSTALL  \
      "C:/Users/jaymathe/AppData/Local/Temp/RtmpOExrwJ/devtools214018d3302/RevolutionAnalytics-dplyrXdf-656083e"  \
      --library="C:/Users/jaymathe/Documents/R/win-library/3.2" --install-tests 
    
    * installing *source* package 'dplyrXdf' ...
    ** R
    ** inst
    ** preparing package for lazy loading
    Warning: package 'dplyr' was built under R version 3.2.4
    ** help
    *** installing help indices
    ** building package indices
    ** installing vignettes
    ** testing if installed package can be loaded
    Warning: package 'dplyr' was built under R version 3.2.4
    Error : object 'union_all' not found whilst loading namespace 'dplyrXdf'
    Error: loading failed
    Execution halted
    ERROR: loading failed
    * removing 'C:/Users/jaymathe/Documents/R/win-library/3.2/dplyrXdf'
    Error: Command failed (1)
    > library(dplyrXdf)  # also loads dplyr
    Error in library(dplyrXdf) : there is no package called ‘dplyrXdf’

    How can I download the package?

    Thanks,
    Jaya

    Wednesday, August 10, 2016 3:38 PM

Answers

  • Thanks. I just installed the latest version from the CRAN repository: https://cran.r-project.org/web/packages/dplyr/index.html

    I still encounter this error:

    > install.packages("C:/Users/jaymathe/Desktop/dplyr.zip", repos = NULL, type = "win.binary")
    Installing package into ‘C:/Users/jaymathe/Documents/R/win-library/3.2’
    (as ‘lib’ is unspecified)
    package ‘dplyr’ successfully unpacked and MD5 sums checked
    > devtools::install_github("RevolutionAnalytics/dplyrXdf")
    Downloading GitHub repo RevolutionAnalytics/dplyrXdf@master
    from URL https://api.github.com/repos/RevolutionAnalytics/dplyrXdf/zipball/master
    Installing dplyrXdf
    Skipping 2 unavailable packages: RevoPemaR, RevoScaleR
    Skipping 4 packages ahead of CRAN: BH, dplyr, R6, Rcpp
    "C:/PROGRA~1/MICROS~1/RCLIEN~1/R_SERVER/bin/x64/R" --no-site-file --no-environ --no-save --no-restore CMD INSTALL  \
      "C:/Users/jaymathe/AppData/Local/Temp/RtmpCINAyI/devtools396464d45781/RevolutionAnalytics-dplyrXdf-656083e"  \
      --library="C:/Users/jaymathe/Documents/R/win-library/3.2" --install-tests 
    
    * installing *source* package 'dplyrXdf' ...
    ** R
    ** inst
    ** preparing package for lazy loading
    Warning: package 'dplyr' was built under R version 3.3.1
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
      namespace 'DBI' 0.3.1 is being loaded, but >= 0.4.1 is required
    Error : package 'dplyr' could not be loaded
    ERROR: lazy loading failed for package 'dplyrXdf'
    * removing 'C:/Users/jaymathe/Documents/R/win-library/3.2/dplyrXdf'
    * restoring previous 'C:/Users/jaymathe/Documents/R/win-library/3.2/dplyrXdf'
    Error: Command failed (1)
    > 

    I also used the option to install packages from RStudio using Tools -> Install packages and I still get the error.

    Is there anything else I need to look into?

    Wednesday, August 10, 2016 8:53 PM

All replies

  • You probably have dplyr version 0.4.3 or earlier installed. What's happening is that dplyrXdf implements an xdf method for the union_all generic, which was introduced in dplyr 0.5.

    If you update dplyr, the problem should go away. I'll also push an update to dplyrXdf to allow it to be used with dplyr 0.4.3.

    Wednesday, August 10, 2016 8:43 PM
  • Thanks. I just installed the latest version from the CRAN repository: https://cran.r-project.org/web/packages/dplyr/index.html

    I still encounter this error:

    > install.packages("C:/Users/jaymathe/Desktop/dplyr.zip", repos = NULL, type = "win.binary")
    Installing package into ‘C:/Users/jaymathe/Documents/R/win-library/3.2’
    (as ‘lib’ is unspecified)
    package ‘dplyr’ successfully unpacked and MD5 sums checked
    > devtools::install_github("RevolutionAnalytics/dplyrXdf")
    Downloading GitHub repo RevolutionAnalytics/dplyrXdf@master
    from URL https://api.github.com/repos/RevolutionAnalytics/dplyrXdf/zipball/master
    Installing dplyrXdf
    Skipping 2 unavailable packages: RevoPemaR, RevoScaleR
    Skipping 4 packages ahead of CRAN: BH, dplyr, R6, Rcpp
    "C:/PROGRA~1/MICROS~1/RCLIEN~1/R_SERVER/bin/x64/R" --no-site-file --no-environ --no-save --no-restore CMD INSTALL  \
      "C:/Users/jaymathe/AppData/Local/Temp/RtmpCINAyI/devtools396464d45781/RevolutionAnalytics-dplyrXdf-656083e"  \
      --library="C:/Users/jaymathe/Documents/R/win-library/3.2" --install-tests 
    
    * installing *source* package 'dplyrXdf' ...
    ** R
    ** inst
    ** preparing package for lazy loading
    Warning: package 'dplyr' was built under R version 3.3.1
    Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
      namespace 'DBI' 0.3.1 is being loaded, but >= 0.4.1 is required
    Error : package 'dplyr' could not be loaded
    ERROR: lazy loading failed for package 'dplyrXdf'
    * removing 'C:/Users/jaymathe/Documents/R/win-library/3.2/dplyrXdf'
    * restoring previous 'C:/Users/jaymathe/Documents/R/win-library/3.2/dplyrXdf'
    Error: Command failed (1)
    > 

    I also used the option to install packages from RStudio using Tools -> Install packages and I still get the error.

    Is there anything else I need to look into?

    Wednesday, August 10, 2016 8:53 PM
  • Thanks, now I am able to install it.
    Thursday, August 11, 2016 3:25 PM
  • How did you isntall it?
    Thursday, May 10, 2018 7:46 AM