locked
People Picker (WSS 3.0) finding only a partial list of AD users RRS feed

  • Question

  • Environment: WSS 3.0, Server 2003, single domain, AD with users in several OUs, back end SQL2005

    When I try to add users to a WSS site using people picker, it can only find a certain AD users and can't resolve others.

    When I do a search, I get an error.

    "No results were found to match your search. Please enter a new term or less specific term."

    The users it does resolve span the different OUs. It seems to be related to the more recent additions to AD. I only have about 50 users and it resolves maybe about half of them.

    The problem exist in the top level site and all sub sites.

    It had been fuctioning properly at one time.
    Anyone suggest what I might look at?


    Monday, September 15, 2008 5:45 PM

Answers

All replies

  • Hi,

    which authenticatio provider are you using? (NTLM, Kerberos or forms)

    Do you have more than one DC in the domain.. maybe they didn't get replicatated yet..

    Which SharePoint roles are on which server?

    Did you ever used the peoplepicker option in stsadm?

    Have you tried entering the full name "domain\username"?

    Just need more info to help you :)


    Daniel Bugday Web: http://www.sharepointforum.com/ Blog: http://www.sharepointforum.com/en-US/Blog/
    Monday, September 15, 2008 8:18 PM
  • Hi Jackson,

    Don't know if this will help but try to do a full import for the users.
    That's in Central Admin Site -> Shared Service1 (or whatever your shared service name is) -> User profiles and properties (under User Profiles and My Sites).

    Charles A.

    The only completely consistent person are the dead ~Aldous Huxley~
    Tuesday, September 16, 2008 10:35 AM
  •  

    I am running Server 2003, AD, DNS and WSS 3.0 all on the same box.

     

    I'm tried to limit People Picker to a specific container using the following command.

     

    stsadm -o setsiteuseraccountdirectorypath -path "CN=Sales,DC=ContosoCorp,DC=local" –url http://server_name

     

    It broke people picker. Now people picker is only pulling users from the site collection list not AD.

     

    Prior to executing the command I could use people picker to pick names out of AD, the “User OU”, a created “WSS OU”, and several OUs under WSS.

     

    I need to get to the functionality prior to running this command and don’t know the stsadm syntax to do so.

    Friday, September 19, 2008 4:16 PM
  • NTLM

    Single domain

    I havn't used stadm option for people picker

    I have used domain/name

    Friday, September 19, 2008 7:42 PM
  • Hi Charles, I working with WSS not MOSS so I do not have these options in SharePoint Admin.

    I did try to add users from stsadm and get "The user does not exist oe is not unique"

    My woes began when I ran this stsadm command.

    stsadm -o setsiteuseraccountdirectorypath -path "CN=Sales,DC=ContosoCorp,DC=local" –url http://server_name

    Saturday, September 20, 2008 3:24 PM
  •  

    I found my own answer.

    stsadm -o setsiteuseraccountdirectorypath -path "" -url http://server_name

    • Marked as answer by Jackson5403 Monday, September 22, 2008 8:53 PM
    Monday, September 22, 2008 8:51 PM
  • Hi

    I seem to have the same issue with stsadm -o setsiteuseraccountdirectorypath -path "CN=Sales,CN=North,DC=ContosoCorp,DC=local" –url http://server_name

    I can back the change out with stsadm -o setsiteuseraccountdirectorypath -path "" -url http://server_name

    But does anyone know why the first command does not work?  I have
    MOSS2007 SP1
    WSS SP1
    stsadmn - v12.0.6217.1000

    The command runs without error.
    Thursday, October 16, 2008 10:16 AM
  • Thank you so much!  I had spent a lot of days to resolve this issue.  To restore back the original settings and get the "The user does not exist or is not unique." error off using stsadm -o setsiteuseraccountdirectorypath -path "" -url http://mysite

    But if I want to limit the search for limited of users account, how will I do then?

    thanks!

    tong
    Thursday, January 1, 2009 11:10 AM
  • Hello

    You have to use the following command to make people picker search through the domains you specify in the command for the particular site

    stsadm -o setproperty

       -propertyname peoplepicker-searchadforests

       -propertyvalue <valid list of forests or domains>

       [-url] <URL>

    Mohamed Hachem ;)

    Cheers


    Momo
    Monday, August 23, 2010 8:06 PM