DPM 2016 Error backing up SQL Express databases on server after ur4 RRS feed

  • Question

  • After updating our DPM 2016 Server with ur4 I have an issue with two MS ADFS 2.0 servers that appear to be running SQLExpress 2005. I receive this error when trying to do a Recovery Point on any the SQL Express databases:  

    Error 104: An unexpected error occurred while the job was running.

    Error details: VssError:Class not registered


    I have removed all of the SQL backups from its Protection Group from one of the servers. When I try to add the databases back to the Protection group I get the following error:
    DPM could not enumerate application component SERVERNAME\MICROSOFT##SSEE\master on protected computer SERVERNAME (ID: 964)
    Wednesday, November 22, 2017 8:28 PM

All replies

  • SQL 2005 went end of life before DPM 2016 was released. I doubt that it was ever supported.

    Time to upgrade your SQL servers, they have been out of support for over a year now.

    Monday, November 27, 2017 10:00 AM
  • I had the same issue with DPM 1801, I fixed it by installing the SQL Server 2012 Native client:

    Also, I gave NT AUTHORITY\SYSTEM db_backupoperator permissions on every single DB, although this may not be needed in every case.

    Gabriel Talavera | MCP

    Tuesday, August 7, 2018 10:53 PM
  • Thanks! The SQLCLI.MSI fixed it for me, after about 6 hours wasted!

    Thanks a bunch!

    Saturday, January 26, 2019 3:44 PM