none
ActiveX component can't create object, error 429, please help RRS feed

  • Question

  • Hello guys,

    I am getting 'ActiveX component can't create object', error 429. when schedule runs scripts after 10 - 12 hr. interval. Issue is not re-producable and caused by:

    Set objEmail = CreateObject( "CDO.Message" )

    Set oConn = CreateObject("ADODB.Connection")

    I tried to run below statement but it does not help.

    C:\Windows\system32>%systemroot%\system32\regsvr32 %systemroot%\system32\scrrun.dll

    C:\Windows\system32>wscript -regserver

    Any ideas?


    gene

    Friday, December 5, 2014 5:47 AM

Answers

  • Sorry but this is not a scriping isuue.  You may need to fix your system.  If it is intermittent thn it is caused by conditions outside of the script or by a badly designed script.  There is not enough information to help you no matter what the cause.

    ¯\_(ツ)_/¯

    Friday, December 5, 2014 9:48 AM

All replies

  • Sorry but this is not a scriping isuue.  You may need to fix your system.  If it is intermittent thn it is caused by conditions outside of the script or by a badly designed script.  There is not enough information to help you no matter what the cause.

    ¯\_(ツ)_/¯

    Friday, December 5, 2014 9:48 AM
  • If you want it 
    to continue working after you log off you have to change the COM+ properties 
    of the package to run as a specific user. 

    I recently installed the Evaluation edition of BizTalk Server, but am 
    finding 
    that I need to reinstall the software every time I log off(I am using the 
    same 
    logon throughout). 
    The problem I think is that BizTalk cannot start the XLANG Scheduler COM+ 
    component - If I try to start it manually (in Component Services) I get 
    "Catalog 
    Error: Error Code 80080005 - Server Execution Failed" 
    more info: http://www.programd.com/118_4e0323a255219dd1_1.htm

    If I try to run the XLANG Schedule created in the Tutorial, via 
    ExecuteTutorial.exe, the error message is "...ActiveX Component can't create 
    object. Error: 429 (0x1AD)" 
    BizTalk is unable to run any XLANG Schedule, I also have a Schedule setup 
    which 
    is activated via a File Receive Function. This fails also. 

    The System Log reports the following error every minute (at least!): 
    "The server{bla bla bla}did not register with DCOM within the required 
    timeout" 

    The only solution I have found is to reinstall & even this is not successful 
    every time. 

    Has anyone else seen this problem? Any suggestions? 


    • Edited by KellerGary Thursday, February 26, 2015 1:42 PM
    Thursday, February 26, 2015 1:42 PM