WMI Failing


  • Hello,

    We have a domain controller running windows server 2003 R2 SP2 (32-bit).  For the past few months we have getting many errors in event viewer for the following:

    Source: Userenv

    Catergory: None

    Type: Error

    Event ID: 1090


    Description: Windows couldn't log the RSoP (Resultant Set of Policies) session status.  An attemp to connect to WMI failed.  No more RSoP logging will be done for this application.

    These errors have been appearing every 5-10 minutes since 9/10/13, but I haven't received any reports of something not working off of this server.

    I have restarted the Winmgmt service and ran "wbemtest.exe", but when I try to connect to the namespace "root\default" I get the following error message:

    Number: 0x8007007e

    Facility: Win32

    Description:  The specified module could not be found

    When I run "gpupdate" it completes, but generates the same error in event viewer (event ID 1090)

    I have also tried registering "userenv.dll" by running the following:

    cd /d %windir%\system32

    regsvr32 /n /I userenv.dll

    cd wbem

    mofcomp scersop.mof

    gpupdate /force

    However, I don't get past the 2nd line of the script; when I hit "enter" after "regsvr32 /n /I userenv.dll" I get the following error message:

    "DllInstall in userenv.dll failed.  Return code was: 0x8007007e"

    At this point, should I consider running a windows repair on a domain controller?  Any advice would be greatly appreciated?


    Wednesday, November 13, 2013 10:05 PM


All replies