DDE links in Excell not connecting after latest Windows 7 update on 01/10/2013 RRS feed

  • Question

  • Windows 7 Professional Service Pack 1 (upadated 01/10/2013 8:54 am)

    Office professional 2010 version 14.0.6129.5000 (32 bit)

    I have been using a DDE datafeed and Excel for connections to TDAmeritrade for stocks for several years.  After the latest Windows auto update my DDE excel formulas do not work.  I get the following messages when I open an established workbook and also when creating new formulas.

    “Remote Data not accessible…..Start application ‘TOS.EXE’?

    “Cannot run ‘TOS.EXE’.  The program or one of its components is damaged or missing.”

    I am also emailing this to TDAmertrade.  I have spoke with one of their techs and they said to contact microsoft. 

    Also, DDE is the only way I can connect.

    Anyone else having DDE problems?

    Thanks in advance


    Saturday, January 12, 2013 6:19 PM


  • MSCOMCTL problem fixed. 

    The Windows reinstall had 3 instances in different folders (including a real old one in a Cache folder).  I replaced all locations with the latest version -  MSCOMCTL.OCX 6.01.9834, unregistered \Windows\syswow64\mscomctl.ocx, rebooted, registered \Windows\syswow64\mscomctl.ocx and it now loads my listview controls.

    • Marked as answer by Jaynet Zhang Thursday, January 17, 2013 1:32 AM
    Wednesday, January 16, 2013 2:03 PM

All replies

  • Hi,

    Based on my research, this 'Remote data not accessible' warning is the equivalent of the workbook not found error when trying to update normal links. If you click yes then Excel will try to start the exe via DDE. This will only work if Windows knows where to find the app.

    To make sure Windows can find the app, you need to add its location to the 'path'.

    You can add the PATH by right clicking 'My Computer'>>Properties>>Advanced>>Environment Variables, then click path, then edit then add your new one on the end with a semi colon ; to separate it from the previous.

    Jaynet Zhang
    TechNet Community Support

    Monday, January 14, 2013 4:20 PM
  • Try going into the executable excel.exe in the program files(x86). right click on it and run as administrator. Then   open the excel file with your dde from within that instance of excel. 
    Tuesday, January 15, 2013 2:16 AM
  • Naomi/Jaynet

    I'm having the same issue with the DDE connection between ThinkorSwim and Excel on Workbooks that have been working for 3 or 4 years.  The problem started on 1/9/13 when Windows automatically installed the monthly "fixes".   The problem occurs on my 2 laptop computers that are running Windows 7 Home SP1 – 64 bit with Office 2010 SP1 32 bit.  The DDE links work fine on my desktop computer which is running Windows 7 SP1 32 bit with Office 2010 SP1 32 bit.   I’m launching the same workbook object from a file server for all 3 machines.  

    I called ThinkorSwim support and they said that a lot of people are having this issue to call Microsoft.  I did an online chat with Microsoft and he said that they are not aware of a problem and they cannot support third party software – call ThinkorSwim.   Yes this is old technology, but it’s the only way I can get real-time information from ThinkorSwim.   Over the last 5 days I have taken the following steps without resolving the problem:

    1.       Elevated Excel to run as admin which shows the CAC “Are you Sure” message and causes the problem “There is a problem sending the command to the program” whenever a workbook is opened from a shortcut or double clicking in Windows Explorer.   Opening Excel first then opening a workbook using then Excel open dialog opens fine.
    2.       Found and ran MicrosoftFixit50392 which appears to be related to this issues but no change.
    3.       Uninstalled and reinstalled ThinkorSwim desktop.
    4.       Updated Java to current levels.
    5.       Uninstalled and reinstalled MS Office 2010.
    6.       Started Windows in Safe Mode and the connection worked
    7.       Updated all the drivers – and rebooted in Normal – does not work
    8.       Ran DDESPY and determined that on the Laptop TOS is creating a DDE Server but Excel cannot find it.   On the Desktop TOS creates a server and Excel starts a conversation(s).
    9.       Wrote a VB program to do a DDE connection with TOS – connects fine on the desktop but not on the laptop.
    10.    After 4 days decided that a fresh version Windows is the answer.  Took most of Sunday to refresh the Operating system and reinstall the programs that I use.  I installed TOS and Office 2010 before I allowed Windows to run the automatic Updates.  The DDE connection to Windows worked.  But when I after the Windows Update it stopped working again.   This process was very painful as it broke my connection to the MSCOMCTL.OCX (32 bit) listview control that I use on my forms. (Same Workbook with the controls  still works fine on the desktop and second laptop!!!).

    So at this point I need to know how to launch my workbooks from shortcuts without having to set Admin permission (DDE does not update system info) and how to fix my MSCOMCTL.OCX connection.

    Fortunately I’m in town this week and can use my desktop, but need to be able to use my laptop when I travel next week.  Microsoft – if you are monitoring this thread, I can give you the results of my testing and research.

    Tuesday, January 15, 2013 3:42 PM
  • Adding the path to the environment variables did not fix the problem.
    Tuesday, January 15, 2013 3:43 PM
  • An Update

    I just spent 5 hours with MS support and made a little progress

    If I elevate EXCEL to Run as Admin, the workbooks will not launch from desktop shortcuts or by double clicking in windows explorer, but if opened directly from Excel will connect to DDE.   I guess DDE changes the system somehow to require Admin rights???

    If EXCEL does not have Admin rights, DDE will not connect

    MSCOMCTL still will not load on one of the laptops even after unregister/registering .....

    Tuesday, January 15, 2013 8:29 PM
  • MSCOMCTL problem fixed. 

    The Windows reinstall had 3 instances in different folders (including a real old one in a Cache folder).  I replaced all locations with the latest version -  MSCOMCTL.OCX 6.01.9834, unregistered \Windows\syswow64\mscomctl.ocx, rebooted, registered \Windows\syswow64\mscomctl.ocx and it now loads my listview controls.

    • Marked as answer by Jaynet Zhang Thursday, January 17, 2013 1:32 AM
    Wednesday, January 16, 2013 2:03 PM
  • Hi RW_MS,

    Thank you for sharing the solution to us!

    Jaynet Zhang
    TechNet Community Support

    Thursday, January 17, 2013 1:33 AM
  • Finally - I removed KB2778930 and the DDE links from EXCEL to TOS work without have to elevate EXCEL to admin.  

    Jaynet - please let the developers know that this "fix" broke the DDE connection in Windows 7 64bit

    • Proposed as answer by lucknau Monday, March 4, 2013 10:31 AM
    Monday, January 21, 2013 4:48 PM
  • Jaynet Zhang; allthough I'm not a pro; I fear to be more layman, I've the same problem with DDE's  in a Excel workbook/sheet. I used them very succesfully for more then 10 years, to bring in changes in stock quotes intraday from an Stock-investment system in to workbooks .

    I've tried several advices here above but the problem is still there.

    Question: does MS soon come with a new update to restore the situation? Or where I ve to go to for further help



    Tuesday, January 22, 2013 9:21 AM
  • same problem here today.  Uninstalling the update doesn't work.  I had to write a custom script for this user to elevate permissons.  Really, thanks for making more work for me today!
    Tuesday, February 12, 2013 7:35 PM
  • Feb Updates broke this again!!!!   I had to remove KB2778344 to get it working again.   Microsoft - Can you please give us a permanent fix for this issue.
    • Proposed as answer by lucknau Monday, March 4, 2013 10:32 AM
    Wednesday, February 13, 2013 5:13 PM
  • I also had to run MicrosoftFixit50392 on my Windows 7 32bit desktop and reboot several times to get my DDE links working again 
    Wednesday, February 13, 2013 6:13 PM
  • Thank you! Removing KB2778930 worked for me, too. Now all DDE links are functioning properly and I'm getting no error messages. The really confounding thing about this was that at one point it did start working, even with the updates installed. I wasn't able to put my finger on the reason it ever did work, though.
    • Edited by lucknau Monday, March 4, 2013 10:32 AM
    Monday, March 4, 2013 10:31 AM
  • Removing KB2778344 helped me, too. Thanks, so much for pinpointing this update as the cause.
    Monday, March 4, 2013 10:33 AM
  • Broken again with April Update - KB2808735 was the offender for 64bit Windows 7.  No problem with 32bit Windows 7

    Thursday, April 11, 2013 7:55 PM
  • Hi Jaynet - The problem remains. Microsoft updates are causing the problem. I had to remove the following updates KB2778344 - KB2778930 - KB2808735 for the DDE links in Excell to work.

    Tuesday, April 23, 2013 1:54 PM
  • When I set excel to Run as Administrator Windows cannot find/open the excel spreadsheet that is on the desktop. I get an error message "Windows cannot find C:\Users\...Desktop\ Make sure you typed the name correctly, then try again." Problem remains. No solution other than removing windows updates.

    Friday, April 26, 2013 2:18 PM
  • Jaynet Zhang,

    Broken again with May Updates.  Sure would like a fix to this.

    • Edited by Qmbg Thursday, May 23, 2013 1:51 PM
    Thursday, May 23, 2013 1:51 PM
  • Hi Jaynet - The problem remains. Microsoft updates are causing the problem. I had to remove the following updates KB2778344 - KB2778930 - KB2808735 for the DDE links in Excell to work.

    I only had 2 of these updates so I uninstalled those and the dde problem persisted.  I decided to format and reload my system.  I installed win7 home pro 64bit, TDA thinkorswim and Office 2010.  I did not install any Windows or Office updates - just plain vanilla.  The problem persists.  Before this problem started I used Excel with DDE links to TOS every day without problems.  I realize that DDE is old but there is no other way to get live data from TOS until TOS updates their system to a more modern protocol.  Any help is appreciated.
    Wednesday, May 29, 2013 8:38 PM
  • I inspected the Excel error codes and found that Logitech's Setpoint.exe was causing Excel to hang.  Uninstalled Setpoint.exe and now the DDE links work properly.
    Thursday, May 30, 2013 1:18 PM
  • Hi Trader73 - I also had to remove the May update KB2829361. Glad you found a solution for your system.
    Wednesday, June 5, 2013 1:50 PM
  • I had the same problem, I removed KB2778930, KB2778344, KB2808735, and KB2829361 and it worked.  Then in June there was a lot of updates from Microsoft and I could not read my stock quotes using the DDE link again.  So I got rid of all the updates to make it work.  Last night I recieved the July updates and once again my DDE link does not read.  Has anyone found the culprit updates for June and July?  Please share if you do.  Thanks
    Tuesday, July 16, 2013 4:57 PM
  • Worked for me too Win7 x32.  Connection to ToS works now.  Thanks!

    Tuesday, July 30, 2013 3:45 AM
  • i am having the same problems as this other user.

    i cant get the dde links from thinkorswim to work on my new notebook computer, even though all was fine on my desktop.  the solutions discussed here are over my head in terms of computer lingo, can somebody please walk me through the steps necessary to get it to work? 

    thanks so much in advance

    Monday, June 16, 2014 3:33 PM
  • I can concur I Killed Process Setpoint.exe and My Autohotkey DDE interface -> Rumba AS/400 ( tn5250 ) started working again.   I want to throw is mouse out the window so bad right now.  And WTF Logitech, make better software.
    Tuesday, June 24, 2014 12:11 AM
  • Same problem here.

    Excell hangs opening a workbook with DDE connections, when Logitech's SETPOINT.EXE is running.

    Innitialy raising both Excell and setpoint to administrator privilages, the problem was solved.

    After windows update's this solution didn't work anymore.

    I got everthing running again for e few days after defragmentation of disk and registry.

    But now the only thing that works is killing the setpoint process on opening the workbook. After opening the workbook setpoint may be started again, and existing hot dde-formulas will continue to be update. But making new DDE connections, pasting DDE connections is not possible, or make DDE connections with VBA is not possible.

    It appears form the extended office logging that excel waits for 'setpoint.exe' wich will not give an appropriate response.

    Friday, June 19, 2015 11:42 AM