none
Enabling Data Co-Location on DPM 2012 did not work RRS feed

  • Question

  • I been trying configure and fully utilize the tape by enabling the "Tape Optimization Setup". I have 5 PG right now. I tried to set 2 co-located PG sets and each of them have two PG. However on the first day job backup, it didn't make happen on both PG. I still see individual PG been written to the tapes. And I realized I didn't enable the co-location to fully utilize the tapes. By setting up the command on shell, I got this result:

    PS C:\Program Files\Microsoft System Center 2012\DPM\DPM\bin> Set-DPMGlobalProperty -DPMServerName SERVERFILES07 -OptimizeTapeUsage $True
    Set-DPMGlobalProperty : Parameter set cannot be resolved using the specified named parameters.
    At line:1 char:22
    + Set-DPMGlobalProperty <<<<  -DPMServerName SERVERFILES07 -OptimizeTapeUsage $True
        + CategoryInfo          : InvalidArgument: (:) [Set-DPMGlobalProperty], ParameterBindingException
        + FullyQualifiedErrorId : AmbiguousParameterSet,Microsoft.Internal.EnterpriseStorage.Dls.UI.Cmdlet.SetGlobalProperty

    Please advise.

    Currently I already update Rollup 3




    • Edited by Oneoa Thursday, November 1, 2012 4:38 AM
    Thursday, November 1, 2012 1:04 AM

All replies

  • Hi,

    The powershell command is no longer required.  Please be sure that the option to prevent PG's with different recovery goals to use the same tape is unchecked.  Also review the advanced option to be sure you have write period set long enough to accomodate the potential different start times of the backup for the protection groups you want to be co-located


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, November 1, 2012 2:33 AM
    Moderator
  • Yes, I did uncheck that, because I watched this video from Robert Hedblom when he mention.

    http://www.nic2012.com/nic2012_agenda
    http://vimeo.com/nicconf/review/35055224/edcdfa9672

    If you see my snapshot, Slot 11-14 created different tapes and the PG name still individual name, I assuming the PG name should change to FIL05v-FIL07v and OS-NON-VM??

    If powershell command is no longer required, however I follow the command from help.

    • Edited by Oneoa Thursday, November 1, 2012 5:00 AM
    Thursday, November 1, 2012 4:37 AM
  • Yes, the help file is incorrect, that is still from DPM 2010.  The protection group that writes the first dataset to a tape will use that PG name for the tape label.

    Do you have more than one tape drive in the library, and do the PG's specify to use more than one drive in the library selection screen ?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, November 1, 2012 11:58 PM
    Moderator
  • Hi Mike,

    Yes, I using DELL TL4000 (4 Drives) and DELL TL2000 (2 Drives).

    PGs:
    1. FIL01v, retention 2 weeks, ST-daily full backup, start at 5PM, located 1 drive, TL-4000.
    2. FIL02v, retention 2 weeks, ST-daily full backup, start at 5PM, located 1 drive, TL-4000.
    3. FIL03v, retention 2 weeks, ST-daily full backup, start at 6PM, located 1 drive, TL-2000.
    4. FIL04v, retention 2 weeks, ST-daily full backup, start at 5PM, located 1 drive, TL-4000.
    5. FIL05v, retention 2 weeks, ST-daily full backup, start at 6PM, located 1 drive, TL-2000.
    6. FIL06v, retention 2 weeks, ST-daily full backup, start at 4PM, located 1 drive, TL-4000.
    7. FIL07v, retention 2 weeks, ST-daily full backup, start at 6PM, located 1 drive, TL-2000.
    8. NON-VM, retention 2 weeks, ST-daily full backup, start at 9PM, located 1 drive, TL-2000.
    9. OS, retention 2 weeks, LT-Mon,Wed,Fri start at 1AM, located 1 drive, TL-2000.
    10. ARCHIVE, retention 5 months, LT-third Fri of month, start at 11PM, located 1 drive, TL-2000.

    Daily full backup except On Sat and Sun and all PG are enable on-the-wire compression. The reason we upgrade to DPM 2012 we want this feature co-location feature.


    • Edited by Oneoa Friday, November 2, 2012 1:54 AM
    Friday, November 2, 2012 1:53 AM
  • You can test co-location by manually making a recovery point for one data source in one PG that is in the co-located PG set, then when that if finished, manually make a recovery point for a data source in an PG that is in the same co-located PG set.  It should use the same tape.  You can use the in-box Power shell script ForceFree-Tape.ps1 to free the test tape.

    I tried to repro the issue and could not, here are my co-location settings. Both PG's are configured to do weekly backup's with 4 week retention.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Friday, November 2, 2012 10:40 PM
    Moderator

  • Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, November 2, 2012 10:55 PM
    Moderator
  • Mike,

    I changed expire tolerance to 2 days, It still did not work.

    How make this Co-location work with my PG configuration?

    Please take a note, my PG configuration are all ST Daily Full Backup to Tapes with 2 weeks retention.

    How make this thing working?

    Wednesday, November 7, 2012 1:13 AM
  • Hi,

    I also used daily backup, 1 week retention and still had no problems.  Please open a support case for further investigation.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, November 7, 2012 3:18 AM
    Moderator
  • Mike,

    What i'm supposed to see if this working?

    Could you share your screenshot of the tapes successfully worked with multiple co-location?

    I'm seriously didn't understand which are wrong, I installed DPM 2012 as fresh installation and updated with update roll-up 3. This co-location is kind simple, however it doesn't.

    Friday, November 9, 2012 4:11 AM
  • He,

    The screen shots above detail that DPMDB and GDS-TaskSchedulewriter PG's were co-located on the tape label DPMDB-LT-1dayX1Week-0000005

    Are you using tape encryption in any of your protection groups ?    We cannot co-locate encrypted PG's with non-encrypted PG's on the same tape.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Friday, November 9, 2012 2:57 PM
    Moderator
  • No, I'm not using encryption in any of my PG.

    I'm seriously I don't understand which part I did missed. It is fresh installation DPM 2012 with roll up 3 and i realized the cleaner tape got issue so i applied registry for "8 = RSM_COMPAT_CLEANER_EXCEPTION" and change the MinThresholdForFreePool.

    It seem your PG are DB, currently I'm backup are the contain of file server running with Hyper-V server with installed DPM agent. But I'm not backup the VHD files.


    • Edited by Oneoa Monday, November 12, 2012 3:57 AM
    Saturday, November 10, 2012 4:04 AM
  • On PG it self, this come to my attention.
    Why the backup library show as dash sign (-) ?

    All PG are set to ST with 2 weeks retention period and every day the tapes was pulled out from library and inserted with new tapes. Because everyday we send out tapes to offisite.


    • Edited by Oneoa Monday, November 12, 2012 7:25 AM
    Monday, November 12, 2012 4:12 AM
  • Hi,

    This appears to be GUI bug, if you only have short term tape backups scheduled, the backup library field is not populated, but that does not seem to effect tape backups or co-location as mine shows the same condition, yet co-location works fine.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Monday, November 12, 2012 5:16 PM
    Moderator