none
Error 360: The Operation failed due to a virtual disk service error RRS feed

  • Question

  • Hi,

    I am using System Center Data Protection Manager 2012 which is installed on Windows Server 2008 R2.

    2 virtual Disks (17 TB and 11 TB) are connected with DPM Server via ISCSI and all the replica volume and recovery point volumes are being created in those 2 disks.

    Everything was working fine till 2 days back, now I am not able to create any protection group or assign replica volume in DPM Manager.

    I am getting  "Error 360: The Operation failed due to a virtual disk service error"

    I have restarted the Virtual disk service and DPM Server, but it did not work.

    Can anyone help? 

    Tuesday, May 7, 2019 12:48 PM

All replies

  • Hi,

    Windows Server 2008 R2 supports a NTFS volume size up to 16 TB (GPT volume), when using the default cluster size (4K).

    Also please perform the steps below:

    1. Open a Command Prompt (Admin), then run diskpart.exe

    2. In the diskpart console type: list disk

    3. Paste the results here.

    4. Open the DPM PowerShell, and type: GetDPMDisk <DPMSeverName>

    5. Paste the results here.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, May 7, 2019 1:09 PM
  • Hi Mr. Leon,

    I did not attached any new disk recently.

    Here is the DISKPART result:

    Get-DPMDisk Result:

    Wednesday, May 8, 2019 4:19 AM
  • I tried restarting both DPM Server and Storage Server, but it didn't work for me.

    I created 10 MB volume in my disk, just to check if the manual partition creation is working or not, partition is created but virtual disk manager was not able to format the volume with error "Cannot find the file specified".

    When I reviewed the event viewer there I got this error:

    Wednesday, May 8, 2019 5:56 AM
  • Did you create the 10MB volume on the 10 or 17TB disks?

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, May 9, 2019 8:33 AM
  • I created on 10 TB disk, just to check if normal volume partition is working.
    Friday, May 10, 2019 4:23 AM
  • I tried on 17 TB disk also, same error "System can not find the file specified".

    These both disks are ISCSI disk hosted on Windows Server 2012 R2 Storage Server.

    I have made both the disks offline and disconnected the ISCSI target and again connected then and made the Disks online, but still the same error.

    While DPM Server's local disks are able to shrink and extend partition.

    Friday, May 10, 2019 5:26 AM
  • Sorry for the late reply, have you made sure that your storage hardware is compatible with your Windows Server operating system?

    www.windowsservercatalog.com


    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, May 20, 2019 7:06 AM
  • Yes, as I said earlier I was able to create the protection group for each server, and we have more than 100 server being backed up through SCDPM.
    Tuesday, May 21, 2019 1:01 PM
  • What exact version of DPM are you currently running? In the DPM console go to Help > About.

    Is your DPM server a physical or virtual machine?

    Are you able to create a Basic disk (not Dynamic) in the Disk Management?

    I noticed you had some volumes named as "Acronis", are you also using that as a backup software?

    Windows Server limitations:

    • NTFS volumes can be up to 2TB on an MBR disk and 16 Exabytes (EB) on GPT disks.
    • The maximum size NTFS volume that has been tested by Microsoft is 16 TB.
    • The maximum size of a VHD is 2040 GB (8 GB short of 2 TB).
    • Microsoft iSCSI Software Target maximum VHD size is 16 TB.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, May 21, 2019 9:15 PM
  • Hi Mr. Leon,

    Please see answers:

    What exact version of DPM are you currently running? In the DPM console go to Help About.

    Is your DPM server a physical or virtual machine?

    Ans: Its a windows Server 2008 R2 SP1 Physical Server.

    Are you able to create a Basic disk (not Dynamic) in the Disk Management?

    Ans: I have 14 TB, 10 TB and 2.3 TB disks connected to the server through ISCSI, and I have 3.4 TB and 1.7 TB disks connected to the server directly.

    When I create new volume in the disks connected to server directly, I am able to create it.

    But when I tried creating 10 MB Volume manually in 14 TB and 10 TB disks, the volume created but not formatted, and no drive letter assigned.  Manually formatting and assigning drive letter throws an error of "Can not find the file specified". I am even not able to delete those volumes.

    I noticed you had some volumes named as "Acronis", are you also using that as a backup software?

    Ans: Yes, we are using acronis 11.7 for the backup of Linux servers in our environment.

    In the above picture, Disk 3 and Disk 5 are used by SCDPM, Disk 2 and Disk 4 are used by Acronis 11.7, and disk 1 is used for manually backing up Operator Consoles.

    Regards

    Rohit


    Wednesday, May 22, 2019 5:41 AM
  • Also I restarted the virtual disk in the server and again tried formatting, deleting the volume and getting the error: RPC Server is not available.

    Now I started doubting of the issue is related to AD Group Policy.

    Any Clue?

    Wednesday, May 22, 2019 6:20 AM
  • This is not an AD or GPO issue, the Virtual Disk service is dependent on the Remote Procedure Call (RPC), so when you restarted the service, the RPC dependency was not available.

    In general it is not recommended to have multiple backup software in an environment, especially when it is on the same server, as this can cause issues.

    You could try referring to the similar post below to see if it could be of any help:

    Error 360 : Operation Failed due to a virtual disk service error


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, May 22, 2019 6:53 AM