locked
"Upload Failed" in Office Clients after adding ADFS RRS feed

  • Question

  • Hi,

    We are attempting to add ADFS authentication to SharePoint in a combined Kerberos/ADFS setup. Clients connected to the internal network use Windows Authentication, and remote clients use ADFS for authentication. (We're using https://spautomaticsignin.codeplex.com/). This works well in a browser, but does not seem to work for local Office clients (e.g Word, OneDrive for Business).

    When a user tries to save a file to the SharePoint document library with an Office application, it says Upload Failed: You are required to sign in to upload your changes to this location. Clicking the Sign In button does not seem to do anything.

    Looking at a network trace as Word attempts to sign in shows an HTTP request to /_vti_bin/cellstorage.svc/CellStorageService with a FedAuth cookie but no Authentication header, which gets a 401 response with the WWW-Authenticate header set to Negotiate,NTLM. Based on my understanding, Word should then re-try the request with the Kerberos ticket, but Word does not seem to retry at all.

    OneNote gives a real error message:

    Error code: 0x803D001F) There was an error communicating with the endpoint at 'http://{SharePoint URL inside network}/_vti_bin/webs.asmx'.; The server returned HTTP status code '401 (0x191)' with text 'Unauthorized'.; The server requires HTTP authentication scheme 'negotiate'.

    We are using Office 2013 and 2016 and SharePoint 2013. ADFS is version 3.0 on Windows Server 2012 R2.

    Note: I originally posted this at http://sharepoint.stackexchange.com/questions/200674/upload-failed-in-office-client-after-adding-adfs

    Thanks

    Thursday, December 8, 2016 1:25 AM

All replies

  • Hi,

    Please modify the authentication settings to only Kerberos authentication to see what happens when uploading files to SharePoint.

    Best Regards,

    Victoria

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, December 9, 2016 7:53 AM
  • Hi,

    Sorry for the delay. Setting authentication settings to Kerberos only does fix the upload problem. Unfortunately this is not a great solution for external users. Prior to disabling ADFS authentication, I also tried switching to the default sign-in page to make sure that it is not an issue with automatic sign in plug-in, but that did not fix the problem.

    Wednesday, December 21, 2016 5:49 AM
  • Hi,

    This issue may be due to that the security token was timeout when signing with ADFS.

    If you are using office 2013, please install update KB2910931 for Microsoft Office 2013 and then check what happens. This update include a fix for the security token timeout issue with ADFS.

    https://support.microsoft.com/en-us/kb/2910931

    Here is a similar thread for you to take a look:

    http://sharepoint.stackexchange.com/questions/176552/upload-failed-you-are-required-to-sign-in-to-upload-your-changes-to-this-locate

    Best Regards,

    Victoria


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, December 22, 2016 5:37 AM
  • I already had the update installed that you suggested, but I did try adding HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Internet\FormsBasedAuthSettings\RefreshFormBasedAuthCookie like the page suggested.

    I checked and made sure my settings were the same as the ones suggested by the StackExchange site.

    Both seemed to have no effect. As soon as I enable a Trusted Identity Provider, client integration starts failing.

     
    I would be happy to record a network trace using Microsoft Message Analyzer and send it to you.
    • Edited by felipet Sunday, January 8, 2017 6:05 AM
    Sunday, January 8, 2017 6:03 AM
  • Hi felipet,

    Did you find a solution for your problem with the ADFS authentication in Office? We are experiencing the same issue here as you described, but no solution yet.

    Should you have more information, feel free to share.

    Thanks in advance!

    Kind regards

    Gerry


    Best regards, Gerry Laenen.

    Thursday, October 12, 2017 8:27 AM
  • I also have a user that is experiencing a similar issue.  Getting Upload Pending in Office Upload Center then got a Kerberos Authentication Error below.  My issue is a little different because we are using Office 2016 but the user is connecting to our network over VPN not ADFS. 

    

    Wednesday, November 6, 2019 4:43 AM