none
Connection to the DPM service has been lost - ID:917 - When backup of exchange database runs to tape RRS feed

  • Question

  • DPM 2010

    When the backup of a specific exchange database runs to tape, an error occurs and the DPM console crashes. This only happens when backing up this database; all the others run fine.

    Here's the application event log message:

    Can anybody help with this one?

    The description for Event ID 999 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    An unexpected error caused a failure for process 'msdpm'.  Restart the DPM process 'msdpm'.

    Problem Details:

    <FatalServiceError><__System><ID>19</ID><Seq>1052</Seq><TimeCreated>2/5/2013 1:37:12 PM</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>ApplicationException</ExceptionType><ExceptionMessage>Unknown database error:  SP='dbo.prc_PRM_RecoverableObject_Insert' Error=50003</ExceptionMessage><ExceptionDetails>System.ApplicationException: Unknown database error:  SP='dbo.prc_PRM_RecoverableObject_Insert' Error=50003

       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlRetryCommand.ValidateReturnValue(String errorTitle)

       at Microsoft.Internal.EnterpriseStorage.Dls.DB.SqlRetryCommand.get_Parameters()

       at Microsoft.Internal.EnterpriseStorage.Dls.PRMCatalog.RecoverableObject.CreateInstance(SqlContext sqlContext, Int32 datasourceSequenceNumber, String logicalPathLocal, String componentNameLocal, ComponentTypeType componentTypeLocal, String captionLocal, Boolean selectableForRestoreLocal, Int64 dependentRecoverableObjectIdLocal, String recoverableObjectMachineNameLocal, Boolean matchLogicalPath)

       at Microsoft.Internal.EnterpriseStorage.Dls.PRMCatalog.PrmCatalog.AddRecoverableObjects(StreamWriter writer, DatasetROIdDictionary datasetROIdDictionary, Int32 datasourceSequenceNumber, Int32 datasetSequenceNumber, Guid datasetId, String logicalPathLocal, String componentNameLocal, ComponentTypeType componentTypeLocal, String captionLocal, Boolean selectableForRestoreLocal, Int64 dependentRecoverableObjectIdLocal, String machineNameLocal, List`1 fileSpecList, Guid lastSuccessfulDatasetId, Boolean matchLogicalPath)

       at Microsoft.Internal.EnterpriseStorage.Dls.PRMCatalog.PrmCatalog.AddDatasetROMapEntriesForReplicaDataset(Guid taskId, Guid fromReplicaDatasetId, Guid forDatasetId, Int32 forDatasetSequenceNumber, Boolean matchLogicalPath)

       at Microsoft.Internal.EnterpriseStorage.Dls.Prm.SetShadowCopyContextBlock.CreateArchiveDataset()

       at Microsoft.Internal.EnterpriseStorage.Dls.Prm.SetShadowCopyContextBlock.SetSnapshotContextSendForArchive(Message msg)

       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.Fsm.Transition.Execute(Message msg)

       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.Fsm.Engine.ChangeState(Message msg)

       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.TaskInstance.Process(Object dummy)

       at Microsoft.Internal.EnterpriseStorage.Dls.TaskExecutor.FsmThreadFunction.Function(Object taskThreadContextObj)

       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)

       at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)</ExceptionDetails></FatalServiceError>



    • Edited by Al- Tuesday, February 5, 2013 3:24 PM
    Tuesday, February 5, 2013 3:18 PM

Answers

  • Hi,

    This can occur if there are two entries in the tbl_RM_RecoverableObject table for Exchange's component. There should be only 1 entry - unfortunately this is not something that is fixable in a forum setting, please open a support case for further investigation and solution.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, February 5, 2013 5:50 PM
    Moderator

All replies

  • Hi,

    This can occur if there are two entries in the tbl_RM_RecoverableObject table for Exchange's component. There should be only 1 entry - unfortunately this is not something that is fixable in a forum setting, please open a support case for further investigation and solution.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, February 5, 2013 5:50 PM
    Moderator
  • Ok, thanks Mike.  I'll log a call.
    Friday, February 8, 2013 1:24 PM
  • Hello,

    I have the same issue. Was this resolved? If so, how?

    Thanks.

    Thursday, April 25, 2013 2:45 PM