locked
Resource Mailbox confirmation messages not being sent ( Exchange 2010)_ RRS feed

  • Question

  • Hello Folks,
     
                    I’m wondering if someone could have some insight into an issue we are having in our environment. First the issues, when users would setup a new appointment in one of the Resource rooms (conference rooms for us), they would usually receive a confirmation e-mail. Lately, they don’t receive any confirmation e-mail and the appointment or meeting is placed in their local calendar rather than the meeting room. This is only appearing on 3 out of the 9 rooms we currently have setup.  If I remember correctly, this was the older method of booking rooms and has since been changed in Outlook 2007. However, some users are dead set in their way and they completely rely on the e-mail and really need it back.
     
    Important Info: Exchange 2010 with Outlook 2007 Clients
     
    What I tried:
    ·         Restarted the Micorsoft Exchange Mailbox Assistants Service
    ·         Verified the Auto Accept feature was enabled using Get-CalendarNotification –identity; the AutomateProcessing was set to AutoAccept
    ·         Compared settings with a known working Mailbox using Get-CalendarNotification; the working and non-working mailbox had the same exact settings.
    ·         Found a few articles detailing a possible bug with the confirmation and followed instructions by selecting the Resource Out-Of-Policy Requests settings to “Selected Recipients” and leaving the text box blak
    ·         Removed all delegates
    ·         Checked Full Access permissions; both rooms have the same users
    ·         Checked Mail Flow Settings -> Message Delivery Restrictions -> Accepting messages from “All users” is selected and Reject Messages from “No Senders” is selected

    Thanks again Folks, and please ask any questions in case I left something out.


    Sys Admin, Rob M
    Monday, October 17, 2011 8:09 PM

Answers

  • Hello Fiona,

                    Thanks again for the clarification. Once running the new command we did get a return RoomMailbox.  I verified everything was set to AutoAccept. Thanks for the shortcut to the TechNet command as well.

    Folks,

                    This might be a different and odd issue, but here is what worked for us.  After checking and rechecking all the settings mentioned, we verified all settings were identical to working rooms, yet we still received no confirmations. I read a similar issue on another post mentioning the arbitration mailbox and creating a Local Move request. Therefore we moved the rooms to another database. Surprisingly after a few hours, the notifications began to appear again, and all the messages stuck in queue were delivered. 

     

    Thanks again to those who helped.


    Sys Admin, Rob M
    • Marked as answer by Rob Mart Thursday, October 20, 2011 7:16 PM
    Thursday, October 20, 2011 7:14 PM

All replies

  • What do you mean by "Checked Full Access permissions; both rooms have the same users"? Do all users who need to book have full access permissions to those conference rooms, or author rights or higher to the conference room calendars?

    If so, you have enabled Direct Booking. One of the characteristics of Direct Booking is that you will not get an Auto-reply but a pop-up.

    What happens if you try to book from OWA or ActiveSync? Do you you get a confirmation message then?


    MCTS: Messaging | MCSE: S+M
    Tuesday, October 18, 2011 4:52 AM
  • Thanks for the reply Jon,

                    Apologies if my post was confusing. What I meant to say was that I checked under “Manage Full Access Permission” and under “Select users or groups to grant or remove full access permission:” the rooms that are working correctly and the room that is not currently working have the same users listed.   Currently only the defaults Built-in Groups as well as a few admins are listed only.

    In order to check further I sat down with the user and had her show me exactly what she is doing; after following her steps I was able to reproduce the error on my own machine. For the sake of argument I’ll label the rooms Paladin and Gettysburg. 

    On the Client she does the following: New items -> Appointment -> selects date/time/subject -> Scheduling Assistant -> Add Rooms -> Adds Paladin -> Send. Within a few seconds she receive an e-mail from the conference room informing her the room Accepted the meeting, and it is placed on the calendar and is seen by all users.

    When we follow the same exact steps for the Gettysburg Room, there is no reply received. We then go check her calendar and see the meeting is seen in her personal calendar instead. Opening the meeting we see an error displayed “No responses have been received for this meeting”

    Is there any way to disable and re-enable the Assistant only for the Gettysburg Room? Does this help at all?


    Sys Admin, Rob M
    Tuesday, October 18, 2011 3:20 PM
  • Still, this is done from Outlook? What happens if you book from OWA? OWA has no code to handle Direct Booking.
    MCTS: Messaging | MCSE: S+M
    • Proposed as answer by tickermcse76 Tuesday, March 5, 2013 1:47 PM
    Wednesday, October 19, 2011 3:40 AM
  • Hi Bob,

     

    I believe it is configuration related issue but not the server side related issue. Please try the steps to troubleshoot this issue:

     

    1.    Verify and remove Directory Booking. There is an know issue that Directory Booking cannot coexist with auto accept agent, so we should disable direct book in Exchange 2010 system for Room mailboxes. To do this:

     

    1)    Enable the resource mailbox AD account and then logon as Outlook 2003 or Outlook 2007;

    2)    Click Options/Calendar Options/Resource scheduling, remove all three “Auto accept/decline” option if it is selected;

    3)    Switch to Permission box, remove users from calendar folder.

     

    2.    Verify if the Room mailbox has been correctly setup. To do this:

     

    1)    Run “Get-Mailbox –id <Room id> |FT RecipientType”, make sure the result returned is Room.

    2)    Run “Get-CalendarProcessing –id <Room id> |FL”, make sure the AutomateProcessing value is set to Autoaccept, and other values are the same as the working room mailboxes.

     

    Hope it is helpful.


    Fiona
    Wednesday, October 19, 2011 5:27 AM
    Moderator
  • Got some more information folks,

    ·         After hours, we moved the room to another database with no success

    ·         We created another Conference room, and it exhibits the same symptoms, no confirmation replies are sent

    ·         If I use OWA to login as the room I see all the confirmations in the inbox, waiting to be accepted or denied.

    ·         If I manually accept the invitations, the recipient receives the response as usual and the Appointment is added to the calendar correctly.

    Jon,

                    The user and I are using Outlook 2007 client to work on this. When I attempt to use OWA I still receive no notification.

     

    Fiona,

                    I completed the steps you mentioned in Option 1. Upon login, all 3 of the “Accept/Decline” were already unchecked. The only permissions were setup for Anonymous (None) and Default (Free/Busy time).

                    When I ran the “Get-Mailbox –id <Room id> |FT RecipientType” command the Recipient Type was actually returned as UserMailbox and not room.  However, I checked in the EMC and it displays it as Room.

                    After following these steps we did begin to get confirmations from the mailbox.

    Now I think we are getting somewhere. J I’ll keep you posted once we find a complete solution.


    Sys Admin, Rob M
    Wednesday, October 19, 2011 8:04 PM
  • Hi Rob,

    Thanks for your reply.

    Sorry for my typo, it should be Run “Get-Mailbox –id <Room id> |FT RecipientTypeDetails”.

    It appears the newly created mailbox cannot accept automatically, so run “Get-CalendarProcessing –id <Room id> |FL”, make sure the AutomateProcessing value is set to Autoaccept.

    If you have other require like delegate, inpolicy, etc, please use the "Resource option" in OWA, it will help prevent confusion. Or you can just simply compare the configuration with the working room mailbox. Refer to:http://technet.microsoft.com/en-us/library/dd335046.aspx.  


    Fiona
    Thursday, October 20, 2011 3:05 AM
    Moderator
  • Hello Fiona,

                    Thanks again for the clarification. Once running the new command we did get a return RoomMailbox.  I verified everything was set to AutoAccept. Thanks for the shortcut to the TechNet command as well.

    Folks,

                    This might be a different and odd issue, but here is what worked for us.  After checking and rechecking all the settings mentioned, we verified all settings were identical to working rooms, yet we still received no confirmations. I read a similar issue on another post mentioning the arbitration mailbox and creating a Local Move request. Therefore we moved the rooms to another database. Surprisingly after a few hours, the notifications began to appear again, and all the messages stuck in queue were delivered. 

     

    Thanks again to those who helped.


    Sys Admin, Rob M
    • Marked as answer by Rob Mart Thursday, October 20, 2011 7:16 PM
    Thursday, October 20, 2011 7:14 PM
  • Hi Rob,

    Thanks for your update and sharing, it would be helpful for others who encounter the same issue.

    From the information provided, I guess the room mailbox was corrupted or over the size limite. Anyway, it is good to know the issue is resolved.

    Thanks again :)


    Fiona
    Friday, October 21, 2011 1:50 AM
    Moderator
  • Thanks ! This was also what saved me. All my settings were ok , and well defined as Room Mailboxes with AutoAccept.

    After some message tracking i saw that the day of domain migration all rooms stopped answering requests.

    After changing databases all started flowing again . Many thanks ! :)


    • Edited by PedroPrata Tuesday, December 13, 2011 4:35 PM
    Tuesday, December 13, 2011 4:34 PM
  • Hi there,

    i think we've the same problem here - i moved the room mailbox several times but it still won't send notifications.

    We've 16 other roommailboxes - there are no known problems with sending notifications.

    Maybe someone got new informations/solutions regarding this problem?

    We're using Exchange 2010 SP2 on Windows 2008 R2 SP1.

    • Edited by heyko Wednesday, February 1, 2012 9:49 AM Update - OS / Exchange Version
    Wednesday, February 1, 2012 9:48 AM
  • Hello everyone!

    So we also had this issue and to be more specific as to the solution you need to move the Arbitration mailboxes and the Room mailboxes to a new database. About 30 minutes after the move was complete all queued up meeting requests from the day this issue started were sent to the delegates.

    To move the Arbitration mailboxes run this command.

    1. Run “get-mailbox –arbitration | fl name,database” to identify the current database the mailboxes reside on
    2. Get-Mailbox -Arbitration -Database currentdatabasename | New-MoveRequest -TargetDatabase targetdatabasename


    barney

    • Proposed as answer by barneytgo Thursday, July 19, 2012 3:02 PM
    Thursday, July 19, 2012 3:02 PM
  • Do I read this correctly in that if I have Full Access permissions to a room and I send a meeting request, that I would not receive a confirmation from the room that the meeting has been accepted? If I want to test, perhaps I should be testing from an account that doesn't have full access rights??

    Monday, March 25, 2013 8:16 PM
  • Thank you, worked like a charm!
    Wednesday, April 5, 2017 4:44 PM