none
Issues removing folder redirection

    Question

  • There is a group policy for redirecting My Documents to a file share but we'd now like to remove it while repointing back to the local PC but do not want the documents to get copied back to the users PC.

    I've tested by denying the GPO to a user and everything works except it keeps copying the users documents from the file share to the local PC at logon. I've tried both options in the "policy removal" behavior but it still happens. Also tried deselecting to move documents to the new location and no go.

    How can we remove the redirection but not have the documents copied back to the users pc?


    Wednesday, July 13, 2016 11:17 PM

All replies

  • Hi,

    Thanks for your post.

    In my opinion, you cannot remove folder redirection without redirecting the folder to local userprofile.

    To remove folder redirection, you must redirect the folder to local userprofile location. Then you could configure the folder redirection to not configured after the folder redirected to local.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 14, 2016 2:56 AM
    Moderator
  • > How can we remove the redirection but not have the documents copied back
    > to the users pc?
     
    You need to adjust the existing policy first (disable the "copy back"
    option), and then after a while (after each user has processed this
    first change) remove it.
     
    Thursday, July 14, 2016 10:43 AM
  • Hi,

    Are there any updates?

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 19, 2016 12:36 AM
    Moderator
  • Disabling the copy back did not work for us. It was testing using the existing GPO as well as a test GPO with identical settings. It seems like if the copy back option is set initially, un-checking it had no affect. After un-checking and running gpupdate /force with a reboot afterward two times and ensuring site replication on the DC's were ran manually twice just prior it still did not work. Each time it copied the files back. The AD environment is 2012 R2 native so maybe its a bug or some forgotten issue from way back creating this behavior.

    We ended up just removing the GPO and used a 3rd party software to set the relevant registry keys back to local. A GPO could have been used to reset the keys but the 3rd party software was used to monitor so no PC was left out.

    Tuesday, July 19, 2016 1:00 PM