locked
Office 2007 - fails to start (any application) 4.6 on XP RRS feed

  • Question

  • Hello everyone

    For the last 2 weeks I have tried to sequence Office 2007. I followed the sequencing guidelines to the letter and also used the famous "30 easy steps to sequence office" tutorial. (The only problem is that I don't find a check to disable the virtualized flag on the 2 VFS records)

    First the problem:

    All other applications like Sketchup, VLC and Firefox work perfectly on every client. However when I want to start a sequenced version of Word, Acces, Powerpoint or any other Office suite application I get the following error (translated from Dutch):

    "The operating system currently doesn't have the right configuration to execute the application".

    I see that Windows tries to execute an installer in the miliseconds before this error appears. I get the feeling that this is the installer you get sometimes when you first open an Office application. I want to note here that I have openend the applications already during sequencing (but no installers opens there).

    This is logged:


    [09/13/2010 14:33:26:627 ???? INF] {tid=97C:usr=leerling}
    Er is een fout opgetreden tijdens het openen van het virtuele register (sectie: 9), rc: 07B01F0C-0000004A
    There was an error during the opening of the virtual registry

    [09/13/2010 14:33:26:674 ???? INF] {tid=97C}
    Er is een fout opgetreden tijdens het openen van het virtuele register (sectie: 9), rc: 07B01F0C-0000004A
    There was an error during the opening of the virtual registry

    My setup:

    Sequenced on a  XP prof SP3 virtualbox machine. I use a clone of this machien with the client on it to try out the application.
    I use 4.6 for the Client and the management server.
    Server 2003 Domain with SQLExpress Database (2008)

    What did I try already:
    Used Q:\Off2k7 as directory
    used Q:\Office\Off2k7 as directory
    Only sequence Word (same error)
    Tried installing under Domain Admin and Local Admin account
    Added/remove the local interaction flag

    Any help will be greatly appreciated. If I need to sell my soul for this, so be it! First born son will be conciderd.

    Best regards

    Geert

     

     

     

     

    ort

    Monday, September 13, 2010 12:46 PM

Answers

  • Based on the log output, there's obviously something wrong with your VFS mappings in the package, which would explain why Office can't run properly as it does not see those certain virtualized directories.

    Have you tried to sequence again in case something went wrong the first time?

    Btw, virtualized flag mentioned in the recipe means "Override local directory" in 4.6, which should be changed to "Merge with local directory" in the VFS -tab's context menu.

     

    • Proposed as answer by znack Thursday, December 2, 2010 6:30 PM
    • Marked as answer by Aaron.ParkerModerator Saturday, November 17, 2012 2:34 PM
    Monday, November 22, 2010 7:38 AM
    Moderator

All replies

  • Hello,

    So, what did you do while monitoring?

    /Znack
    Monday, September 13, 2010 12:55 PM
  • Hello Znack,

    After the installation (still in monotorin status) I went to q:\Off2k7 and opened every application (excl Outlook etc..). Then I pressed stop monotoring and after selecting the applications that I wanted I opened those applications again. (Never did an installer start again).

    I hope this helps. If you have any more quenstions please feel free to ask.

    Thanks for taking the time to read all this.

    Monday, September 13, 2010 1:02 PM
  • Hello,

    Well - is that all? How did you install the application?  What settings where done? What components were installed? 
    Is there anything differentiating a client from your sequencer?

    /Znack
    Monday, September 13, 2010 1:05 PM
  • Hello Znack,

    I follow this tutorial to the letter : http://blogs.technet.com/b/appv/archive/2008/07/30/softgrid-sequencing-office-professional-2007-in-30-easy-steps.aspx

    There was only one difference. In the tutorial there is at step 27 :

    On the Virtual File System tab, expand CSIDL_APPDATA\Microsoft\Templates, and then right-click this entry to clear the virtualized flag. If you perform the sequencing operation on a Microsoft Windows XP-based computer, expand CSIDL_PROGRAM_FILES_COMMON\Microsoft Shared\ink and right-click this entry to clear the virtualized flag.

    However when I right clicked these items I din't see/find any checkbox nor other control with a name of virtualized flag.

    The components I got rid off are :

    • 2007 Microsoft Office Component
    • Digital Certificate for VBA Projects
    • Microsoft Office 2007 Language Settings
    • Microsoft Office Diagnostics
    • Notepad

    The client machine Is a clone of the sequencer (without the sequencer installed of course).

    Best regards
    Geert

     

    Monday, September 13, 2010 1:08 PM
  • Hello,

    Considering the fact that the guide utilizies a version of the sequencer that looks different from the 4.6 sequencer, following it to the letter seems just ridicilius. 

    I would guess that either the run all from my computer was missed, the installation-path is wrong. But since you aren't providing enough details - I really don't know.

    /Znack

    Monday, September 13, 2010 1:12 PM
  • I just tested the applications on a machine were Office 2007 is also physicly installed and it works!
    So my guess is that there are some registry settings that the app-v client can't make...
    Monday, September 13, 2010 1:13 PM
  • Hello Zack,

    Unfourtunatly it is the only guide I can find. Yes it looks different but almost all options are also there in version 4.6 (excluding the virtualized flag).

    The installation path isn't wrong. Tried both Q:\Off2k7 and in Q:\Office\Off2k7. This is what every guide and Microsoft recommends to use.

    I din't use Install all from my computer because the Guide doesn't recommend this. However if you think that this maybe the cause of the problem I will try it now.

    My best guess is that there are some user bound registry settings that the appV clients try to set on the pc but fails to do so. However I don't know why or how I can fix this.

    If further details are needed I am more than willing to provide them but what else do you need?

    Best regards
    Geert

     

    PS: If you have a guide for the 4.6 version feel free to share it.

     

     

     

     

    Monday, September 13, 2010 1:23 PM
  • Does Process Monitor show you the missing Registry key? If you place the App-V client log in verbose mode, does it log the Registry key it's having issues with?
    Monday, September 13, 2010 1:51 PM
    Moderator
  • Hello Aaron,

     

    I din't find the registry keys in the log. However I do find this:

    09/13/2010 17:25:42:412 ???? VRB] {tid=688:usr=Administrator}
    vfs_csidl_root_map_builder::upload_entry suite (0x00000008) failed virtual path \??\C:\Program Files\Common Files ondersteunend pad \??\Q:\OFF2K7\VFS\CSIDL_PROGRAM_FILES_COMMON\.


    [09/13/2010 17:25:42:443 SWAP VRB] {hap=C:app=Mozilla Firefox 1.9.2.3855:tid=D6C:usr=Administrator}
    GetIcon(global=FALSE)

    [09/13/2010 17:25:42:475 ???? VRB] {tid=688:usr=Administrator}
    vfs_csidl_root_map_builder::upload_entry suite (0x00000008) failed virtual path \??\C:\WINDOWS\system32\spool ondersteunend pad \??\Q:\OFF2K7\VFS\SFT_SYSTEM32_SPOOL\.


    [09/13/2010 17:25:42:490 SWAP VRB] {hap=C:app=Mozilla Firefox 1.9.2.3855:tid=D6C:usr=Administrator}
    Checking for user-specific icon

    [09/13/2010 17:25:42:521 ???? VRB] {tid=688:usr=Administrator}
    vfs_csidl_root_map_builder::upload_entry suite (0x00000008) failed virtual path \??\C:\WINDOWS\system32 ondersteunend pad \??\Q:\OFF2K7\VFS\CSIDL_SYSTEM\.


    [09/13/2010 17:25:42:553 FILE VRB] {tid=D6C:usr=Administrator}
    GetCachedIcon(file=C:\Documents and Settings\Administrator.LLNET\Application Data\SoftGrid Client\Icon Cache\199C1181-21C3-40CB-9FC4-CCB52251FF2C.ico, user=0xFFFFFFFC)

    [09/13/2010 17:25:42:600 ???? VRB] {tid=688:usr=Administrator}
    vfs_csidl_root_map_builder::upload_entry suite (0x00000008) failed virtual path \??\C:\Program Files ondersteunend pad \??\Q:\OFF2K7\VFS\CSIDL_PROGRAM_FILES\.


    [09/13/2010 17:25:42:615 FILE VRB] {tid=D6C:usr=Administrator}
    GetCachedIcon() got user id 0x1

    [09/13/2010 17:25:42:646 ???? VRB] {tid=688:usr=Administrator}
    vfs_csidl_root_map_builder::upload_entry suite (0x00000008) failed virtual path \??\C:\WINDOWS ondersteunend pad \??\Q:\OFF2K7\VFS\CSIDL_WINDOWS\.


    [09/13/2010 17:25:42:678 SWAP VRB] {hap=C:app=Mozilla Firefox 1.9.2.3855:tid=D6C:usr=Administrator}
    Got user-specific app icon 'C:\Documents and Settings\Administrator.LLNET\Application Data\SoftGrid Client\Icon Cache\199C1181-21C3-40CB-9FC4-CCB52251FF2C.ico'

    Hope this helps.


    Thanks alot!

    Monday, September 13, 2010 3:52 PM
  • Hello,

    have you tried removing your antivirus and see if that makes a difference?

    /Znack
    Friday, November 19, 2010 11:55 PM
  • Based on the log output, there's obviously something wrong with your VFS mappings in the package, which would explain why Office can't run properly as it does not see those certain virtualized directories.

    Have you tried to sequence again in case something went wrong the first time?

    Btw, virtualized flag mentioned in the recipe means "Override local directory" in 4.6, which should be changed to "Merge with local directory" in the VFS -tab's context menu.

     

    • Proposed as answer by znack Thursday, December 2, 2010 6:30 PM
    • Marked as answer by Aaron.ParkerModerator Saturday, November 17, 2012 2:34 PM
    Monday, November 22, 2010 7:38 AM
    Moderator