none
Azure Storage Explorer not working for either Data Lake Gen 2 or Gen 1 accounts

    Question

  • Hi,

    I am trying to setup a Azure Data Lake Gen 2 account and then upload some data. However, the Azure Storage explorer keeps erroring out with "Unable to retrieve children. socket hang up".

    Only the Storage accounts with hierarchial namespace enabled (Data lake gen 2) and data lake store gen 1 accounts have this problem.

    The normal blob storage accounts work just fine.

    I see the accounts, just that in case of Gen 2, when I click on containers it gives me the error.

    In case of Gen 1 accounts , there is no error, but it just keeps looping without showing any data.

    Had it been a proxy issue as mentioned in many blogs, I would not have been able to see other storage accounts (which work fine), so I am not sure what is the problem here.

    Also, this is my MSDN subscription, so I am the administrator/owner of these, so it is not an access issue either.

    I have also tried clearing up %appData%/StorageExplorer but to no avail.

    What is the problem here?

    Monday, February 11, 2019 11:29 AM

All replies

  • Hello Saugat,

    Thanks for posting here!

    Yes,  it may be proxy issue also, if you are connected to Azure through a proxy, verify that your proxy settings are correct. If you were granted access to a resource from the owner of the subscription or account, verify that you have read or list permissions for that resource.

    Try to sign out and sign into your MSDN subscription in Azure storage explorer to access the Data lake and see if this issue still persists. You can share the screenshot of the error with us to help better on this?

    I tried reproducing the issue and able to access the Data lake without any issue as shown below.

    I followed the steps as  mentioned in the article here.

    Monday, February 11, 2019 5:52 PM
    Moderator
  • Hi,

    Thanks for looking into this. Really appreciated.

    As I mentioned in my question already- It is all under my subscription (the data lake gen 2), and therefore I am the administrator/owner. So, the question of permissions does not arise.

    Regarding the proxy also, as again I already mentioned in my question, I can browse the other normal Blob Storage accounts. Had it been because of the proxy, even those would have been affected I believe.

    As you can see from the attachments, the other storage accounts are fine. Again want to reinforce - All these resources are under my azure subscription, so no problems with access.

    I am trying to follow up with the Network team to see if they could see anything in the proxy logs. But, I am still surprised as to why the other storage accounts show up fine.

    Tuesday, February 12, 2019 7:09 AM
  • I can able to access the containers of Azure data lake generation 2 and data present in the storage account. Did you tried refresh all or sign out and sign in options in Azure storage explorer?

    If not, could you please try once and let me know the status of issue.

    Wednesday, February 13, 2019 4:47 AM
    Moderator