locked
Mail Delivery Failed : message size exceeds fixed maximum size ##

    Question

  • Hi all,

     

    We have just started using MS Exchange 2007. Earlier we were able to send out mail with big attachment, however; the past one week I notice that users are not able to send out mail with size over 5MB. I have confirmed that 2MB mail can be sent out but anything over 5MB failed to deliver.

     

    Actual failed delivery message is

     

    "Requested #550 5.3.4 SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size # #"

     

    I have configured/confirmed  the following using management shell:

    1. SendConnector MaxMessageSize is 30MB

    2. ReceiveConnector MaxMessageSize is 30MB

    3. TransportConfig MaxSendSize is 30MB

    4. TransportConfig MaxReceiveSize is 30MB

     

    Appreciate any suggestion to guide me to work around the issue.

     

    Thank and best regards

    RW Lambas

    System Administrator

     

    Thursday, November 22, 2007 12:56 AM

Answers

  • You might want to try to set the message size limit values in AD using ADSIEdit:

     

    To use ADSI Edit to modify the global message size limits

    1. If it is necessary, install the Microsoft Windows Support Tools. For detailed instructions, see Install Windows Support Tools.

    2. Click Start, and then select Run. In the Open field, type C:\Program Files\Support Tools\Adsiedit.msc, and then click OK.

    3. Open ADSI Edit, expand Configuration, and then expand CN=Configuration..., expand CN=Services, expand CN=Microsoft Exchange, expand CN=<Your Exchange Organization Name>, and then select CN=Global Settings.

    4. In the result pane, right-click CN=Message Delivery, and then select Properties.

    5. In CN=Message Delivery Properties, select the Attribute Editor tab. In the Attributes section, locate the following attributes:

      • delivContLength   This is the incoming message size limit that corresponds to the MaxReceiveSize parameter in the Set-TransportConfig cmdlet.
      • submissionContLength   This is the receiving message size limit that corresponds to the MaxSendSize parameter in the Set-TransportConfig cmdlet.
      • msExchRecipLimit   This is the maximum number of message recipients that corresponds to the MaxRecipientEnvelopeLimit parameter in the Set-TransportConfig cmdlet.
    6. To modify an attribute, select the attribute, and then click Edit. We recommend that you set each global message size limit to match the value of the corresponding organization message size limit. In the Integer Attribute Editor, perform one of the following actions:

      • To remove the global message size limit, select Clear, and then click OK. The value of the attribute will be <not set>.
      • To enter value for a specific global message size limit, in the Value field, type the value, and then click OK. Valid input values are as follows:
        delivContLength   Valid input for this parameter is 0 to 2097151 KB. The default value is 10240 KB.
        submissionContLength    Valid input for this parameter is 0 to 2097151 KB. The default value is 10240 KB.
        msExchRecipLimit   Valid input for this parameter is 0 to 2147483647 recipients. The default value is 5000 recipients.
    7. Repeat step 6 for each global message size limit that you want to modify.

    8. To close CN=Message Delivery Properties, click OK and then click File, Exit to close ADSI Edit.

    From: http://technet.microsoft.com/en-us/library/bb310771.aspx

     

     

     

     

    Thursday, December 6, 2007 2:39 PM

All replies

  • Hi:

     

      Just to confirm same kind of problem, in my case; internal messages are stucked in 10MB; I've also adjusted the following values in the Mailbox,Hub,Trasport Server Role (1 Server with the 3 Roles) and also in the Edge Server Role:

     

    Send and Receive connectors MaxMessageSize to 100MB

    TransportConfig MaxSendSize and MaxReceiveSize to 100MB

     

    Any Help will be appreciated,

     

    Regards.

     

    Enrique Carbonell

    IT Consultant

     

     

    Tuesday, November 27, 2007 7:06 AM
  • Have you made these settings to all the receive connectors (of all servers)? It seems that the receiving server is advertising smaller size limit.

     

    Wednesday, November 28, 2007 10:29 PM
  • Hi,

    Only one mail server.

    Setup all connectors to 30MB

    Tested internal delivery 'OK'

    External delivery still return same error.

     

    Additional informations:

    1. MS Exchange 2007 running on Win2003 64bit server

    2. PDC running on Win2003 32bit server

    3. DNS running on Linux

    4. Firewall device is a Watchguard X1000 series running FSM 7.2 (already checked SMTP setup support up to 30MB)

     

    I believe issue lies somewhere on MS Exchange 2007 but could not pin-point. We did not have this issue before we migrated from Lotus Notes.

     

    Further advice appreciated.

     

    Regards

    RW Lambas

     

     

    Thursday, December 6, 2007 3:07 AM
  • You might want to try to set the message size limit values in AD using ADSIEdit:

     

    To use ADSI Edit to modify the global message size limits

    1. If it is necessary, install the Microsoft Windows Support Tools. For detailed instructions, see Install Windows Support Tools.

    2. Click Start, and then select Run. In the Open field, type C:\Program Files\Support Tools\Adsiedit.msc, and then click OK.

    3. Open ADSI Edit, expand Configuration, and then expand CN=Configuration..., expand CN=Services, expand CN=Microsoft Exchange, expand CN=<Your Exchange Organization Name>, and then select CN=Global Settings.

    4. In the result pane, right-click CN=Message Delivery, and then select Properties.

    5. In CN=Message Delivery Properties, select the Attribute Editor tab. In the Attributes section, locate the following attributes:

      • delivContLength   This is the incoming message size limit that corresponds to the MaxReceiveSize parameter in the Set-TransportConfig cmdlet.
      • submissionContLength   This is the receiving message size limit that corresponds to the MaxSendSize parameter in the Set-TransportConfig cmdlet.
      • msExchRecipLimit   This is the maximum number of message recipients that corresponds to the MaxRecipientEnvelopeLimit parameter in the Set-TransportConfig cmdlet.
    6. To modify an attribute, select the attribute, and then click Edit. We recommend that you set each global message size limit to match the value of the corresponding organization message size limit. In the Integer Attribute Editor, perform one of the following actions:

      • To remove the global message size limit, select Clear, and then click OK. The value of the attribute will be <not set>.
      • To enter value for a specific global message size limit, in the Value field, type the value, and then click OK. Valid input values are as follows:
        delivContLength   Valid input for this parameter is 0 to 2097151 KB. The default value is 10240 KB.
        submissionContLength    Valid input for this parameter is 0 to 2097151 KB. The default value is 10240 KB.
        msExchRecipLimit   Valid input for this parameter is 0 to 2147483647 recipients. The default value is 5000 recipients.
    7. Repeat step 6 for each global message size limit that you want to modify.

    8. To close CN=Message Delivery Properties, click OK and then click File, Exit to close ADSI Edit.

    From: http://technet.microsoft.com/en-us/library/bb310771.aspx

     

     

     

     

    Thursday, December 6, 2007 2:39 PM
  • Hi Henrik,

     

    Thanks... I think that resolved the issue.

     

    Actually, I came accross with the article many times and choose to ignore because my AD is on different box and I did not think much about it.

     

    For benefit of others, in my case, the Watchguard also play a role. There is an article on Watchguard Support Forum that says outgoing SMTP should be set to use 'filtred packet' instead of 'proxies' as in incoming SMTP.

     

    Once again, thanks all.

     

    Regards

    RW Lambas

    • Proposed as answer by KTell Tuesday, August 2, 2011 4:02 PM
    Friday, December 7, 2007 1:54 AM
  •  

    Good to hear you got it sorted out.

     

    Friday, December 7, 2007 7:49 AM
  • here's the fix,

    organization configuration -> hub transport -> and then click on the send connectors

    Then right click on each send connector and go to the properties and change the max message size

    to what ever you want.  Smile

     

     

    Thursday, January 3, 2008 9:12 PM
  • I had to go into Global Settings and change the record there after SP1 reset these to 10 MB.
    Wednesday, April 2, 2008 6:46 PM
  • after you did the ADSI edit, did you have to restart the servers, I made the same changes you did

    but it is still not working

     

    thank you sharon

    Friday, August 15, 2008 6:42 PM
  • Hi Sharon,

     

    Did you get an answer as to whether you had to restart the server for the adsiedit change to take effect.  I am having the same size limitation issue, amde the adsiedit change to 20480kb and still cannot receive any emails larger than 10240kb.

     

    Amar

    Tuesday, November 18, 2008 3:49 PM
  • Hi Henrik,

     

    Thanks... I think that resolved the issue.

     

    Actually, I came accross with the article many times and choose to ignore because my AD is on different box and I did not think much about it.

     

    For benefit of others, in my case, the Watchguard also play a role. There is an article on Watchguard Support Forum that says outgoing SMTP should be set to use 'filtred packet' instead of 'proxies' as in incoming SMTP.

     

    Once again, thanks all.

     

    Regards

    RW Lambas

    For me - this was the issue.  I had a SMTP proxy that had a restriction on the total email size that I recently implemented.  Exchange settings noted above were correct, the WatchGuard Firewall was the issue.

     

    Greetz.

    Tuesday, August 2, 2011 4:03 PM
  • Hi Henrik,

     

    Thanks... I think that resolved the issue.

     

    Actually, I came accross with the article many times and choose to ignore because my AD is on different box and I did not think much about it.

     

    For benefit of others, in my case, the Watchguard also play a role. There is an article on Watchguard Support Forum that says outgoing SMTP should be set to use 'filtred packet' instead of 'proxies' as in incoming SMTP.

     

    Once again, thanks all.

     

    Regards

    RW Lambas

    For me - this was the issue.  I had a SMTP proxy that had a restriction on the total email size that I recently implemented.  Exchange settings noted above were correct, the WatchGuard Firewall was the issue.

     

    Greetz.

    I came here to say this as well - I've been ripping my hair out with Exchange 2010, and not being able to figure out what the problem is/was. I had all the settings above done correctly, and only to find out (from reading this thread) that it was my Watchguard the whole time.... 10mb limit on the Proxy.

    Thanks to both of you above for finding this!

    -Chris

    Tuesday, January 31, 2012 8:56 PM
  • Thanks We werehaving same issue... solution was life saver..
    Thursday, April 5, 2012 8:07 PM
  • Same issue, Exchange 2007 SP1 + Fortimail, all max* size values on all connectors are 18Mb, but unable to send over 8Mb, only when change to 20Mb able to send until 10Mb no more. Double checked ADSEdit and values are the same as shell.

    3 months ago we were using Barracuda, now FOrtimail. When using Barracuda this problem wasn't exist; Fortimail experts swear their system is perfectlly configured and accepting mails such sizes (18Mb and greater), I doubt that, but CEO is asking for a solution.

    Friday, October 19, 2012 5:47 PM