locked
Failure at Configuration of Dashboard Viewer for Sharepoint Services at Monitor Server Configuration: Error1: Object reference n RRS feed

  • Question

  • Hello,

     

    I have a problem while trying to configure the Dashboard Viewer Component of the Monitoring Server. All the other components are configured successfully.

     

    The configuration of the dashboard viewer starts also fine. While the configuration is running, it performs a rollback and creates the Error Message “Error1: Object reference not set to an instance of an object”.

     

    I’m using a German windows 2003 server, so I thought the error is thrown because of using an English monitoring server.

     

    So I installed the German version of performance point monitoring server. The configuration failed also with the same error message, only in German. “Fehler 1: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.”

     

    Another issue is maybe, that the windows server is a domain controller. I used the following guide to install Monitoring Server on a DC.

     

    Installing PerformancePoint Monitoring Server on a Domain Controller

     

    1. If you are using a domain account, you must add it to the Administrators and IIS_WPG groups before installing the Monitoring Server. You don’t need to do this if using Network Service (recommended).
    2. To add a domain account to the appropriate groups: Use Start\Administrators\Active Directory Users and Computers:
      1. Add it to the Domain Administrators group
      2. Add it to the IIS_WPG group
    3. Install the Monitoring server MSI using this command line:
      1. msiexec /i PscSrv.msi SKIPOSCHECK=true

     

    Thanks for your help

     

     

    Cheers

     

    Christian

     

    Monday, November 12, 2007 9:51 AM

Answers

All replies

  • Hi Christian

     

    Unfortunately I do not know the answer but here is an article that may help:

     

    http://blogs.msdn.com/performancepoint/archive/2007/11/08/installing-performancepoint-on-a-domain-controller.aspx

     

    From what I can gather you cannot install the M&A portion onto a DC. You must install M&A first and then set up DC afterwards.

     

    Regards

     

    Paul

     

    Monday, November 12, 2007 10:34 AM
  • Hello,

     

    today, I removed the DC from my virutal pc. I learned a lot about Active Directory, but it didn’t solved the problem with the Performance Point dashboard viewer. The same error occurred while the configuration after the downgrade.

     

    So it seems to be that this is a particular problem with the vpc from my customer. I think it has something todo with custom rights configuration of the service accounts, but I’m not sure.

     

    I’m giving up right now.

     

    If someone maybe has an idea, why this error occurs, please let me know.

     

    Thanks again for your help.

     

     

    Cheers

     

    Christian

     

    Tuesday, November 13, 2007 9:26 PM