none
Export-mailbox MAPI error

    Question

  • I get the following error when attempting to export a Exchange 2007 SP1 mailbox to a PST file using the cmdlet: get-mailbox -identity test.test | export-mailbox -PSTFolderPath c:\temp\test

     

    The export-mailbox task for mailbox 'test test' failed.

    Error: Failed to copy messages to the destination mailbox store with error:

    MAPI or an unspecified service provider.

    ID no: 00000000-0000-00000000, error code: -1056749164

     

    Any and all help would be appreciated.

     

    Tuesday, March 04, 2008 9:52 PM

All replies

  • This drove me nuts, but mine was a relatively simple fix:  add to server admins on Exchange 2007 box then log out/log back into 32-bit xp machine to finalize permissions changes.

     

    This article shows you how:

    http://www.exchangeinbox.com/article.aspx?i=102

     

    Monday, March 17, 2008 3:52 PM
  • I've spent a better part of this day trying to get export-mailbox to work.  I have no luck at all.  No matter what I do I constantly get the "MAPI or an unspecified service provider.  ID no: 00000000-0000-00000000, error code: -1056749164"

    Exchange 2007 SP1 Rollup 5

    32bit windows server 2003 with EMT installed

    Outlook 2007 installed

    I added my personal user account as an exchange organization admin.  I even login to the machine as the domain admin who I KNOW is an exchange admin.

    I checked permission and added fullaccess to these accounts (was already there anyways)

    I have tried -includefolder -excludefolder -startdate -enddate   (makes no difference)

    I have moved the account to a brand new storage group and database

    I have tried different accounts.


    Nothing seems to work.   All i get is a username.pst file that is 32kb big and that's.  Anyone have any ideas?  I'm about ready to buy powercontrols from Ontrack.

    Thanks,
    Dan
    Thursday, January 08, 2009 8:44 PM
  • Found this on another post.  I followed it exactly.  Same error message.   I have no idea what to do.  You pay tons of money for this and its worthless.

    ------------------------------------

    Hi all,

    I got same issue,but fix it.

    Here is my step

     

    1. Create a New User account (EX: ExportAdmin)
    2. Add this account to a Exchange Server Administrator Permission Both Source and Target Exchange Mailbox Server
    3. Add this account to Local Administrators Group Member Both Source and Target Exchange Mailbox Server
    4. Make sure this account DO NOT HAVE ANY Domain Admin/Exterprise Admin permission(Just keep Domain User group permission)
    5. Assign Mailbox Full Access to this account by follow Cmdlet
    6. Get-Mailbox -Server "EX-CCR" | Add-MailboxPermission -User ExportAdmin -AccessRights FullAccess
    7. Runas with ExportAdmin account (Open EMC)
    8. Get-Mailbox -Server "EX-CCR" | Export-Mailbox -PSTFolderPath
    9. Done
    ------------------------------------------------
    • Proposed as answer by dlindsey Thursday, January 08, 2009 10:13 PM
    Thursday, January 08, 2009 9:59 PM
  • wow,  post by Elric in another topic.  I did simply that.  type fixmapi and prompt.  then export works. 

    Hello,

     

    I had the same issue after trying to do the export on server that had exchange 2003 installed.

    I did a fixmapi command and the error disappeared.

    It seems that the power shell takes the bad mapi dll to do the export.

     

    Cordially

    Elric Osmont


    • Proposed as answer by dlindsey Thursday, January 08, 2009 10:13 PM
    Thursday, January 08, 2009 10:13 PM
  • The Rollup 8 seems to fix the issue.
    Going to apply it very soon, and do some testing with mailboxes causing the issue


    http://support.microsoft.com/?kbid=968012

    960367   (http://support.microsoft.com/kb/960367/ ) Error message when you run the Export-Mailbox command on a folder that has more than 5000 items in Exchange 2007: "-1056749164"
    Friday, May 29, 2009 7:33 PM
  • hello all,

    i just want to make sure do we have the proper permission 

    since by defult both domain admins and also Enterprise admin will not have send as and receive as permission on the mailbox store 

    create a new user account 

    go to the ADSIEDIT and on the mailbox store properties add that account and give a send as and receive as permission log off and log back in 

    and check we are getting the same error 


    even we can give the account send as permission on the org level but we have to make sure that the permission are inherited properly to the mailbox store 

    thanks 
    venkat 

    Venkat
    Saturday, May 30, 2009 1:00 PM
  • I fixed this by changing the 'Receive As' permission on the Mailbox Store.

    I've also ran in to this issue when using ExMerge on Ex2003 boxes, so it was the first place I looked.

    Sunday, July 26, 2009 8:46 PM
  • I encountered the same problem but was able to complete the export by granting the account I was logged on as, full access to the users mailbox.
    • Proposed as answer by soadcma Tuesday, September 11, 2012 3:29 PM
    Tuesday, January 26, 2010 7:23 PM
  • I had the same error trying to export mail via the powershell cmdlet .. Export-Mailbox –Identity Alias-PSTFolderPath c:\pst,  and each time i receive the same error  ID no: 00000000-0000-00000000, error code: -1056749164

    I followed the support doc link http://technet.microsoft.com/en-us/library/dd285510(EXCHG.80).aspx and still no luck

    I confirmed the Exchange organization  permissions - aok
    I confirmed the full permission of the source mailbox - aok
    I confirmed the send as permission of the source mailbox - aok
    I confirmed local memebership of the server administrator group - aok
    On my test computer to perform the Export-Mailbox i verify the user was a member of the local administrator - aok

    I was p1ssed why this doesn't work..   Here's the weird thing.  I spoke to MS and they asked me to check the following setings in the registry for the Outlook client.

    The Outlook client machine may have cached mode set or PSTDisableGrow set or
    both keys set. Check the following registry keys and change them to FALSE (0) if they are set to
    TRUE (1):
    HKCU\Software\Microsoft\Office\12.0\Outlook\PST\PSTDisableGrow and change from 1 to 0

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\12.0\Outlook\Cached Mode and
    change from 1 to 0

    I didn't have the first registry entry, but I did have the second.  I changed it from 1 to 0 and tried it again.  It failed again.

    I then checked to see if I my profile was still in cache mode and it was.  I uncheck to use cache mode, confirm the registry entry and tried the Export-Mailbox cmdlet again.  BINGO!! 

    I was able to export the mailbox.   

    NLCRibby

    NLCribby
    • Proposed as answer by NLCribby Wednesday, January 27, 2010 12:27 PM
    Wednesday, January 27, 2010 12:27 PM
    • Verify Full Access Permissions on Mailbox
    • Set Mailbox Retention to 0 to clear dumpster items on the mailbox
    I've worked through this MANY a MANY of times. Clearing out the dumpster items via nightly scheduled maintenance and a retention value of 0 did it for me.
    Tuesday, November 23, 2010 5:35 PM
  • I am Domain Admin and I had no problem in Export the mailbox, only thing to solve this problem was to get full mailbox permission in in the mailbox that I was trying to export.
    Tuesday, September 11, 2012 3:30 PM