Windows Server 2012 r2 preview installation error

    General discussion

  • Downloaded today the preview version of Windows Server 2012 r2 preview. On boot, it gives an error. Tried it on a vm and I could find the following:

    Error Code: 0x000000C4






    Note: the CPU does not support virtualisation, Hyper-V

    Update 1: tested the Server Essentials version of well. The same error on vm.
    Update 2: two atempts to install. One, I removed all the hardware connected through usb and booted. Failure. The second, tried an upgrade instalation. On first boot, failed as well.
    Update 3: Tested both the X86 and X64 versions of Windows 8.1 preview on vm. The x64 version failed with the same error code, 0x000000C4. On the System Requirements for Windows 8.1 preview, it says: ”For 64-bit installations of Windows 8.1 Preview, your CPU must also support CMPXCHG16b, PrefetchW and LAHF/SAHF.” Tested my CPU with Coreinfo, it says it lacks CMPXCHG16b.

    Now, I am curious to know. WS 2012 r2 will be a free upgrade to WS 2012, like 8.1 to 8? If so, there will be problems, because they are some CPUs up there that do not support all thoose features.

    Maybe thoose who will not pay for an upgrade license to WS 2012 r2 will at least receive several updates, like one to update the kernel from 6.2 to 6.3 ?
    • Edited by Lotusisrael Saturday, June 29, 2013 10:47 PM
    Tuesday, June 25, 2013 3:13 PM

All replies

  • You state you are trying this in a VM.  What is the hypervisor?  The error message - CPU does not support virtualization - sounds like you might be trying to install the VM within VM running a hypervisor.

    Historically, R2 releases have come at no additional cost to customers who have a Software Assurance contract. If the product was not covered by SA, it was an additional cost to obtain the R2 release.  That's how Microsoft has done it historically.  You should talk to your Microsoft account team for specifics on your contract.

    .:|:.:|:. tim

    Friday, June 28, 2013 6:47 PM
  • I have a student free Dreamspark license.

    My CPU is rather old, it lacks support for Hyper-V, I use VMWare player. I have tried to install WS 2012 on a host machine as well, first as an upgrade. On first boot, it flicked with less then a second with an indistinguishable error code and reboot, in an endless loop. After choosing the old WS2012 instalation that was restored, I removed, as much as possible, the failed instalation. Tried again, with a new install of WS2012 r2 starting from Windows itself, again. The same thing. Burned the iso on a DVD and, on boot, gave a similar error. After the Windows 8.1 iso install was available, tried to make a vm with Windows 8.1 x64. It failed with the same major error code, 0x000000C4 . Tried then with Windows 8.1 x86, I succeded in installing on that vm, and to log on, even if the performance was pretty bad and instable. What can I make of this? I have asked on Windows 8.1 preview forums as well, could not get a clear answer. Most likely, the basic CPU requirements for Windows NT 6.3 x64 were raised with 3 extra ones, and one of thoose 3 lacks on my CPU and that can not be upgraded without the motherboard itself, to reach a state in which all thoose requirements are kept. I heard that Windows 8.1 will be upgraded for free from Windows 8, but WS2012 r2 from WS2012 will not.

    Note: on the previous post,  ommited unintentionally some characters and works. I mean: ”Tested both the X86 and X64 versions of Windows 8 on vm”, turned ”Tested both the X86 and X64 versions of Windows 8.1 preview on vm.” I have edited the post and I apologise.

    • Edited by Lotusisrael Saturday, June 29, 2013 10:49 PM Corecting spelling
    Saturday, June 29, 2013 11:57 AM
  • Hi,

    I have previously successfully installed Windows 8 Professional on a VMWare Player virtual machine.  On attempting to install Windows 8.1 preview, I get the identical error code that you posted above in your first post.  Hopefully, someone will have an answer for our problem.

    I note that the issue was solved for trying to install on Oracle Virtualbox - see

    Tuesday, July 02, 2013 6:11 AM
  • I used VMware, not  Virtual Box. If the CPU support virtualisation, I would have used Hyper-V. On me, not even the instalation DVD could be booted, it gave the error code for a flash of a second, unable to note it, then reboot over and over. Using VMware, the process would be frozen at the point of the crash, so I could get the error code. It may be an unsupport CPU, most likely, but I could not rule out other causes. I have managed to install the x86 version of Windows 8.1 preview, but not the x64 one, that gave the same error code, having the same kernel as Windows Server 2012 r2 preview.

    • Edited by Lotusisrael Tuesday, July 02, 2013 4:10 PM Spelling errors
    Tuesday, July 02, 2013 10:56 AM
  • You would have to check with the hypervisor vendor to see if they support the OS yet.  Not uncommon for them to take a rev or two to get the support for the latest OS into their products.

    .:|:.:|:. tim

    Tuesday, July 02, 2013 10:30 PM
  • That may be true, but that does not explain why the instalation DVD gives a flash of error on boot, then endless reboot. On Microsoft Community, I have seen others experienced an error with the same error code on Windows 8.1 preview x64. Some, who were on Oracle Virtual Box, had to enable the CMPXCHG16b on VB, and the instalation went on fine afterwards. My CPU does not support CMPXCHG16b, so it would make sense that any Windows NT 6.3, so far, to be impossible to install.  I was able to install the x86 version of the Windows 8.1 preview on VMware, the instalation DVD was also booted by the PC, even if this does not mean much for my problem. If WS2012 r2 will be a free upgrade, I would make sense that it will require exactly the same hardware as WS2012. On Windows 8.1 x64 installed on CPUs without CMPXCHG16b, if the present state I have observed continues, Microsoft could just give people the option to switch from Windows 8 x64 to Windows 8.1 x86, even this will mean, probably, loss of performance, installed programs etc. On WS2012 r2, most likely, there is no such solution and, since the 6.2 will be replaced on all Windows 8 machines with the 6.3 one, it would make sense for Microsoft to do the same on WS2012, even if the costumer does not pay for the whole WS2012 r2. I mean to upgrade only the kernel, maybe the interface too. I guess it will realy weird that, after the launch of WS2012 r2 and Windows 8.1 preview, the 6.2 kernel will remain present on WS2012 and not on Windows 8. Or maybe the final version of the kernel will support exactly what the previous one did, and this will solve the problems.
    • Edited by Lotusisrael Tuesday, July 02, 2013 11:23 PM Adding new information.
    Tuesday, July 02, 2013 11:14 PM
  • "but that does not explain why the instalation DVD gives a flash of error on boot, then endless reboot"

    Actually, that very behavior is what makes me think that the hypervisor needs an update in order to support it.  I've seen similar things in the physical world until the hardware vendor provided a BIOS upgrade.  In a hypervisor world, the hypervisor is providing the 'BIOS' for the virtual machine.

    You will need to talk to your Microsoft representative about how 8.1 and R2 will be released - that is not a topic for a forum while the product is just in preview release.  Microsoft often does not make those decisions until just before release.  But, historically, as noted above, R2 has always meant a purchase unless the customer had their current version under SA.

    .:|:.:|:. tim

    Wednesday, July 03, 2013 8:06 PM
  • "but that does not explain why the instalation DVD gives a flash of error on boot, then endless reboot" - That was hapening on the physical machine, not on any vm. I have called for local technical support, I was told the error will be examined and they shall get back to me soon. No significant information on future upgrade, I was said it is not decided yet, it seems. Still waiting to get back to me, at least with a brief explanation. I really hope that Microsoft will eventualy reconsider their strategy that seems to have been adopted and make the final versions of any Windows T 6.3 available to the exactly the same hardware as Windows NT 6.2 was, I mean 100%, not 95%, not 99%. They should keep in mind that some of their costumers, maybe not thoose from the US or 1st world countries, might have deployed their OS on some older hardware. Windows 8.1 was announced as a completly free upgrade, puting extra requirements will not fit this. Still hoping this is a bug, altough it is highly unlikely, very likely Microsoft just decided to pull off support of some older CPUs.

    Wednesday, July 03, 2013 11:58 PM
  • I got the same issue installing R2 preview on a Proliant ML350 G4p server. I had a file server role on it before in my test lab(WS2012 SP1), I decided to go for clean install as I found somewhere a statement on that upgrade from 2012 SP1 to R2 is not supported if certain roles are configured on the server.

    So I initially tried to install R2 preview over network, got a flash error with immediate reboot just after the Loading files part. Then I tried to install from USB stick with a double-checked version of install files. Same result. I am able to install the R2 preview from the same media on a VM or a regular PC bare-metal.

    ML350 G4p initially designed as a file server, CPU does not support virtualization. I intend to used it as such but no luck installing the R2 preview. No way to test the classy storage tiering :(

    If anyone come out with a solution, please ping me back!

    Thursday, August 29, 2013 10:02 AM
  • If WS 2012 r2 will not be a free update, and so users who will not choose to upgrade to 2012 r2 from 2012, Microsoft could at least launch a free update or free update pack to upgrade at least the kernel and, perhaps, to replace the 8 interface with the 8.1 interface, keeping the server feature unchanged. But, in this case, there is a issue, like on 8.1 x64. People with x64 cpus that do not support the new requirements could get the new kernel and interface on a slightly different version of the 6.3 kernel, with lower system requirements. If on the 8 to 8.1 Microsoft could present the solution for thoose in this situation to reinstall Windows 8 to the x86 version, with the same key, to be able to upgrade to 8.1 , on the server side things will be much tricier. My honest opinion is that it would be easier and cheaper, on the long term, for Microsoft to choose this issue, with the slightly modified 6.3 kernel, to be able to run on the old x64 cpus, so that they could dump 100% the 6.2 kernel from maintenence, to lower costs.
    Friday, August 30, 2013 11:46 AM
  • Tried to install a final release version of R2 today on my ML350 G4p. Same problem. I disabled internal NIC, removed all cards but SCSI controller. Nothing. Dead End?
    Tuesday, November 05, 2013 10:45 AM
  • Let's see.  The ML350 G4 was released to support Windows Server 2003.  I seriously doubt that HP has BIOS updates for a 10-year old system in order to run the latest operating system.  But, you can check with HP.  It will take updates for them.

    .:|:.:|:. tim

    Tuesday, November 05, 2013 2:14 PM
  • The only purpose for switching from a working server 2012 SP1 to 2012 R2 is to use the storage tiering function as I intend to use my ML350 G4p as an iSCSI target for a SOFS cluster nodes. I will definitelly see if I have the latest firmwares etc from HP but still I am surprised. I thought R2 is slightly upgraded 2012 SP1, but obviously not.
    Wednesday, November 06, 2013 7:56 AM
  • Well, since there is no such thing as Windows Server 2012 SP1, I don't know what you are currently running on your old box.  But, you will still have to check with HP for any updates they have.  But since the ML350 G4 is not listed on as supporting anything beyond Windows Server 2003, you could very well run into other issues that are not caused by the operating system.

    But, all is not lost if all you need is iSCSI.  You can do that by building a virtual environment and installing the iSCSI Target on it.

    .:|:.:|:. tim

    Wednesday, November 06, 2013 3:37 PM
  • I have just brought a brand new HP ML310e Gen8 v2 and the supplier has sent me Windows 2012 Essentials R2 with it..

    I have now tried a clean build on the server 5 times and every single time it has crashed out with the KERNEL SECURITY CHECK FAILURE...

    I have tried all the usual firmware updates etc.., nothing worked.. We just have 2 x 1TB HDD's in a RAID1 config and the server has the very latest BIOS firmware..

    I'm not sure what to do here other that go back to serversdirect and ask them for the original Windows 2012 Essentials..

    • Edited by CPA-UK Saturday, January 18, 2014 8:00 PM
    Saturday, January 18, 2014 7:31 PM
  • Since it is a new system, yes, you should most likely contact your vendor and have them take care of it.  I would be surprised if the system is not under warranty, in which case it is the vendor's responsibility.

    BTW, it is not a good idea to tag a post onto an old post, especially one that is dealing with a different topic.  The topic of this thread is 2012 R2 preview (last entry two months ago) and your post is about Essentials. Essentials has its own forum -

    .:|:.:|:. tim

    Saturday, January 18, 2014 8:20 PM