locked
Mailbox Move Issue - Mailbox Locked RRS feed

  • Question

  • Hi

    I have tried 3 user mailboxes for local move request.

    It get-moverequest says all three completed.

    Then I cleared the same with Clear-moverequest command.

    Now get-moverequest says none.

    Now if i login with owa, it says mailbox locked for Movement.

    If i try to delete content or once again try to move, it says Mailbox locked by MRS and will be released automatically after 2 hrs.

    but its been more than a day still the error remains the same.

    Restarted all Exchange services.. Restarted Exchange server.. still no hope

    The Exchange console still shows these 3 mailboxes with Old DB name.

    If i query through shell, for Mailboxdb for these users, it shows blank.

    How do i bring back these mailboxes active and make it usable?


    regards Sundaresan.C

    Thursday, January 29, 2015 2:49 PM

Answers

  • This has been resolved now.

    The problem was the movement of mailboxes when the users are accessing it.

    This has gone to a stage where both the database has these users listing. One in Live and other in disconnected state.

    I need to reduce the DB Mailbox retention to Zero -> disable the mailbox -> clean DB -> reconnect the Mailbox to existing user -> Clean DB.

    This made users access their mailboxes with all old mails.

    Lesson learnt: Do not move mailboxes when users accessing it though Microsoft says no issues. It may be locked inbetween.


    regards Sundaresan.C

    Friday, January 30, 2015 8:04 AM