none
There is a scheduling conflict with this particular resource. Therefore, the overallocation cannot be resolved. RRS feed

  • Question

  • Guys,

    I'm struggling here, I setup a Project a week or two ago and I've been opening it daily, it's been fine. Today I've opened it and it's complained that:

    "There is a scheduling conflict with this particular resource. Therefore, the overallocation cannot be resolved."

    However:

    1. I hadn't changed anything when I opened it

    2. All tasks are set to automatically scheduled

    3. All tasks are set to As Soon As Possible, except one milestone task which doesn't have resources associated with it.

    4. Developers are assigned to tasks in 90% capacity, their maximum working capacity is 100%

    5. The project is connected to a resource pool so I can centrally log time off/holidays/sick days etc

    6. No other projects are using these two resources which are causing a problem.

    So... Why isn't Project just moving my development end date on by a day or more and re-scheduling the tasks when they're set to auto schedule?

    I'm a little lost about what I can do next to be honest. My tasks are entered in hours, I changed the levelling options to look for overallocations on an hour by hour basis rather than day by day, that seemed to help a bit but there are still over allocations.

    Any help much appreciated, I've spent the entire morning going round in circles trying to fix it.

    Thanks

    Monday, August 11, 2014 10:25 AM

Answers

  • Rob,

    Well yes, but there's a catch. I forgot to mention that going through the XML route, some custom settings are lost, I don't remember what all is preserved and what it lost. If you want to re-instate custom settings that were lost in the process, you can preserve your custom views, calendars, etc. in a separate file and then use the Organizer to copy them back to your clean new file. However, if one of those items was the source of the corruption, you will be polluting your new file all over again, so use with caution. Note however that custom resource calendars are not visible in the Organizer so to preserve a custom resource calendar, you would need to copy that resource individually from the backup file, but again, it could be corrupt itself.

    John

    • Marked as answer by Rob-R Wednesday, August 13, 2014 8:36 AM
    Monday, August 11, 2014 3:37 PM

All replies

  • Hi rob,

    Your file might be corrupted. Try the XML export method to see if it helps.


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Monday, August 11, 2014 12:16 PM
    Moderator
  • Thanks, I'll give that a look. If it gives any more clues I'm convinced it's down to the resource pool...

    I created a copy of the project and told it to 'use own resources' rather than the pool, it broke the link to the pool but I had a non linked copy of all the resources and their calendars - that allowed for an auto level with no little red men there to cause problems.

    This tells me it's something to do with the link between the resource pool and the project.

    I'm guessing if I do the XML thing then when I connect it up it'll complain because it'll still be using the resource pool and it'll think the original one is using hte pool? - I suppose I can rename the original one before doing it though to prevent this?

    Thanks,

    Rob

    Monday, August 11, 2014 12:26 PM
  • Hmm, I tried that, I renamed the original project to stop it being a project file, I imported the XML into a new project, it seemed to find even more levelling issues and put the end date at some time in December instead  of October, much worse.

    At this point I'm contemplating using the standalone project without the connection to the resource pool - it seems to cause more problems than it's solving.

    Monday, August 11, 2014 12:43 PM
  • Thus I understand that you're using a shared resource pool file? Have you tried to disconnect the project from the resource pool and connect it again?

    http://office.microsoft.com/en-us/project-help/share-resources-using-a-resource-pool-HA010214871.aspx#BM4


    Hope this helps,


    Guillaume Rouyre, MBA, MCP, MCTS |

    Monday, August 11, 2014 12:54 PM
    Moderator
  • Thanks, I just tried that...

    Resource Pool --> Share Resources --> change to 'Use Own Resources'.

    Level and it's fine.

    Connect to 'Use Resources (...) From:

    And it whinges again.

    I tried saving it without the pool connection, closing it and opening it again - the same thing.

    Hmm, it really hates the resource pool :/

    Monday, August 11, 2014 1:48 PM
  • Rob-R,

    As the saying goes "it takes two to tango", and so it is with any linked structure in Project. It's unlikely that just one of the linked structure elements (i.e. pool file and your sharer file) is corrupt. You've tried clearing corruption from your sharer file, now I suggest you either disconnect the pool file from all other sharer files and clear corruption from it, or break all the links and rebuild the resource pool file.

    John

    Monday, August 11, 2014 2:39 PM
  • Hi John,

    I just attempted to rebuild the pool, I then compared the non linked one and one joined to the newly created pool - they had different end dates but no over allocation - then I realised the pool needs a ton of work.

    I saved the original pool as an XML file and tried to import this as a project, it seemed to work but looking now it doesn't have the working times as I'd set them (it has starting at 8am etc) and it doesn't have the global exceptions (Christmas day, Bank Holidays etc), or any resource level exceptions - which explains the earlier date.

    Is there a way to import the original pool xml file and maintain all of this information? - I was just in the process of adding it again when I got disturbed, I have a meeting now I'll pause on it for a while.

    Thanks,

    Rob

    Monday, August 11, 2014 2:54 PM
  • Rob,

    Well yes, but there's a catch. I forgot to mention that going through the XML route, some custom settings are lost, I don't remember what all is preserved and what it lost. If you want to re-instate custom settings that were lost in the process, you can preserve your custom views, calendars, etc. in a separate file and then use the Organizer to copy them back to your clean new file. However, if one of those items was the source of the corruption, you will be polluting your new file all over again, so use with caution. Note however that custom resource calendars are not visible in the Organizer so to preserve a custom resource calendar, you would need to copy that resource individually from the backup file, but again, it could be corrupt itself.

    John

    • Marked as answer by Rob-R Wednesday, August 13, 2014 8:36 AM
    Monday, August 11, 2014 3:37 PM
  • Thanks John, I've manually added 'enough' to the resource pool for now - for three devs and the Summer Bank Holiday, this compared to the 'non linked' one is coming out at 8th October vs 7th October. I'm happy with that, I'll use the one that's 1 day later for safety sake.

    It's been a total pain but I guess I've learnt more about the resource pool today!

    Thanks,

    Rob

    Monday, August 11, 2014 4:09 PM
  • Rob,

    You're welcome and thanks for the feedback. If any of the responses to your post were helpful, please mark as the answer or at least give a vote. You can mark as many responses as you wish. There is often no single right answer.

    John

    Monday, August 11, 2014 4:30 PM
  • Thanks John, finally got round to doing that!

    Resource pool all connected and working again, I'll be careful to rename and move project files - I suspect that was a massive part of it.

    Rob

    Wednesday, August 13, 2014 8:37 AM
  • Rob,

    Again you're welcome. I hope that's a typo in you last statement (i.e. "careful to rename and move project files"). Grammatically that says you are going to rename and move files in the linked structure. I sincerely hope you meant to say, "careful never to rename or more project files".

    John

    Wednesday, August 13, 2014 2:26 PM
  • It was missing the words 'not to'!
    Wednesday, August 13, 2014 2:34 PM
  • Rob,

    Okay, you scared me for a minute there :-)

    John

    Wednesday, August 13, 2014 2:46 PM