locked
Windows 10 mail and Exchange account with a self signed certificate RRS feed

  • Question

  • Hi,

    We use Windows 8.1 phones in our IT development department with an exchange account (our mail server with a self signed certificate).
    We have upgraded two weeks ago all devices to Windows 10 (10.0.10166.0) => All works perfect. 

    Now we had to renew our exchange 2013 certificate. All Windows 10 phone devices and all Windows 10 computers with windows mail can't connect to our mail server anymore. 

    We have deleted the Exchange account on our phones and our computers and recreate the account from scratch. All settings will accepted. The message "certificate is not trusted" we accept as usual. The account is successful created but if I synchronize the account I receive the message that I have to repair the account. If I use the function "repair the account" I have to enter my password again and again and again. I copied the new certificate to the phone but still same behavoir.

    Okay - the windows 10 version on our phones are still a "Insider Preview", but the same problem exist on our official Windows 10 computers with windows mail.

    On all other devices (Phone Windows 8.1, Andriod smartphones, iPhones and Outlook 2013) we haven't any problems.

    For any hint I'm happy! Thanks!



    • Edited by BIRDAN Tuesday, August 18, 2015 2:57 PM
    Thursday, August 13, 2015 12:21 PM

All replies

  • Please try to import new SSL certificate to phone storage. But maybe better way will be using trusted CA SSL certificate.
    Thursday, August 13, 2015 12:42 PM
  • Your new cert is self-signed again?

    Phone: Can you uncheck the option "Server requires encrypted (SSL) connection"?  If so, does it work?

    PC:  Have you imported the new Exchange cert onto the PCs? You can try putting it into either the Trusted Publishers or Trusted Root Certification.


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.

    Thursday, August 13, 2015 12:49 PM
  • We also tried to import the new SSL certificate to phone storage but still the same problem.
    Tuesday, August 18, 2015 2:53 PM
  • Your new cert is self-signed again?
    Yes

    Phone: Can you uncheck the option "Server requires encrypted (SSL) connection"?  If so, does it work?
    Sorry no

    PC:  Have you imported the new Exchange cert onto the PCs? You can try putting it into either the Trusted Publishers or Trusted Root Certification.
    Yes but still the same behavoir

    Tuesday, August 18, 2015 2:56 PM
  • The answer may be like Kazzan said, you may have to buy a 3rd party SSL cert from a trusted CA.

    Looks like Thawte has a 21 day trial for an SSL cert: https://ssl-certificate-center.thawte.com/process/retail/trial_product_selector?uid=cd99de962897aaa3b4eb71ac9b960916&locale=THAWTE_US&language=en


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.



    • Edited by B0ndoo7 Tuesday, August 18, 2015 3:36 PM
    Tuesday, August 18, 2015 3:30 PM
  • I just wrote one solution I found for something like this. Not Exchange... sorry, It was an IMAP/SMTP account, maybe it can help.

    https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-outlook_mail/windows-10-mail-certificate-errors/eed0520a-9de2-4c0c-a1d7-aa0d28fa3fa2

    Luck to all !

    Tuesday, July 18, 2017 11:52 PM