locked
Unable to set media center as default player. RRS feed

  • Question

  • WHEN I PUT A DVD INTO MY DVD PLAYER IT PLAYS IN MEDIA PLAYER NOT MEDIA CENTER? I HAVE TRIED TO CHANGE THE AUTO PLAY AND THE DEFAULT PROGRAM
    Thursday, October 29, 2009 10:58 AM

Answers

  • Hi GCS Gupta, have you installed any third party codec package or player? If so, the default autoplay settings can be changed. I suggest you temporarily remove those third party player and go to Control Panel\All Control Panel Items\AutoPlay and choose "Reset all defaults", press "Save". Then, you can restart the computer and see the result.
    Sean Zhu - MSFT
    • Marked as answer by Sean Zhu - Friday, November 6, 2009 1:53 AM
    Saturday, October 31, 2009 4:38 AM

All replies

  • Hi GCS Gupta, have you installed any third party codec package or player? If so, the default autoplay settings can be changed. I suggest you temporarily remove those third party player and go to Control Panel\All Control Panel Items\AutoPlay and choose "Reset all defaults", press "Save". Then, you can restart the computer and see the result.
    Sean Zhu - MSFT
    • Marked as answer by Sean Zhu - Friday, November 6, 2009 1:53 AM
    Saturday, October 31, 2009 4:38 AM
  • Hi Sean, I apologize for the late response. Thank you for responding for the issue, I have not installed any third party codec, as windows 7 does have many codecs. I have tried the autoplay option, however media center is not an option there.
    Tuesday, November 24, 2009 7:57 PM
  • Exact same problem here. Media center is not an option in under Autoplay and DVD then movie. Windows 7 64 bit fresh install.

    Help


    EDIT
    Found this link and it works for me.

    http://thegreenbutton.com/forums/p/79235/392717.aspx#392717
    It's reg edit that adds the option to the autoplay selections.
    Still have to tell Media center to start when Windows starts and wait till fully booted then insert DVD. That alone may be the fix and you don't even need the reg hack.
    Hope it works for you too.
    Tuesday, December 1, 2009 10:29 PM
  • For some reason Windows Media Center entries are note added to AutoPlay by default. You can do it manually using the REG file here.
    How to Restore Missing Windows Media Center AutoPlay Entries in Windows 7


    The REG fix adds EHomeDVDDropTarget, EHomeMusicDropTarget, EHomePhotosHandler, EHomeSVCDDropTarget, EHomeVCDDropTarget,  EHomeVideosHandler AutoPlay handlers.
    Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]
    Wednesday, December 2, 2009 5:20 AM
    Answerer