locked
MTD and Static IP RRS feed

  • Question

  • I am using MDT 2013 to deploy custom 2008R2 image on a physical servers using CDROM deployment on UEFI machine. We are required to use Static IP. If I wipe out the target disk with diskpart.exe prior to deployment, everything works perfectly. However, otherwise I get the following error: 

    Unable to find the SMs task sequence. The deployment will not proceed 

    I have verified that there are no MININT folders or _SMSTaskSequence folder on C: drive prior to starting deployment and yet the deployment fails unless I clear out the drive completeley by using clean disk command. The reason it cannot find the Task Sequence is it sets IP to DHCP and does not process "Apply Network Settings". I have modified LiteTouch.wsf as well as added "Apply Network Settings" in Task Sequence just like what Johan's blog suggested (http://deploymentresearch.com/Research/Post/367/Fix-for-MDT-2013-offline-media-deployment-bug-Static-IP-addressing)

    Here is the few lines from BDD.Log:

    Property DeploymentMethod is now = UNC LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    DeploymentMethod = UNC LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property DeployRoot is now = C:\MININT LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Using a local or mapped drive, no connection is required. LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    DeployRoot = C:\MININT LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property DeployDrive is now = C: LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    DeployDrive = C: LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Phase = STATERESTORE LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Using a local or mapped drive, no connection is required. LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property DeployDrive is now = C: LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    DeployDrive = C: LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property ResourceRoot is now = C:\MININT LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    DeploymentType = LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    ResourceRoot = C:\MININT LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property ResourceDrive is now = C: LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    ResourceDrive = C: LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property _SMSTSPackageName is now = Lite Touch Installation LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    Property Architecture is now = x64 LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    FindFile: The file TsmBootstrap.exe could not be found in any standard locations. LiteTouch 11/12/2015 11:01:11 AM 0 (0x0000)
    FAILURE ( 5208 ): Unable to find the SMS Task Sequencer.  The deployment will not proceed. LiteTouch 11/12/2015 11:18:45 AM 0 (0x0000)

    I tried adding diskpart.exe clean disk Task Sequence step in Pre-Install phase but it still doesn't work. I have to boot to Litetouch CD and during WinPE boot process press F8 to go to command prompt and clean the disk and then it deploys successfully with correct Static IP.

    Thanks,

    Deepak

    Friday, November 13, 2015 3:08 PM

All replies

  • This is a known issue with MDT 2013.  What would you like help with?

    Logs are very important. https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Mention any customizations you have made.


    • Edited by Ty Glander Friday, November 13, 2015 9:14 PM
    Friday, November 13, 2015 9:13 PM
  • Thanks for the reply. Does that mean that if you have are rebuilding existing Windows machine, you have to manually press F8 in WinPE to go to command prompt and wipe out the disk by using diskpart.exe otherwise the deployment will fail?

    That sounds like a major bug.

    If that is the case, is there a way to automate that part withing Task Sequence? I tried adding diskpart.exe and clean command in Task Sequence in Pre-Install phase but still it has same issue.

    Thanks,

    Deepak


    Monday, November 16, 2015 2:43 PM
  • Sorry, I have doubts on the original post.

    Windows 2008 R2 and uEFI should be a problematic configuration, and I would first investigate to see if the machines are/were running with MBR configurations, if so then failure is expected.

    If you are still encountering errors, please upload your bdd.log file to a public site and share the link.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Tuesday, November 17, 2015 9:31 PM
  • Keith,

    I was using MBR disk. I changed it to GPT and still having issue where it says "Unable to find Task Sequence and it sets NIC Adapter to DHCP instead of static IP address. However, It works perfectly without any change if I wipe out the disk before starting MDT 2013.

    I have uploaded BDD Log file here: BDD.Log

    Thanks,

    Deepak

    Wednesday, November 18, 2015 6:37 PM
  • Sorry, but I still don't see this as a supported configuration, the bdd.log attached is weird too, it does not contain any ztigather sections.

    IF you are still having problems, please copy the bdd.log (with ztigather sections) for the pass and failure case to a public site like onedrive, and share the link.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Wednesday, November 18, 2015 9:45 PM