locked
Can't rename "Documents" library to "Comics", but I can rename it to anything else RRS feed

  • Question

  • So here's what happened:

    I was using my "Documents" library as a shortcut to my comics folder. I did this because I wanted my comics folder to be accessible through the start menu. So I renamed it to "Comics" and all was well. That is, until I installed the windows 7 service pack 1 update. After that, the library was renamed "Documents", and whenever I'd try to change it back to "Comics", it would simply revert after hitting enter. I even tried changing the name through the "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders" registry key, but that didn't work either. Any suggestions?


    Tuesday, March 22, 2011 1:17 AM

Answers

  • Solution: I deleted the desktop.ini file from the Libraries folder (C:\Users\*username*\AppData\Roaming\Microsoft\Windows\Libraries).
    • Marked as answer by JoshBjelovuk Thursday, March 31, 2011 4:50 PM
    Monday, March 28, 2011 10:48 AM

All replies

  • Hi JoshBjelovuk,

    Thanks for the post!

    Did you receive any error message when you fail to rename the Documents?

    I suggset you create a new Library called Comics to check if it works. Then right-click the new library, choose Properties, click Include a folder, then choose the comics folder you want.

    Regards,

    Miya 

     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, March 23, 2011 6:25 AM
  • Hi, thanks for the reply.

    I receive no error message when this happens, it just ends up as "Documents" instead of "Comics". I can create a new library and name it whatever I want, that's not the problem. The reason I initially renamed the Documents library instead of creating a new one is because I wanted my Comics library to be accessible through the start menu, along with the Videos, Pictures, and Music libraries. I can rename to anything else, just not "Comics".

    I'm certain it has something to do with the Service Pack 1 update. I assume during the update, as the Documents library was named "Comics", it sort of amalgamated that name with "Documents", since that's what it expected it to be titled, and now it can't tell a difference. I should point out though, when I do change it to "Comics", it does show up as Comics.library-ms under the registry key I mentioned earlier.


    Wednesday, March 23, 2011 9:27 PM
  • Solution: I deleted the desktop.ini file from the Libraries folder (C:\Users\*username*\AppData\Roaming\Microsoft\Windows\Libraries).
    • Marked as answer by JoshBjelovuk Thursday, March 31, 2011 4:50 PM
    Monday, March 28, 2011 10:48 AM
  • Yes, I had the same problem but when I restored the ini file nothing changed.  What else do I need to do.
    Wednesday, May 22, 2013 5:03 PM