Printer Spooler: Error 2:The system cannot find the file specified RRS feed

  • Question

  • I have recently come across a problem with my computer so that every time I try to install a printer driver on my computer i receive the error message:

    Windows could not start the Spooler service on Local Computer
    Error 2:The system cannot find the specified file

    This occurred about a month ago and I have not been able to print since. I had a Canon MP780 printer already installed but the printer portion of it stopped working, though the scanning portion of it still works. I tried to install the Windows 7 drivers for HP Photosmart C4400 but the keep telling me that there is an error with my printer spooler. I have gone into the spooler properties and everything looks set up right but when I try to manually start it I receive the same message. 

    I am just looking for a fix so that I can print. I don't care how the fix occurs or if I use another program as long as it doesn't effect the rest of my computer and I don't have to pay an arm and leg for a simple fix like Dell and Microsoft want me to do.
    Tuesday, January 19, 2010 7:30 PM

All replies

  • Hi, you may want to try this. If not work ask again.

    1. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
    2. Type the following command, and then press ENTER:
      sfc /scannow
      The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

    This is how to use sfc /scanow http://support.microsoft.com/kb/929833

    Good Luck

    Hope you find the info useful
    Wednesday, January 20, 2010 4:34 PM
  • Did the fix work?  I am having the same issue on my pc.  I've tried everything from the sfc /scannow to uninstalling the enumerator.  I have not had any success.
    Monday, November 29, 2010 3:43 AM
  • Hi Justohelp...

    I've tried your suggestions as well as numerous others and still I can't get the printer spooler to start.  Earlier this year, I installed VPN on my home laptop in order to access my office's network.  I now suspect this has something to do with my problem as the result mentions CB.log (my employer) and says cannot open Maher\Desktop\sfcdetails.txt (my last name and how my office computer is defined).  So, knowing this... do you have any other suggestions?

    Any help is much appreciated!





    Wednesday, December 28, 2011 9:56 PM