none
Resource Time is still 8 hour day when calendar (and schedule) is 7.5 RRS feed

  • Question

  • Please note - cost is no longer a problem, fixed. However the Timesheet Status Ribbon still shows incorrectly. Thanks for any responses.

    Hi All,

    - We have a number of projects

    - We have a calendar based on 7.5 hour days (and Resources and Projects assigned to this calendar)

    - The project have a schedule os 7.5 hours a day and a 37.5 hour week

    - Timesheet Reporting Units (in Server Settings) is set to 7.5 and 37.5

    The problem

    - When a user types in 1d into their timesheet, it records 0.94d rather than 1d.

    - It is then causing problems with the cost (as the day rate is being recorded as 0.94*dayRate rather than 1*dayRate)

    - I am stumped. Only thing I can think of is that we still have the original Project Server Enterprise Calendar which is set to 8 hours a day (but I cannot delete it or edit it)

    Any suggestions?



    • Edited by Lokolo Monday, May 28, 2012 9:05 AM updated problem
    Wednesday, May 23, 2012 8:43 AM

All replies

  • Lokolo --
     
    Open the enterprise Standard calendar for editing and change the working schedule to 7.5 days, Monday through Friday.  As you now know, it is not enough just to change the Hours Per Day and Hours Per Week settings in the Project Options dialog.  You must also change your calendars to match the working schedule shown in the Project Options dialog.  Hope this helps.

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Wednesday, May 23, 2012 12:18 PM
    Moderator
  • Hi,

    Unfortunately this didn't work.

    I have been investigating for a couple of days now to see if anything else has caused it but I am now stumped. Project has 7.5 hours, (including tasks), calendars are 7.5 hours, resources are 7.5 hours.

    Below is the main problem we are having. You can see that I've put in 1d but the Timesheet Status is saying 0.94d (which is 7.5/8). The Server Settings -> Timesheet Settings and Default is also set to 7.5 hours a day.

    Any other ideas?

    Thanks.



    • Edited by Lokolo Friday, May 25, 2012 9:46 AM
    Friday, May 25, 2012 9:46 AM
  • Open the desktop client, and navigate to File > Options > Schedule.  The
    Hours Per Day Setting needs to be set on all projects to remain consistent
    with your calendar settings.
     
     

    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky
    Friday, May 25, 2012 11:22 AM
    Moderator
  • You mean like this? This is what it was already set to.

    Thanks.

    Friday, May 25, 2012 12:20 PM
  • As far as I can see, the only problem is that the Status line is showing .94d.  The actual timesheet grid correctly shows 1d.

    The behavior of the timesheet grid is controlled solely by the Timesheet Reporting Units settings.  Calendars and Project options have nothing to do with it.

    I believe that the behavior of the Status line on the timesheet page is hard-coded to equate 1 day to 8 hours, so when you enter 1 day at 7.5 hours per day, it displays .94 d.  Surely you don't use that line as the basis for billing?  But if you do, and if your people enter time as days or fractions of days, then why is it important to define a day as containing 7.5 hours?  I'm not saying you are wrong, only that I don't understand the model.

    Related to that, I'm not clear on your statement:

    "- It is then causing problems with the cost (as the day rate is being recorded as 0.94*dayRate rather than 1*dayRate)"

    Where is this occurring?


    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn

    Saturday, May 26, 2012 2:58 PM
  • Hi,

    Sorry the cost is no longer a problem, our resources were being set to 8 hours and when putting 1d into their timesheet it would class it as 7.5 hours and therefore charged this amount.

    The only problem that still lies is that Timesheet Status, as you say, it shows 0.94d even if the user enters 1d. Everything now seems to work in the mathematically sense, but we do not want users seeing 0.94d if they've entered 1d (if they've worked 5 days, and recorded 5 days, why would they want to see 4.69d?)

    The next best thing would to remove the status line - is this possible?

    Monday, May 28, 2012 9:00 AM
  • I don't think you can remove the Status Line easily (through configuration).  Have you considered changing the default units in the timesheet to hours instead of days?  That would seem to make most sense, since you have some people for whom one day is 7.5 hours, and others for whom a day is 8 hours.  the common denominator is hours.

    Reid McTaggart – DeltaBahn Vice President
    Blog | Twitter | LinkedIn

    Tuesday, May 29, 2012 12:54 PM