none
How to restore disabled autoruns from command prompt? RRS feed

  • Question

  • Very longtime Autoruns user. I'm not an IT pro but have used (and tweaking) Windows since 1989. I'm fairly conservative in changing settings to regain performance and memory so I don't screw things up, until yesterday it seems.

    Dell Optiplex 7040, Win 10 1903.

    Apparently I disabled something, maybe a driver, or something else, that resulted in Windows not booting with an "Inaccessible Boot Device" error.

    Have gone through the Win 10 troubleshooting but no help. SFC scannow resulted in 100% verification but then said "Windows Resource Protection could not perform the requested operation". I'm 98.9% confident that the problem is not a disk error, corrupted file, MBR, etc. but rather something I unchecked in Autoruns.

    With a USB recovery disk and command prompt I've navigated to the folder where Autoruns is located, a "Data" partition on the HDD.

    It's not clear to me from looking at the command line usage list if this is possible, but, is there anyway I can run Autoruns, from command prompt, with a command to reset everything back to default? Or perhaps some other way restoring what was disabled in Autoruns?

    If it helps, I can remove the HDD and use an adapter to attach it to a working PC. Perhaps I can use Autoruns from the good PC to reset items on the other PC?

    If more info is needed before offering advice let me know.

    Any help is sincerely appreciated.

    Ken
    Monday, April 20, 2020 3:48 PM

All replies

  • If you have ever observed how Autoruns work using Process Monitor, you should already know how it works.

    By example, if a remove the check sign near to a a registry entries,

    You would see Autoruns to create a new Key called AutorunsDisabled under the path where the key we have disabled reside.

    If you want to rollback that change, you can simply export the registry key under AutorunsDisabled, edit the reg file deleting AutorunsDisabled from the path, save the file and add it back, double clicking on it or importing it using regedit

    So, if you are pretty sure your problem is something you disabled go find it using regedit searching for "AutorunsDisabled", and then reapply them back.

    HTH
    -mario

    Tuesday, April 21, 2020 6:50 AM
  • I'm aware of the Autoruns Disabled feature, BUT I cannot start Windows on the affected PC. It won't boot due to Inaccessible Boot Device error. So I'm looking for an alternate way to use Autoruns on the affected PC, thus my question about command prompt usage. OR,

    If I remove and attach the affected HDD to another PC is it possible to use Autoruns, or RegEdit, on the attached HDD to find and fix the disabled item/s?

    Tuesday, April 21, 2020 12:31 PM
  • I don't know if you know how to use Regedit from Windows RE to manipulate the Registry of an offline system.

    There is a tutorial here:

    https://www.wintips.org/how-to-edit-and-modify-registry-offline/

    Tuesday, April 21, 2020 12:32 PM
  • Or use DART.. dart contains all the tool you need to start a PC and access the registry..

    https://docs.microsoft.com/it-it/microsoft-desktop-optimization-pack/dart-v10/

    HTH
    -mario

    Tuesday, April 21, 2020 1:31 PM
  • Click Start, Run, type gpedit. msc and click OK.

    Navigate to User Configuration \ Administrative Templates \ System.

    Double-click the Prevent access to the command prompt.
    Tuesday, April 21, 2020 3:10 PM
  • Unless I'm misunderstanding what I'm reading I'm unable to get DART 10 (Microsoft Desktop Optimization Pack (MDOP)) as I do not have access to MS Volume Licensing.
    Tuesday, April 21, 2020 4:31 PM
  • Click Start, Run, type gpedit. msc and click OK.
    Navigate to User Configuration \ Administrative Templates \ System.
    Double-click the Prevent access to the command prompt.

    Unable to follow your steps because the PC will not boot into Windows. I have access to the command prompt. What would this do to help my situation?

    I tried going to C:\Windows\System32\gpedit.msc via the command prompt but it won't open. Error message says "this file does not have an app associated with it..."

    Thanks
    Tuesday, April 21, 2020 4:57 PM
  • I tried many times today using RegEdit to search and find Autoruns entries. I loaded hive after hive but searches failed to find anything. I did find the program's entry but nothing else. Apparently I wasn't doing something right because I know I changed at least 5-7 items but couldn't remember exactly what they were (I'm old, memory sucks).

    So, did some brainstorming and found this:

    https://pureinfotech.com/restore-registry-backup-windows-10/

    Luckily there was a 4/16 registry backup. Using the instructions in the above link I was able to restore to that and Voila! Back in business.

    Thanks for everyone's input.

    Tuesday, April 21, 2020 9:02 PM
  • Good Morning Ken,<u1:p></u1:p>

    I am getting started using Sysinternals utilities.  I notice you have more than 10 years of experience.  Please keep an eye open for my posts I will try not to ask general questions;  so far I have made a Clean Install on a Win 10 notebook and back-up to USB hard drive. 

    Friday, May 15, 2020 2:19 PM
  • Use either of the following methods:

    Method 1
    Click Startthe Start button , type Gpedit.msc in the Start Search box, and then press ENTER.

    User Account Control permission  If you are prompted for an administrator password or for confirmation, type the password, or click Allow.
    Under Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Autoplay Policies.
    In the Details pane, double-click Turn off Autoplay.
    Click Enabled, and then select All drives in the Turn off Autoplay box to disable Autorun on all drives.
    Restart the computer.
    Method 2
    Click Startthe Start button , type Gpedit.msc in the Start Search box, and then press ENTER.

    User Account Control permission  If you are prompted for an administrator password or for confirmation, type the password, or click Allow.
    Under Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Autoplay Policies.
    In the Details pane, double-click Default Behavior for AutoRun.
    Click Enabled, and then select Do not execute any autorun commands in the Default Autorun behavior box to disable Autorun on all drives.
    Restart the computer.
    Friday, May 15, 2020 2:50 PM