locked
App-V 5 Server installation issue RRS feed

  • Question

  • Hello,

    I am having the error message below when installing App-V server 5 ( the 2 DB roles) on my SQL server . SQL 2008 R2 or SQL 2012 gives me the same error msierrSQLFailedExecString . The account I am using to install App-V has administrative right on the  server, and I ran the app-v setup , by right clicking on the exe, run as administrator.

    Any help would be appreciated. Thanks

    Friday, March 22, 2013 3:50 PM

Answers

All replies

  • Hello,

    Is there any reason you have not shared the log-files, which are indicated in the above screenshot?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, March 22, 2013 3:56 PM
  • Hello, thanks for answering,

    I can totally share the information included in this file:

    Below is the end part of the log where the error message lies:

    MSI (s) (70:C4) [11:22:48:733]: Executing op: ActionStart(Name=ExecuteSqlStrings,Description=ExecuteSqlStrings,)
    MSI (s) (70:C4) [11:22:48:734]: Executing op: CustomActionSchedule(Action=ExecuteSqlStrings,ActionType=25601,Source=BinaryData,Target=**********,CustomActionData=**********)
    MSI (s) (70:24) [11:22:48:736]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI7598.tmp, Entrypoint: ExecuteSqlStrings
    ExecuteSqlStrings:  Error 0x80040e14: failed to execute SQL string, error: Finished login creation phase., SQL key: GrantMachinePermissions SQL string: EXEC dbo.spSetupLogin 0x01050000000000051500000027172C054670A525994A9E3752040000, N'sandbox.cg\ratchet$', 1
    MSI (s) (70!78) [11:22:48:781]: Product: Microsoft App-V Server 5.0.285.0 -- Error 26204. msierrSQLFailedExecString

    CustomAction ExecuteSqlStrings returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (70:C4) [11:22:48:788]: Note: 1: 2265 2:  3: -2147287035
    MSI (s) (70:C4) [11:22:48:788]: User policy value 'DisableRollback' is 0
    MSI (s) (70:C4) [11:22:48:788]: Machine policy value 'DisableRollback' is 0
    Action ended 11:22:48: InstallExecute. Return value 3.

    Friday, March 22, 2013 5:24 PM
  • When installing SQL  all the 5 App-V Server roles ( DB and not DB) on the same server, it works.

    I guess there is a problem to grant permissions to the App-V server machine, when SQL is not the same server , and I have no idea why.

    Friday, March 22, 2013 6:33 PM
  • Hello,

    Did you really execute the DB installations part on the SQL server, even if the other components were remote?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Saturday, March 23, 2013 7:18 AM
  • Yes the error message you see in the first post occurs when I run the App-V server installation on the SQL server, while only installing the 2 DB roles.

    If I choose to install all the roles on the SQL server, it works

    Wednesday, March 27, 2013 7:39 PM
  • Though not directly addressing your issue I usually recommend not using the the setup wizard, but SQL scripts

    http://kirxblog.wordpress.com/2012/11/01/remote-database-preparation-for-app-v-5/



    Falko

    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Thursday, March 28, 2013 7:33 AM
    Moderator