none
ADRMS with multiple versions of Office RRS feed

  • Question

  • We have some clients with Office 2007 and 2010.  We are also beginning to roll out 2013 to some users.

    We currently have AD RMS installed on Server 2008.

    My understanding is that for Office 2013 to work with AD RMS we need the 2012 version.

    What is the best way to upgrade/migrate our existing setup so that all three versions of Office will work with our existing templates?

    I've found walk-throughs for RMS 1.0 to ADRMS 2008 but I can't find anything for 2008 to 2012.  Is it just a matter of upgrading the server to 2012 then running the AD RMS upgrade wizard from the snap-in?  Are there any known issues we should be aware of?

    I know that our Windows 7 clients need to be upgraded to the client version 2.1 and need the hotfix for the new key length (KB 2627273).  Our Windows 8 clients should work as is.

    We still have some older machines running XP that we are planning to upgrade in the near future (before support ends is the goal).  Is there a hotfix for the key length available for XP?

    Thanks in advance


    • Edited by nrickard Friday, January 3, 2014 5:24 PM clarification
    Friday, January 3, 2014 5:22 PM

All replies

  • Hello there, Office 2013 works with RMS server 2008 so you don't need to migrate your RMS servers to support Office 2013 specifically.

    Thanks,

    Gagan


    Gagan Gulati Senior Program Manager, Information Protection Microsoft Corporation

    Tuesday, January 7, 2014 1:17 AM
    Owner
  • Hi Gagan,

    That's great news, I obviously misunderstood what I read.

    That being said, do we need to do anything specific to get it to work?

    We tried both a fresh install and an upgrade from Office 2010, neither would work.

    The fresh install wouldn't connect and prompt for our domain credentials.  This was both with a new file and with existing content.

    The upgrade would say templates were not available so we couldn't apply them or open existing content.

    We also tried both a domain joined and a stand alone workstation, neither worked.

    Thanks

    Tuesday, January 7, 2014 3:26 PM