none
UDShare is using what credentials?, want to use a different location with different creds RRS feed

  • Question

  • What credentails does UDShare use in the customsettings.ini file for MDT 2012?  USMT backup works and stores on the network if I use a share located on the deployment server but if i set the location to a different server and am logged in as a network user i can backup to the selected path but upon image refresh it obviously doesnt have the path mapped and therefore it never restores user data from my custom location.

    Example my deployment share is located on wds.contoso.com.  If i have UDShare=\\wds.contoso.com\backups\userdata it creates the USMT backup just fine.  If i change the UDShare to be \\fs.OTHERDOM.com\userdata.  When I login to the client with a domain user it will backup fine and create usmt data on \\fs.otherdom.com\userdata but when it does its refresh of the image and gets back into windows under the build in administrator account automaticly it tries to restore user data but it never works.  I dont seem to get an error but it never restores any data.

    How can I have a custom path with perhaps a different set of credentails to connect to for the UDShare location?

    Thanks.

    Tuesday, July 30, 2013 8:34 PM

All replies

  • It's using whatever credentials were supplied when the deployment was started or if you provided values in BootStrap.ini with UserID, UserDomain, and UserPassword.  Try specifying those values in your CustomSettings.ini and see if that resolves the connection.  Note that doing this will store it in clear text (or easily decodable text), so you want to use a limited account that only has access to Read the MDT share and then read/write to the USMT Store.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, July 30, 2013 10:52 PM
    Answerer
  • I have another deployment share that is on the same domain and it doesn't work either.  It seems like it is having trouble restoring data from a DFS share although it never gives me an error.  All permissions for the shares are correct since it does backup just fine to the DFS share.  If i run my state restore task sequence to do it manually it seems to backup fine to the DFS share, it just doesn't work when doing a refresh of an image and it seems like it only works automatically when the share is on the same server as the deployment share.

    In the below scenario \\wds.contoso.com\backups\userdata\%ComputerName% works fine but if i switch it to the DFS share on a the production domain at \\productiondomain.intranet\computerbackups it will not auto restore when doing a refresh.  Do I need to specify additional credentails below the UDshare path?

    deploymentshare1

    bootstrap.ini

    deployroot=\\wds.contoso.com\mdtprod$

    UserID=imageinstaller

    UserPassword=SecretPassword

    UserDomain=contoso

    customsettings.ini

    SkipUserData=NO

    UserDataLocation=NETWORK

    UDShare=\\wds.contoso.com\backups\userdata

    UDDir=%ComputerName%

    JoinDomain=productiondomain.intranet

    DomainAdmin=domjoin

    DomainAdminPassword=SecretPassword

    DomainAdminDomain=productiondomain

    Deployment share 2 is as follows

    deploymentshare2

    bootstrap.ini

    DeployRoot=\\wds1.productiondomain.intranet\mdtprod$

    UserID=installuser

    UserPassword=SecretPassword

    UserDomain=productiondomain.intranet

    customsettings.ini

    SkipUserData=NO

    UserDataLocation=NETWORK

    ; UDShare=\\productiondomain.intranet\computerbackups

    UDShare=wds1.productiondomain.intranet\backups\userdata

    UDDir=%ComputerName%

    JoinDomain=productiondomain.intranet

    DomainAdmin=domjoin

    DomainAdminPassword=SecretPassword

    DomainAdminDomain=productiondomain

    Wednesday, July 31, 2013 8:15 PM
  • Does the task sequence fail?  What message do you get when (if) it does?

    Do the USMT logs contain anything useful when doing the loadstate?

    Off the top of my head they are in

    C:\Windows\Temp\DeploymentLogs

    Have a look before you close the summary page and see if the USMT logs provide any insight.

    Wednesday, July 31, 2013 11:04 PM
  • I'd be interested in seeing your ZTIGather.log from the one that works and the one that doesn't.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, August 1, 2013 1:47 AM
    Answerer
  • The task sequence does not fail.  I have a USMTcapture.log file but there is no restore log file.  Searching both ZTIGather.log and USMTcapture.log I dont find loadstate anywhere.

    Neither deployment shares work when I have the UDDir path set to the DFS share at least on state restore.  They both will work when i set the UDDir path to the share on the same box as the deployment share.

    Thursday, August 1, 2013 4:38 PM