none
Sync failed: WSUS update source not found on site 786. Please refer to WCM.log for configuration error details.

    Question

  • Hi,

    I have installed SC 2012 SP1 + SQL Server 2012 CU2e

    I followed the following guide:

    http://www.windows-noob.com/forums/index.php?/topic/4427-using-sccm-2012-rc-in-a-lab-part-2-add-sup-and-wds/

    And when Sync Failed, what could be went wrong?

    I have copied the logs+screenshot, and would be thankful if someone can give expert advise.

    Here is link :  http://sdrv.ms/13kmHBQ

    N.A.Malik

    Tuesday, July 30, 2013 6:48 PM

Answers

  • Hi,

    I haven't tested myself but going to test the following:

    WSUS is bit cranky for now but here is what I did to fix it:

    1) Uninstall SUP role

    2. Uninstall WSUS

    4. Delete SUSDB from SQL Server if any

    5. Restart Server

    6. Install WSUS (Chose to install DB not WID)

    7. Configured Updates to be stored locally

    8. Run Post Deployment Configuration from Server manager

    9. Started WSUS Admin Console and ran Wizard (also chose to connect for the catalog sync) up to the Point where you select the products. Here I canceled the wizard without choosing any products

    10. Install SUP role in SCCM and configure the right Settings (WSUS on Server 2012 Defaults to its own admin Website and ports 8530 and 8531) and select the products you required.

    11. Check following log file if WSUS does not sync with SCCM.

    Path: C:\Program Files\Microsoft Configuration Manager\Logs

    File Name:

    WCM.log
    wsyncmgr.log

    12.) Starts synchronization in the sccm console

    Source: http://robiulislam.wordpress.com/2013/04/12/sccm-2012-installation/


    N.A.Malik

    • Proposed as answer by Alamaz Tuesday, November 05, 2013 10:56 PM
    • Marked as answer by N A Malik Wednesday, November 06, 2013 8:25 AM
    Tuesday, September 17, 2013 8:13 AM

All replies

  • It looks from your screenshot like you have it set to use an upstream WSUS server.  Was that intentional?  The walk through was supposed to have you syncronizing from Microsoft Update.

    I hope that helps,

    Nash


    Nash Pherson, Senior Systems Consultant
    Now Micro - My Blog Posts
    <-- If this post was helpful, please click "Vote as Helpful".

    Tuesday, July 30, 2013 9:56 PM
  • Hello Nash!

    Thanks for reply.

    It wasn't intentional. When setting up SUP role, I selected "Sync from Microsoft" and still it selected WSUS upstream, and I left it as it.

    When I checked it now, Microsoft Sync is selected.
    And PORTS option are as follows:
    port 8530/8531

    And the result is the same.

    Read SUPs from SCF for OSDServer.konfig.local
    Found 1 SUPs
    Found active SUP OSDServer.konfig.local from SCF File.
    DB Server not detected for SUP OSDServer.konfig.local from SCF File. skipping.   DB Server not detected for SUP OSDServer.konfig.local from SCF File. skipping.
    Sync failed: WSUS update source not found on site 786. Please refer to WCM.log for configuration error details.. Source: getSiteUpdateSource    SMS_WSUS_SYNC_MANAGER    8/1/2013 12:06:02 AM    4488 (0x1188)


    • Edited by N A Malik Thursday, August 01, 2013 7:04 AM
    Wednesday, July 31, 2013 6:03 AM
  • Hello Nash!

    Thanks for reply.

    It wasn't intentional. When setting up SUP role, I selected "Sync from Microsoft" and still it selected WSUS upstream, and I left it as it.

    When I checked it now, Microsoft Sync is selected.
    And PORTS option are as follows:
    port 8530/8531

    And the result is the same.

    Read SUPs from SCF for OSDServer.konfig.local
    Found 1 SUPs
    Found active SUP OSDServer.konfig.local from SCF File.
    DB Server not detected for SUP OSDServer.konfig.local from SCF File. skipping.   DB Server not detected for SUP OSDServer.konfig.local from SCF File. skipping.
    Sync failed: WSUS update source not found on site 786. Please refer to WCM.log for configuration error details.. Source: getSiteUpdateSource    SMS_WSUS_SYNC_MANAGER    8/1/2013 12:06:02 AM    4488 (0x1188)



    I have exactly the same error messages ...
    Friday, September 06, 2013 8:41 AM
  • Hi,

    I haven't tested myself but going to test the following:

    WSUS is bit cranky for now but here is what I did to fix it:

    1) Uninstall SUP role

    2. Uninstall WSUS

    4. Delete SUSDB from SQL Server if any

    5. Restart Server

    6. Install WSUS (Chose to install DB not WID)

    7. Configured Updates to be stored locally

    8. Run Post Deployment Configuration from Server manager

    9. Started WSUS Admin Console and ran Wizard (also chose to connect for the catalog sync) up to the Point where you select the products. Here I canceled the wizard without choosing any products

    10. Install SUP role in SCCM and configure the right Settings (WSUS on Server 2012 Defaults to its own admin Website and ports 8530 and 8531) and select the products you required.

    11. Check following log file if WSUS does not sync with SCCM.

    Path: C:\Program Files\Microsoft Configuration Manager\Logs

    File Name:

    WCM.log
    wsyncmgr.log

    12.) Starts synchronization in the sccm console

    Source: http://robiulislam.wordpress.com/2013/04/12/sccm-2012-installation/


    N.A.Malik

    • Proposed as answer by Alamaz Tuesday, November 05, 2013 10:56 PM
    • Marked as answer by N A Malik Wednesday, November 06, 2013 8:25 AM
    Tuesday, September 17, 2013 8:13 AM
  • Thanks alot saved me alot of time 
    Tuesday, November 05, 2013 10:57 PM
  • Make sure you use port 8530 in the SUP Properties

    • Proposed as answer by Mike Bergin Wednesday, March 26, 2014 4:07 AM
    Wednesday, December 11, 2013 6:22 PM
  • Hello Nash!

    Thanks for reply.

    It wasn't intentional. When setting up SUP role, I selected "Sync from Microsoft" and still it selected WSUS upstream, and I left it as it.

    When I checked it now, Microsoft Sync is selected.
    And PORTS option are as follows:
    port 8530/8531

    And the result is the same.

    Read SUPs from SCF for OSDServer.konfig.local
    Found 1 SUPs
    Found active SUP OSDServer.konfig.local from SCF File.
    DB Server not detected for SUP OSDServer.konfig.local from SCF File. skipping.   DB Server not detected for SUP OSDServer.konfig.local from SCF File. skipping.
    Sync failed: WSUS update source not found on site 786. Please refer to WCM.log for configuration error details.. Source: getSiteUpdateSource    SMS_WSUS_SYNC_MANAGER    8/1/2013 12:06:02 AM    4488 (0x1188)


    Really weird, just had the exact same issue.

    I set changed the setting of the SUP to synchronise from an upstream data source then changed it back to synchronise from Microsoft update and it's now sync'ing

    Sunday, June 15, 2014 8:05 PM
  • I set changed the setting of the SUP to synchronise from an upstream data source then changed it back to synchronise from Microsoft update and it's now sync'ing
    I had the same issue but I followed your advice (changing datasource) and now it's syncing. Thanks alot !
    • Proposed as answer by BoxiKG Tuesday, November 18, 2014 12:52 AM
    Wednesday, August 20, 2014 2:06 PM
  • Too many bugs for novice to solve. Who would think this is cause of an error based on any logic?
    Tuesday, November 18, 2014 12:55 AM
  • Hi Last couple of days I had got same error. I was followed same instruction as given above but no luck, still have get same error in WCM.log and Wsyncmgr.log files. But according the WSUSCTRL.log file it says "Successfully connected to local WSUS server" Please suggest other steps to resolve the issue, Thanks in advance.

    Regards, Md Ehteshamuddin Khan All the opinions expressed here is mine. This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    Friday, January 29, 2016 7:08 AM
  • Hello,

    I saw I had set an account in the "Proxy and account settings", in "Use credentials to connect to the WSUS server", I cleared it, tried again and that's ok now, following the Wsyncmgr and WCM logs files under "\Program Files\Microsoft Configuration Manager\Logs"

    I hope this been informed for you.

    Regards,

    • Edited by Manolo59 Monday, February 08, 2016 11:25 AM Bad english !
    Monday, February 08, 2016 11:15 AM
  • Hello,

    I saw I had set an account in the "Proxy and account settings", in "Use credentials to connect to the WSUS server", I cleared it, tried again and that's ok now, following the Wsyncmgr and WCM logs files under "\Program Files\Microsoft Configuration Manager\Logs"

    I hope this been informed for you.

    Regards,


    That was a good catch and removing that account solved it for me thanks.
    Thursday, April 14, 2016 7:03 PM
  • Hello,

    Thank you! It worked for me too. I guess this checkbox is useful when you sync from a WSUS of your own which need authentication.

    If you sync from windows update it's worth nothing and cause trouble.

    Regards

    Friday, December 23, 2016 5:55 PM
  • Hello, It's an old article, but I get the same error and just wanted to leave an advice for anyone getting the same error : install the feature windows update on the SCCM 2012 / 1511 / 1602 / 1607 / 1702. After a week of research and uninstalling and reinstalling it solved my problem.

    Br,

    Friday, April 21, 2017 2:25 PM