locked
Disable the 'Opening Mail Attachment' dialogue from Outlook system wide RRS feed

  • Question

  • Hi there - I want to disable this pop up in Outlook:

    (it won't let me add a picture, but its the 'Opening Mail Attachment' dialogue which says 'You should only open attachments from a trusted source' and has a greyed out tickbox at the bottom for 'Always ask before opening this type of file')

    There are many posts describing how to disable this per user by running Outlook as administrator and unticking the box - but I am hoping to find a way to disable this for a large number of users at one time (e.g. a registry key or something), without having to give them all local admin rights to untick this box, or going around logging in to do it for potentially thousands of users.

    The reason for this is that this dialogue seems to cause an intermittant issue where users can't click links to shared network locations in emails (outlook says it cant find the file path even though it is correct). This issue seems to go away if you disable this pop up, and I need to do that for a large group of users.  Thanks All

    

    Sunday, February 9, 2020 7:35 PM

Answers

  • Hi ,

    What's the version of your Outlook? (File > Office Account > About Outlook). Please make sure you have upgraded your Outlook to the latest version.

    >> but its the 'Opening Mail Attachment' dialogue which says 'You should only open attachments from a trusted source'
    As a common method to this pop up, like you mentioned, we can run outlook as administrator and open the attachments, removing the check from "Always ask before opening this type of file" box to solve it.

    I researched a lot but failed to find a way to modify your issue for a large number of users at the same time. 
    However, here is a workaround for similar issues with attachments of other format. Since I cannot reproduce this problem, the accuracy of this method cannot be guaranteed.
    (Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)
    (Please Note: Serious problems can occur if you modify the registry incorrectly. Before making changes, back up the registry to restore it in case something goes wrong.)

    Any update, please feel free to post back.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, February 10, 2020 10:16 AM

All replies

  • Hi ,

    What's the version of your Outlook? (File > Office Account > About Outlook). Please make sure you have upgraded your Outlook to the latest version.

    >> but its the 'Opening Mail Attachment' dialogue which says 'You should only open attachments from a trusted source'
    As a common method to this pop up, like you mentioned, we can run outlook as administrator and open the attachments, removing the check from "Always ask before opening this type of file" box to solve it.

    I researched a lot but failed to find a way to modify your issue for a large number of users at the same time. 
    However, here is a workaround for similar issues with attachments of other format. Since I cannot reproduce this problem, the accuracy of this method cannot be guaranteed.
    (Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)
    (Please Note: Serious problems can occur if you modify the registry incorrectly. Before making changes, back up the registry to restore it in case something goes wrong.)

    Any update, please feel free to post back.

    Regards,

    Aidan Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, February 10, 2020 10:16 AM
  • Thanks for that. Unfortunately the same issue is occurring across all versions of Outlook I have tried (I was hoping that Office 2019 would solve the issue I was having but  unfortunately it remains).

    The workaround you found looks promising though - it's exactly what I was searching for.

    Monday, February 10, 2020 9:03 PM
  • Hi ,

    I’m glad to see that the workaround is helpful to you. If there any update about this issue released, I will post here.

    By the way, would you mind marking my reply as answer so that others who might have a similar question can benefit from your thread? Thanks for your understanding and support.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, February 11, 2020 9:45 AM
  • Hi,

    I'm glad to see your issue has been fixed.

    Here I will provide a brief summary of this post for your information. This will make answer searching in the forum easier!

    Request/Expectation:

    Disable the 'Opening Mail Attachment' dialogue from Outlook system wide

    Solution Summary:

    Here is a workaround for similar issues with attachments of other format.

    (Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)
    (Please Note: Serious problems can occur if you modify the registry incorrectly. Before making changes, 
    back up the registry to restore it in case something goes wrong.)

    Reference Links:

    https://www.slipstick.com/problems/disable-always-ask-before-opening-dialog/


    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Sunday, March 1, 2020 4:43 AM
  • Thank you
    Sunday, March 1, 2020 11:43 AM