locked
AppV5: AutoCAD 2015 exception when starting RRS feed

  • Question

  • Good Morning:

    I am attempting to sequence AutoCAD 2015 using the recipe from Tim Mangan located here. I am having some problems with the end result and I was looking for some assistance.

    In Step 12, I have adjusted the VFS configuration and set "Merge with local" on the enu folder (and all of it's parents).  When launching the application, I do end up with two DLL files in this folder:

    • AcLivePreviewContent.dll
    • ContextualTabSelectorRules.dll

    When the application launches, I am presented with an exception:

    Unable to cast object of type 'Autodesk.AutoCAD.LivePreview.PreviewRuleProvider' to type 'Autodesk.AutoCAD.Internal.IPreviewContextProvider'. 

    After clearing the error, the application seems to work.  I am not fluent in the application, so there may be some features not working correctly, but it seems to be fine.  It also seems like the error is related to the AcLivePreviewContent.dll file that gets written to the profile folder.

    After clearing the error, the following error is displayed in the autocad program at the bottom:

    Command: Cannot load assembly. Error details: Autodesk.AutoCAD.Runtime.Exception: eDuplicateKey
       at Autodesk.AutoCAD.Runtime.CommandClass.AddCommand(ICommandLineCallable ca, MethodInfo mi)
       at Autodesk.AutoCAD.ApplicationServices.AutoCADApplicationHolder.Initialize(Assembly assembly)

    Has anyone seen this error and been able to resolve it?

    Thanks for any help!  And if you see this, Tim, thanks for the initial recipe!

    Friday, January 2, 2015 3:21 PM

Answers

All replies

  • Did you do the advanced checkboxes in step 13?  Not sure if needed but remember that I did it.  That sounds like a COM error.  You can externally check the settings in your DeploymentConfiguratin.xml file to determine.

    I would assume some changes I the preq parts from what I wrote if you sequence with SP3 since you now have .NET 4.5.1 on the base image due to the newer sequencer.

    Note:

    The next version of AppV_Manage (3.11; due out later this week or next) will aid in tracking what type of COM (in-process or out-of-process).  It is possible that manual editing of the deploymentconfiguration.xml file is needed to set InProcess to true, but I doubt that is the issue.

    Tim


    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Sunday, January 18, 2015 2:14 PM
    Moderator
  • I did check the 3 boxes.  In fact, I tried both with and without.

    With some of the errors that it was throwing, it was almost like it was seeing inside and outside the sandbox, and then trying to load the DLLs that it dumps to your profile twice.  I even tried putting these DLLs in the program files directory to stop it from looking in the profile at all, but that didn't work.

    Monday, January 19, 2015 5:53 PM
  • Hello,

    Have you verified that the application is looking for the DLL-files at the location you placed them?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, January 23, 2015 4:40 PM
  • I'm facing same issue with a different software. No problem when sequencing, but when running the published application the application is presenting me with this error:

    +++++++++++++++

    Unable to cast object of type
    'Unik.BoligX.Client.WinForms.Plugins.Initialize.BoligXApplicationInitializeUIPlugin' to type 'Unik.BoligX.Client.WinForms.Plugins.Initialize.IBoligXApplicationInitializeUIPlugin'

    +++++++++++++++

    some of the application is working fine, but other parts are not working.

    however, this does only occure on clients which is running SP3 of the App-v client, computers running the SP2 version of App-v Client does not have this error and the application is working without errors. (the package is sequenced on sp3)

    Monday, April 27, 2015 9:05 AM
  • Was a solution ever found for this. I have the exact same error. I tried merging the folder with the local directory and not having the files in the package, I tried adding the files into the package without a merge. I can't seem to get rid of this error...

    The post marked as answer is not helpful. 


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer".


    Sunday, May 24, 2015 12:49 AM
  • No, I never did find a solution.  I still have Autocad installed natively.  
    Sunday, May 24, 2015 12:54 AM
  • Thanks for the quick update Joe.

    Hum... Maybe I can script these files to be added to the non virtual folder on package launch. I will update this post with any progress I make.


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer".

    Sunday, May 24, 2015 12:59 AM
  • And now I am banging my head against this issue when trying to run a script. Unfortunately we need to do users based targeting too...

    http://www.tmurgent.com/TMBlog/?p=1857


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer".


    Monday, May 25, 2015 12:30 AM
  • "The application failed to launch", isn't that because your script returns non zero exit code? - have you tried to set the RollbackOnError to false?
    Monday, May 25, 2015 6:45 PM
  • Made no difference... same error.


    If you found this post helpful, please give it a "Helpful" vote. If it answered your question, remember to mark it as an "Answer".

    Tuesday, May 26, 2015 1:58 AM
  • I assisted a colleague of mine with this same issue for AutoCAD 2015 LT. What I ended up doing was to install the app on the sequencer, launched the sequencer after and then browsed through the tree to the enu folder. Right click the enu folder and select Add. With that said, if you follow Tim's recipe, all you need to do is browse the tree for the enu folder, right click and select merge with local but you need to do that back up the tree to the parent (yellow) folders and you shouldn't have an issue with the dll files.

    What I am running into is an APPCRASH on the client side at first initialization and I have not been able to figure out why. Been banging my head against the wall for 4 days now!

    Tuesday, July 28, 2015 7:42 PM