locked
SharePoint 2016 MIM Synchronization Installation RRS feed

  • Question

  • I am trying to install MIM 2016 Synchronization service and configure User Profile Synchronization. I have installed MIM 2016 SP1. When I run the SharePointSync.psm1 script to configure User Profile Service, I get the following error:

    "SharePoint Sync requires MIM PowerShell version 4.3.2064 or greater (this version is currently installed: 4.4.1237.0.
    Please install the latest MIM hotfix"

    I downloaded the hotfix-rollup-package-build-4.3.2064.0 from https://support.microsoft.com/en-us/help/3092179/hotfix-rollup-package-build-4.3.2064.0-is-available-for-microsoft-identity-manager-2016. When I try to run the FIMSyncService_x64_KB3092179msp, I get the following error:

    "The upgrade patch cannot be installed the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists  on your computer and that you have correct upgrade patch"

    Is this hotfix required? If yes, how do I install it?

    Monday, April 24, 2017 4:16 PM

All replies

  • Hi shankze,

    Your current version of the MIM is 4.4.1237.0, it is greater than version 4.3.2064.0. We cannot install the pervious hotfix.

    This issue is caused by the following if/else block in the SharePointSync.psm1. It checks the current version of MIM is greater than or equal to 4.3.2064.

    if ($MimPowerShellModuleAssembly.VersionInfo.ProductMajorPart -eq 4 -and
    
                    $MimPowerShellModuleAssembly.VersionInfo.ProductMinorPart -eq 3 -and
    
                    $MimPowerShellModuleAssembly.VersionInfo.ProductBuildPart -ge 2064)
    
    {
    
                    Write-Verbose "Sufficient MIM PowerShell version detected (>= 4.3.2064): $($MimPowerShellModuleAssembly.VersionInfo.ProductVersion)"
    
    }
    
    else
    
    {
    
                    throw "SharePoint Sync requires MIM PowerShell version 4.3.2064 or greater (this version is currently installed: $($MimPowerShellModuleAssembly.VersionInfo.ProductVersion). Please install the latest MIM hotfix."
    
    }


    Change it to the following code for checking the current version is greater than or equal to 4.4.1237 version:

    if ($MimPowerShellModuleAssembly.VersionInfo.ProductMajorPart - eq 4 – and $MimPowerShellModuleAssembly.VersionInfo.ProductMinorPart - eq 4 – and $MimPowerShellModuleAssembly.VersionInfo.ProductBuildPart - ge 1237) { Write - Verbose "Sufficient MIM PowerShell version detected (>= 4.4.1237): $($MimPowerShellModuleAssembly.VersionInfo.ProductVersion)" }

    else { throw "SharePoint Sync requires MIM PowerShell version 4.4.1237 or greater (this version is currently installed: $($MimPowerShellModuleAssembly.VersionInfo.ProductVersion). Please install the latest MIM hotfix." }


    Here is a blog explains this issue:

    https://social.technet.microsoft.com/wiki/contents/articles/37525.install-and-configure-microsoft-identity-manager-2016-sp1-for-sharepoint-server-2016.aspx

    Best Regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, April 27, 2017 7:50 AM
  • Hi shankze,

    Did you resolved this PowerShell issue?

    If you think the post is helpful, please mark it as the answer.

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, May 10, 2017 11:47 AM