locked
Outlook and Exchange 2007 Prompting for Authentication RRS feed

  • Question

  • I have been working on this issue for several days now and I have now figured it out.  I have a client that has an Exchange 2007 server that is also his AD and CAS server.  I know best practices is not on the same server but thats another case. 

    When users open Outlook 2007, they are prompted for authentication to the Exchange server.  If you cancel it, mail still comes and goes.  Im not sure what it's authenticating to because the mail works either way.  I have checked the authentication on the IIS virtual directories and all are defaulted. 

    Thursday, June 14, 2012 5:25 PM

Answers

  • I have been working on this issue for several days now and I have now figured it out.  I have a client that has an Exchange 2007 server that is also his AD and CAS server.  I know best practices is not on the same server but thats another case. 

    When users open Outlook 2007, they are prompted for authentication to the Exchange server.  If you cancel it, mail still comes and goes.  Im not sure what it's authenticating to because the mail works either way.  I have checked the authentication on the IIS virtual directories and all are defaulted. 

    I assme the default settings match the article below:

    http://blogs.technet.com/b/exchange/archive/2008/02/01/3404755.aspx

    If the issue continues, create a new Windows profile and then try again.

    Hope it is helpful.


    Fiona Liao

    TechNet Community Support

    Friday, June 15, 2012 7:15 AM
    Moderator

All replies

  • Hi,

    Check IIS Settings under Autodiscover properties> Directory Security> Authentication Methods> Check "Integrated Windows Authentication" and try again


    Regards from www.windowsadmin.info | www.blog.windowsadmin.info

    Thursday, June 14, 2012 5:31 PM
  • I went into IIS>Autodiscovery>Directory Security>Authentication Methods>Integrated Windows Authentication was checked and so was basic.  Ran iisreset.  Same problem.  Went back in and removed Basic Authentication, ran iisreset.  Same problem.

    Ran test autodiscovery test from outlook 2007 and this is the output.

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>Frank Gonzalez</DisplayName>
          <LegacyDN>/o=Tanner Engineering/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=frank</LegacyDN>
          <DeploymentId>c6b4631c-15c0-4c16-86a0-7ca404039fb8</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <Protocol>
            <Type>EXCH</Type>
            <Server>teserver.TE.local</Server>
            <ServerDN>/o=Tanner Engineering/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=TESERVER</ServerDN>
            <ServerVersion>720280B0</ServerVersion>
            <MdbDN>/o=Tanner Engineering/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=TESERVER/cn=Microsoft Private MDB</MdbDN>
            <PublicFolderServer>teserver.TE.local</PublicFolderServer>
            <AD>teserver.TE.local</AD>
            <ASUrl>https://teserver.te.local/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://teserver.te.local/EWS/Exchange.asmx</EwsUrl>
            <OOFUrl>https://teserver.te.local/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://teserver.te.local/UnifiedMessaging/Service.asmx</UMUrl>
            <OABUrl>https://teserver.te.local/OAB/5ec45b51-7fce-4318-8e60-58e5b525c8a4/</OABUrl>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>mail.tannerengineering.com</Server>
            <SSL>On</SSL>
            <AuthPackage>Ntlm</AuthPackage>
            <ASUrl>https://mail.tannerengineering.com/ews/exchange.asmx</ASUrl>
            <EwsUrl>https://mail.tannerengineering.com/ews/exchange.asmx</EwsUrl>
            <OOFUrl>https://mail.tannerengineering.com/ews/exchange.asmx</OOFUrl>
            <OABUrl>https://mail.tannerengineering.com/OAB/5ec45b51-7fce-4318-8e60-58e5b525c8a4/</OABUrl>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <External>
              <OWAUrl AuthenticationMethod="Fba">https://mail.tannerengineering.com/owa</OWAUrl>
              <Protocol>
                <Type>EXPR</Type>
                <ASUrl>https://mail.tannerengineering.com/ews/exchange.asmx</ASUrl>
              </Protocol>
            </External>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic, Ntlm, WindowsIntegrated">https://teserver.te.local/owa</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://teserver.te.local/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
          </Protocol>
        </Account>
      </Response>
    </Autodiscover>

    Thursday, June 14, 2012 6:31 PM
  • Set your client authentication method to NTLM for your Outlook Anywhere configuration. Look under Server Configuration > Client Access > Properties of your CAS server > Outlook Anywhere tab

    Thursday, June 14, 2012 9:11 PM
  • SeCkCeY,

    First, are the clients connecting to the server locally (from within the LAN) and not through the Internet?

    Second, do you even use Outlook Anywhere? Is it enabled?

    If you cancel it, mail still comes and goes.  Im not sure what it's authenticating to because the mail works either way.

    Try downloading just the OAB. Does it prompt you for that? Try just email. Various options can be found here:

    http://2.bp.blogspot.com/_Et8JSdJ9bVo/Szh8yngJhGI/AAAAAAAAAGA/3eTw2wUyD1c/s400/outlook.JPG

    By process of elimination, you should be able to determine what is triggering the authentication prompt.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, June 14, 2012 11:25 PM
  • I have been working on this issue for several days now and I have now figured it out.  I have a client that has an Exchange 2007 server that is also his AD and CAS server.  I know best practices is not on the same server but thats another case. 

    When users open Outlook 2007, they are prompted for authentication to the Exchange server.  If you cancel it, mail still comes and goes.  Im not sure what it's authenticating to because the mail works either way.  I have checked the authentication on the IIS virtual directories and all are defaulted. 

    I assme the default settings match the article below:

    http://blogs.technet.com/b/exchange/archive/2008/02/01/3404755.aspx

    If the issue continues, create a new Windows profile and then try again.

    Hope it is helpful.


    Fiona Liao

    TechNet Community Support

    Friday, June 15, 2012 7:15 AM
    Moderator