MDT auto chooses x86 boot image


  • After setting up a test MDT server to familiarize myself with how MDT works, I was able to choose the boot image to load, x86 or x64.  I have now setup a production MDT server, I am using the same physical workstations to build my image but MDT auto chooses the x86 boot image that I've imported into WDS.  Is there a setting somewhere that I've enabled to make this happen?  This does make for less key pressing for me, I'm just wondering why this is happening given both boot images are in WDS.
    Tuesday, June 19, 2012 3:27 PM

All replies

  • Do you have this configured by any chance?

    Tuesday, June 19, 2012 3:33 PM
  • No, my Boot page looks just like your screenshot.
    Tuesday, June 19, 2012 3:36 PM
  • Why don't you configure the default boot image value in wds properties then? All this does is actually make sure that specific image is highlighted when pxe-booting, it won't boot right into it (not for 30sec that is).

    Kind regards,

    Stephan Schwarz.

    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    How to configure Windows RE/OEM Recovery Partition with MDT

    Tuesday, June 19, 2012 6:15 PM
  • I have tried your suggestion Stephan and even still the x86 boot image is downloaded automatically on a machine I know supports x64.
    Tuesday, June 19, 2012 6:50 PM
  • Can you try running this command on your WDS box:

       WDSUTIL /set-server /architecturediscovery:yes

    Tuesday, June 19, 2012 7:24 PM
  • I ran it and "The command completed successfully"
    Tuesday, June 19, 2012 7:26 PM
  • And do you get a boot menu now?
    Tuesday, June 19, 2012 7:29 PM
  • Still no menu.  Is there something I need to do after running this command, akin to updating the deployment share in MDT?
    Tuesday, June 19, 2012 7:31 PM
  • Perhaps restart the WDS service. If that doesnt work then the only other thing I could suggest is that you delete your existing WDS images and re-import them again just in the unlikely event that something broke during the import.
    Tuesday, June 19, 2012 7:39 PM
  • Just i suggestion, but is none of the boot images in WDS disabled?

    When i have two boot images, but one is disabled, WDS picks the other one automaticly. And since there's only 1 active boot image, WDS directly boots from that image.

    WDS->Boot Imagines->Right click on the appropiate boot image->disable or enable
    • Edited by Roel_85 Wednesday, June 20, 2012 11:41 AM
    Wednesday, June 20, 2012 11:38 AM
  • Thanks for the idea Roel, but both images are enabled.  I just tried deleting the contents of the deploymentshare\boot directory, recreating it and reimporting just the x64 image into WDS.  Then, without the x86 image, my client comes to the error 0xc0000098 screen.  I have verified in the registry that architecture detection is enabled. 
    Wednesday, June 20, 2012 1:41 PM
  • Is there a pressing need for the x64 boot image? If you're using MDT 2012, you don't really need a 64-bit boot image. If you're using 2010 or some other version then, yes, you'll need it to deploy 64-bit OS images.

    -Nick O.

    Wednesday, June 20, 2012 2:33 PM
  • I'm using MDT 2012 and I have been using the x86 boot image so far without issue, I just don't understand why it worked in the test environment and not now in this production environment with, as far as I can find, the exact same server config (though a different physical server) and same physical clients.
    Wednesday, June 20, 2012 3:51 PM
  • Cross platform/architecture deployments only work for Windows 7 and Server 2008R2, if you still have reason to deploy lower versions of Windows in x64 bit you will need a 64-bit boot image.

    Another reason can be that you want to avoid seeing too many TS's per boot image.

    @jwall04. Can you reproduce this error on for example a virtual machine too? Or is this specific to 1 model of pc's that you have?

    Kind regards,

    Stephan Schwarz

    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCC.
    How to configure Windows RE/OEM Recovery Partition with MDT

    Wednesday, June 20, 2012 3:51 PM
  • Ok, we'll never deploy pre-Win7 in x64, but it still bothers me. 

    I am able to reproduce this issue with another model of physical workstation and also a vm.

    Wednesday, June 20, 2012 4:22 PM
  • Out of curiosity, what hardware are we talking about here? I don't see it mentioned anywhere.
    Wednesday, June 20, 2012 4:31 PM
  • I have this issue with Acer Veriton s480G and Veriton s461
    Wednesday, June 20, 2012 5:52 PM