Windows 10 version 1607 build 14393.10 RWW error 50331656 RRS feed

  • Question

  • After just upgrading to the Windows 10 anniversary update RWW no longer work on ANY SBS 2008 server.

    • I have all the sites in compatibility view
    • All site are added to trusted sites
    • Certificates are fine.

    I checked this registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters
    and neither of the values below were there.  via this post,


    X509 Certificate
    X509 Certificate ID

    THis is not a connection issue.  This is happening on 5 different servers.

    Nothing is wrong with the TS Gateway on any of the servers.

    This immediately started after the Anniversary Update

    What did this Anniversary Update break?!?!?

    Thursday, August 4, 2016 2:08 AM

All replies

  • Hi,

    I want to confirm with you that if this the error 50331656 happens when try to remotely connect to Windows 10(has the anniversary update installed) via RWW.

    If so, and the problematic Windows 10 is SBS domain joined client with Connector. I would recommend you to re-connect the client to SBS and check the result:
    Uninstall the Connector – unjoin the computer from domain – remove the computer from Dashboard.

    If the problem persists, any event has been logged in event viewer? 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 4, 2016 8:39 AM
  • Hello,

    The error #50331656 is correct.

    This error is happening when an off-site Windows 10 Anniversary Updated (non domain) computer tries to remotely connect to the SBS 2008 server computer.

    (This worked just fine right before the windows 10 computer was updated to version 1607.)

    I can login to the SBS 2008 website and when I click on "connect to server" I get the pop up to choose to use the clipboard and/or printers and when I click on Connect I get the error.

    • Edited by Daryl Zero Thursday, August 4, 2016 12:10 PM eidt
    Thursday, August 4, 2016 12:05 PM
  • I have connected to an SBS 2008 using RDP Gateway (2008)

    Same system failed using RWW.

    So must be an issue with the code on the RWW page, will see if i can find out why.

    Robert Pearman Cloud & Datacentre MVP
    @titlerequired | LinkedIn | Google+
    Facebook | Windows Server Essentials.com

    Friday, August 5, 2016 4:20 PM
  • Friday, August 5, 2016 5:35 PM
  • I had that workaround in place already.  Still doesn't work.
    Friday, August 5, 2016 6:58 PM
  • If you are the admin of these various machines I would bypass RWW and use RDgateway. 

    In your RDP, click on the last tab, click on advanced, in the Rdgateway setting enter the url of RWW as the Rdgateway entry.  Then in the RDP first tab put the server name and in user put in domain\user.

    The reality is that this product (SBS 2008) is no longer supported, and we only got that workaround from a smart guy in the forums last time.  There comes a point in time when you have to keep the kids on the playground the same age otherwise you hit issues.

    For your customers that will hit this, plan on buying RDcals (that go no where) and bypassing RWW and using the RDGateway methodology to gain access to their remote machines.

    Friday, August 5, 2016 7:02 PM
  • The reality is that small businesses don't want to spend money Susan.  If you are going to pay for the upgrades and the stupid Exchange SaaS, then by all means send me some money.  Otherwise please keep your "realities" to yourself unless you have something to say that contributes to the fix.

    Server support life cycles are 10 years.

    I do know of using RDGateway.  People are not going to spend money on something that was working fine until MS forced everyone to upgrade to Windows 10.  If they want to force upgrades, then they better make sure everything still works.

    I'm not going to debate this with you, I'm looking for Eve @ MS for support or other members with constructive problem solving.

    Friday, August 5, 2016 10:39 PM
  • Microsoft didn't come up with the workaround the last time.  Right now the community is the support for SBS 2008 and SBS 2011.

    Microsoft didn't force everyone to Windows 10.  Yes you had to be smarter than the average bear but ultimately it was a not well read click that got everyone here.

    The error message indicates a RDP protocol mismatch.  The 'fix' in a non Windows 10 era is to roll back to a prior RDP protocol.  Given the 10 model we can't do that.  We have a workaround.  Tape a $100 bill to the top of the monitor of each user and when Microsoft contacts you for their RDP cals, hand it to them.

    Friday, August 5, 2016 10:47 PM
  • Thanks again for not contributing to the solution.  Go away.

    Saturday, August 6, 2016 2:18 AM
  • Daryl I'm a realist.  We can barely get things fixed for Essentials these days.  For now roll back from that AU release because you only have 10 days to roll back [not the old 30 days from before].  If these are pro versions (probably not) you can push off the AU release for first 4 months.  If they are home, I am wincing at this but disable auto updates and manually install the 1511 as you can't block the AU release in non pro versions.

    In the meantime I'll go dig up that original thread of the person who found our workaround (it wasn't Microsoft) the last time and see what we can do. 

    But I'm telling you SBS 2008 isn't supported by Microsoft, there will be no official fix.

    Saturday, August 6, 2016 2:47 AM
  • Talked to the Essentials team, they will have the support guys look at the SBS 2008 issue.  Again can't promise anything at this time.
    Tuesday, August 9, 2016 5:27 PM
  • Server support life cycles are 10 years.

    Just to clarify:  SBS has always had an EOL that stretched to the EOL of all of its bits.  In most cases this is/was Exchange.  Exchange 2007 EOLs  4 April 2017. 


    About half way down.

    There may be some other part of SBS 2008 that extends longer, but if so, it is that bit that ends the support life cycle and I'm willing to bet (small amounts please) that whatever it is won't mean they keep RWA on SBS 2008 current with Windows 10 v2017.

    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Tuesday, August 9, 2016 10:33 PM
  • SBS 2008 is in extended support, not mainstream  That means if it gets broken, and it needs a design change or any sort of update to fix it back up, it's not going to get it.   SBS 2011 is pretty much in the same boat.

    WSUS goes out of support next year btw, so that's probably going to be the first sort of component out of complete support.


    Tuesday, August 9, 2016 10:55 PM
  • Hi,

    I am checking to see how things are going there on this issue. Please let us know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 19, 2016 11:40 AM
  • It's still broken.  Let me check with the product group.
    Friday, August 19, 2016 4:32 PM
  • I have this same exact problem!  SBS 2008 running on server.  I have been using it for 8 years now to remote into my office.  Updated all my home and portable work computers to Windows 10 anniversary.  Bam!  No longer able to connect.  Get the above error message.  Completely reinforces the idea that Microsoft does not give a damn about its small business customers!  People that roll out the updates to Windows 10 are clueless about the "real world" problems being caused to the customers!  Makes me want to completely abandon Microsoft and load Linux on everything! Makes Microsoft look like a joke.
    Wednesday, August 31, 2016 2:02 AM
  • Hi,

    The connector is still a work in progress.  It is a shame you did not do a bit of research before taking the plunge, or tested one computer before upgrading them all. 

    I don't mean to pick on you, but there was plenty of warning that Windows 10 was not fully functional with SBS 2008.  To blame MS for falling into this pit after the warning signs and the danger will robinson alerts were easily located is a bit like blaming Firestone that modern tires don't fit your Model T. 

    SBS 2008 is nearing EOL.  There are still hopes for a fix, but we are all on "wait and see" standby with the gate closing soon.

    Larry Struckmeyer [MVP]-- --If your question is answered please mark the response as the answer so that others can benefit.

    Wednesday, August 31, 2016 6:17 PM
  • Hi Daryl,

    Have you found a work around on this issue yet.  Our computers are updating to this anniversary edition automatically.  Once updated, they cannot connect anymore.

    Please advise.

    Tuesday, September 13, 2016 10:12 PM
  • Is there any answer from the product group yet?
    Tuesday, September 13, 2016 10:14 PM
  • Let me recheck.  We have no other workaround at this time other than bypassing RWW and using RDgateway settings inside the RDP client so as to bypass RWW and use RDP straight and hit the workstation directly. (click on options, then advanced tab , in the connect from anywhere settings enter the url for the RWW you used to use. Now click on RDP enter domain\username and password and hit the desktop directly. Use that as a workaround until we can get an official response from the product team.
    • Proposed as answer by TimXyzzy Saturday, October 1, 2016 9:21 PM
    • Unproposed as answer by TimXyzzy Saturday, October 1, 2016 9:22 PM
    Tuesday, September 13, 2016 10:58 PM
  • Suffering from the same business damaging situation in SBS 2008, I am trying to set up the RDG as detailed in this thread.

    I go to Server Manager/Roles Summery/Add Roles - and Remote Desktop Services is nowhere to be seen. 

    Please advise!

    Wednesday, September 21, 2016 2:51 PM
  • Don't change ANYTHING on your SBS 2008.  RDG is already there and set up.  You only instruct the clients to now use RDP and edit the "access anywhere" section.

    Let me restate:  RDGateway and it's role is already under the hood and working.  You do NOTHING to the server side.  It's all on the client.

    How to Manage the Remote Desktop Gateway Service in SBS 2011 Standard , SBS 2011 Essentials, Windows Server 2012 Essentials and Windows Server 2012 R2 Essentials.:
    https://support.microsoft.com/en-us/kb/2472211  If you want to manage the RDgateway you just enable the snap in.  But again this is not even required to do anything on the server side to get the workaround working.

    [As to the long term resolution -- I will check again with the product group, they've not responded :-(

    Wednesday, September 21, 2016 4:04 PM
  • This has happened to me now that 1607 has arrived on my computer. As we well know, Win10 updates are secretive at best, I look forward to telling my clients that they can no longer connect after being automatically upgraded. Windows 10 continues to hammer more nails into its coffin for me :(, rant over.

    I have tried the RDP method but it fails to connect, saying my user account is not listed in the RD Gateway permissions list or that it is expecting an FQDN/IP. I am using the Domain Admin account and have tried connecting with both FQDN and IP. Do I need to make permission changes on the server? Luckily I still have a Win7 PC so RWW is still possible, but this won't be the case for my clients so I would like to know how to fix for them, thanks.

    Thursday, September 22, 2016 8:26 PM
  • I don't think you are doing it right or you didn't put in the right url.  Whatever you used to go to using RWW/IE, that url stick it into the RDgateway tab.

    Open up your RDP connection, click on the last tab, click on advanced, in the Rdgateway setting enter the url of RWW you used to go to as the Rdgateway entry.  Then in the RDP first tab put the computer/host name and in user put in domain\user.

    There are zero changes to be made on the server.

    • Edited by Susan BradleyMVP Friday, September 23, 2016 12:18 AM
    • Proposed as answer by JamesHurc Wednesday, September 28, 2016 1:09 PM
    Friday, September 23, 2016 12:17 AM
  • And you don't put in www.domain you just put in the info without www.  So if it was domainname.com/remote put that in just like that.
    Friday, September 23, 2016 12:19 AM
  • Thank you Susan, I was doing it wrong :) - for me where it wasn't clear was that I had included the domain name in the first (General) tab of RDC incorrectly, now just using hostname in the Computer field (with the domain name in the Advanced Settings) and it connects fine, thanks again for the quick response.

    Friday, September 23, 2016 2:12 AM
  • Hi,

    We starting seeing this issue this morning. Try removing .NET framework 4.6 on the machine and see how you go. 50% strike rate so far. 1 worked, 1 didn't

    Friday, September 23, 2016 3:32 AM
  • I need a favor of someone in this thread.  I need a repro server that someone would be willing to let the Product group look at.  If you are willing, email me at susan-at-msmvps.com (change the -at- to @) and I'll get you hooked up.
    Friday, September 23, 2016 4:59 AM
  • 4.6 on the server or 4.6 on the 10?
    Friday, September 23, 2016 5:00 AM
  • I have no problem with the product running towards EOL, and accept the need to plan and implement a replacement system within that timescale.

    I do have a HUGE problem in being bounced into replacing it at impossibly short notice, still well within the timescale.

    It seems that Microsoft do not care about the impact of ill thought through Win10AU changes which cannot be prevented.  This bombs one of the key attributes of a working system and wrecks an organisational structure of remote workers.   

    Sunday, September 25, 2016 9:57 AM
  • Susan,

    Like others here, I am disgusted by Microsoft: it has never EVER conceded the view held by 99.99% of other businesses that "the customer is always right". Time after time Microsoft stuffs things down our throats that we don't want. The unmitigated gall that organisation has is all I need to keep using non Microsoft products where ever and when ever I can.

    Anyway, I am trying your workaround without success, and hope that someone here can help:

    If I use the Advanced Tab in RDGateway, go to Settings>Use these RD Gateway server settings and enter what we were using as the url (https://mail.<domain-name>/remote) it won't let me go back to the first tab to enter the computer name (or host) and then domain\user because it says "A valid gateway server address must be specified" IF I remove the https:// from the entry I get the same result.

    So what is the valid gateway server address. (And here I'm hoping that the still current port 3389 forwarding on the router is not upsetting things - YES, I've been trying to get the customer to drop 'Terminal Server Access' for security reasons and start using RWW, but I can see where that's gone now.



    Monday, September 26, 2016 7:05 AM
  • I got it working as a workaround by replacing the mstscax.dll (Version 10.0.14393.0) in %windir%\SysWOW64\ with the "backup file" in "Windows.old\WINDOWS\SysWOW64" version (10.0.10586.494)

    I had to take ownership of the file and give Administrators Full control access to be able to replace the file.

    Hope this helps someone out.

    • Proposed as answer by Jason.25 Wednesday, September 28, 2016 7:07 PM
    Monday, September 26, 2016 4:38 PM
  • Just applied Julestastic's workaround for a client and it worked perfectly - thanks!!
    Monday, September 26, 2016 6:24 PM
  • Confirmed; IT WORKS!

    Many thanks, please collect your Genius badge as you leave the office this evening.

    • Proposed as answer by Peasmarsh1 Wednesday, September 28, 2016 7:56 AM
    Tuesday, September 27, 2016 5:03 PM
  • Thanks - didn't realise I could just use Remote Desktop like that - problem solved
    Wednesday, September 28, 2016 1:10 PM
  • Yes this also enabled RWW to work again for me.


    Wednesday, September 28, 2016 1:30 PM
  • Confirmed! Many thanks Julestastic

    • Edited by Jason.25 Wednesday, September 28, 2016 7:07 PM
    Wednesday, September 28, 2016 7:06 PM
  • To be Debbie Downer this is a temporary fix.

    For sure it will break again each feature release as the bits are replaced by the next release.  It might even break on a cumulative monthly update if they patch the RDP.  

    Don't plan on this sticking long term.

    Thursday, September 29, 2016 1:24 PM
  • MS has confirmed a fix for this issue is going to released as a KB on October 28th. This will work in the meantime, Debbie Downer. Just keep a copy of the mstscax.dll 10.0.14393.0 handy until then!
    Thursday, September 29, 2016 8:50 PM
  • Can you share who you talked to as I've gotten nothing back from the product team.
    Friday, September 30, 2016 1:59 AM
  • Would you believe it!!!

    Last night there was an update which overwrote the replaced and working mstscax.dll file with a non-working one.

    Again, change permissions to Administrator/All, and re-install the file which works.

    Can someone get Microsoft to listen and stop trying to convert us all at very short notice to Server 2016 by their crass behaviour.

    Friday, September 30, 2016 6:31 AM
  • Cumulative update model :-(  
    Friday, September 30, 2016 11:48 AM
  • Thank you Susan, that worked great for me!


    Saturday, October 1, 2016 9:23 PM
  • Just a follow up: I have been able to get the RDP method to work on two clients thusfar, with a third in progress.

    Almost seems to me my clients would prefer this anyway than the long winded RWW approach, and as I gather this uses port 443 rather than 3389 it is quite an elegant solution.

    I can also confirm that the latest mstscax.dll also broke the interim fix I had applied. Will need to wait until October 28 I guess.


    Monday, October 3, 2016 4:00 AM
  • " I gather this uses port 443 rather than 3389 " Yes, it tunnels the traffic over 443 so like RWW you only have to open that port.
    Monday, October 3, 2016 8:10 PM
  • I'd been using the RDC-to-rdgateway workaround mentioned on several other forums for the past few weeks, but as of today that's inexplicably stopped working, as well.  Am now using the mstscax.dll overwrite solution and am able to get in that way.  rdgateway appears to now be completely broken, once I overwrite that mstscax.dll fie.  This hunt for workarounds is getting ridiculous, the 28th can't come soon enough!  :-(

    A bit more info here:  https://community.spiceworks.com/topic/1788483-win-10-anniversary-update-kills-sbs-2008-rww-connection-vbscript-error-50331676

    Saturday, October 8, 2016 7:48 PM
  • Anyone have mstscax.dll v.10.0.10586.494 they can provide?  Recent MS update overwrote it and deleted the Windows.old subdirectory where I had copied from as described above to fix.  Thank you.
    Sunday, October 9, 2016 11:46 PM
  • I need to confirm something here:

    Is everyone impacted running 32 or 64 bit?

    Microsoft knows about the 32bit bug in 1607 accessing Rdgateway.  But on SBS 2008 you guys can go around RWW and access Rdgateway directly.  Can you confirm 32 or 64 bit please? and if 32bit windows 10, can you confirm that IS working if you bypass RWW and use the rdp/rdgateway directly?

    Tuesday, October 11, 2016 5:01 PM
  • I am running 32 bit on my 'holiday' computer.

    The mstscax.dll file does need replacing to access SBS2008 remotely.  For avoidance of doubt, it is found in C:\windows\System32 folder.  

    I have found the takeownership app from 'winaero-download-view16, a helpful way of quickly changing file attributes to Administrator control:

    Monday, October 17, 2016 7:32 AM
  •    I have the same issue but the problem isn't with the SBS 2008 or the remote computer. It is with mine. My customer has a SBS2008. My workstation is Windows 10 and one day when I tried to RWW in to one of their computers I got the 50331656 error.

       I worked on it for days and Googled until I was blue in the face. Then I decided to try it from a Windows 7 computer and it worked like a champ. Since then I have tried RWWing in on four different Windows 10 computers and all of them get the 50331656 error yet I can turn around and RWW in via 6 different Windows 7 computer and it still works flawlessly.

       The problem, at least in my case, is the computer I am using to invoke RWW. Windows 10 doesn't work any longer. It use to. As near as I can tell it quit working around the time of the anniversary update. Still haven't found a fix. When I want to RWW in to their system I have to hop on a Windows 7 system to do it.

       Haven't found a fix yet. Don't know if it is with Windows 10 or and update to IE. Very frustrating.

    • Edited by Ziggy32 Friday, October 28, 2016 11:55 AM
    Friday, October 28, 2016 11:54 AM
  • MS has confirmed a fix for this issue is going to released as a KB on October 28th. This will work in the meantime, Debbie Downer. Just keep a copy of the mstscax.dll 10.0.14393.0 handy until then!
    Alright, It's now October 28th-- where's our KB? Link?
    Friday, October 28, 2016 3:44 PM
  • MS has confirmed a fix for this issue is going to released as a KB on October 28th. This will work in the meantime, Debbie Downer. Just keep a copy of the mstscax.dll 10.0.14393.0 handy until then!

    Alright, It's now October 28th-- where's our KB? Link?

    I had this come up as an issue with a client today.  Did a search and found this topic.   After testing on my own Windows 10 system with 1607 on it I found that the RWW connection works fine. 

    I received two updates on Oct 27

    Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3197954)

    Update for Windows 10 Version 1607 for x64-based Systems (KB3199986)

    So it is possible one of them fixed the issue.   I am having the user that can't connect to the RWW check for updates to make sure he is completely up to date.   If it does update he will test to see if he can connect through RWW without the error.   

    Friday, October 28, 2016 8:26 PM
  • Install the cumulative update released on 10/27/2016 (in addition to the flash update that also came out out of band)

    If you are STILL having issues connecting via RWW AFTER this update
    PLEASE let me know.

    I thought some of you guys had 64bit workstations impacted.  Bottom line test and report back please.

    Addressed connectivity issue from a 32-bit application to a Remote Desktop Gateway that doesn’t have HTTP tunneling enabled.

    Monday, October 31, 2016 6:59 PM
  • you are simply wrong. While it is aggravating you have to upgrade on schedule. Sorry!

    If it is not worth the $$ don't use it.

    Thursday, December 8, 2016 7:37 AM