none
External Journaling and Message Size

    Question

  • Hi,

    I feel like I am in a chicken and egg situation with Exchange 2013.  The organization has a maximum message limit size of 50MB.  We also need to journal all email offsite to a third-party vendor.  The problem arises if a user sends a message to another user in our company with a message size of say 45MB.  The message gets sent with an issue but it cannot be journaled because the message is too large due to message encoding which increases the message size by about 33%.  If I increase the maximum message size to say 75MB, it does nothing to prevent a user from sending a 75MB message and generating the same NDR when the message goes to the journal.  Any advice on how to get around this?  Thanks.

    Wednesday, January 3, 2018 7:32 PM

Answers

  • Setting the connector will not do it according to the MS documentation I am reading as the Global Setting overrides any connector setting (http://techgenix.com/managing-limits-exchange-server-2010-part1/).  I was considering a rule as well but it seems to clunky.  I did a little more digging and found that if the message can leave the mailbox at a certain size (say 48MB), it can completely leave the existing organization before the encoding impacts the internal send connectors.  Basically, if two users in the same organization can send a message at 50MB, it can be routed out my journal connector as well.  Now I just need to talk with my journaling vendor to find out why the messages are not being journaled.  Thanks.
    • Marked as answer by asalois Wednesday, January 3, 2018 10:00 PM
    Wednesday, January 3, 2018 10:00 PM

All replies

  • Hi,

    I feel like I am in a chicken and egg situation with Exchange 2013.  The organization has a maximum message limit size of 50MB.  We also need to journal all email offsite to a third-party vendor.  The problem arises if a user sends a message to another user in our company with a message size of say 45MB.  The message gets sent with an issue but it cannot be journaled because the message is too large due to message encoding which increases the message size by about 33%.  If I increase the maximum message size to say 75MB, it does nothing to prevent a user from sending a 75MB message and generating the same NDR when the message goes to the journal.  Any advice on how to get around this?  Thanks.

    Set the global settings to 75MB.

    THen create a rule that rejects any message over 50MB except when sent to the 3rd party vendor.

    Wednesday, January 3, 2018 7:44 PM
  • Hi,

    You can follow the below mentioned steps:

    First get the name of you connector with the help of PowerShell

    Get-ReceiveConnector
    Then
    Set-ReceiveConnector -Identity Defaultconnector -MaxMessageSize 54096

    Where “Default connector” is the name of your default frontendTransport Connector and MaxMessageSize is set to 54meg here.

    Now restart the Microsoft Exchange transport Service to complete the task.

    Increase Maximum Receive Message Size with Exchange Admin Center

    We first need to launch the EAC and select Mail Flow

    Once done we then select Receive Connectors and select the Default Frontend YOURSEVERNAME connector. Once done, select the pencil to edit. As you can see below, in the general tab you can edit the maximum receive message send size to what you would like to use. Do so and click save.

    Again restart the Microsoft Exchange Transport service to make these changes take effect.

    Thanks

    Wednesday, January 3, 2018 7:49 PM
  • Setting the connector will not do it according to the MS documentation I am reading as the Global Setting overrides any connector setting (http://techgenix.com/managing-limits-exchange-server-2010-part1/).  I was considering a rule as well but it seems to clunky.  I did a little more digging and found that if the message can leave the mailbox at a certain size (say 48MB), it can completely leave the existing organization before the encoding impacts the internal send connectors.  Basically, if two users in the same organization can send a message at 50MB, it can be routed out my journal connector as well.  Now I just need to talk with my journaling vendor to find out why the messages are not being journaled.  Thanks.
    • Marked as answer by asalois Wednesday, January 3, 2018 10:00 PM
    Wednesday, January 3, 2018 10:00 PM
  • Setting the connector will not do it according to the MS documentation I am reading as the Global Setting overrides any connector setting (http://techgenix.com/managing-limits-exchange-server-2010-part1/).  I was considering a rule as well but it seems to clunky.  I did a little more digging and found that if the message can leave the mailbox at a certain size (say 48MB), it can completely leave the existing organization before the encoding impacts the internal send connectors.  Basically, if two users in the same organization can send a message at 50MB, it can be routed out my journal connector as well.  Now I just need to talk with my journaling vendor to find out why the messages are not being journaled.  Thanks.

    a Rule is never clunky. Not sure what you mean by " can completely leave the existing organization before the encoding impacts the internal send connectors. ".

    Thursday, January 4, 2018 1:31 AM