locked
Need to install an earlier version of Citrix receiver on Windows 10 RRS feed

  • Question

  • I need to install an earlier version of Citrix (this is the supported version for my work) and get the message that it is not the latest version and that Citrix recommends installing the latest version.  The only option avaialable from this pop-up is "OK".  This aborts the installation.  How do I get the option to continue the installation?
    Friday, February 3, 2017 4:08 PM

Answers

  • Hi Karen.

    The only thing you could try to do is running the installation program in compatibility mode targeting a previous Windows version or using the Run program made for previous versions of Windows applet in the Windows Control Panel under Control Panel -> All Control Panel Items -> Troubleshooting.
    If none of these strategies solves your problem, I suggest you to contact Citrix and ask for support.

    Bye.


    Luigi Bruno
    MCP, MCTS, MOS, MTA

    Friday, February 3, 2017 4:36 PM