locked
RD Web Access SSL certificate will not install RRS feed

  • Question

  • I am really hoping somebody can help me with this. I have an RDS 2012 R2 setup which is relatively simple. I have two session hosts, a server hosting RGW, and another server which is the licensing server, RD web access server, and the connection broker. I purchased a wildcard certificate for my domain, and have used the RDS gui to install the certificate successfully for SSO, Publishing, and RD Gateway. For whatever reason, the certificate will not install for the RD Web Access role.  I get this error message:

    "Could not configure the certificate on one or more servers. Ensure that the servers are available on the network and apply the certificate again."

    I have the wildcard certificate imported into the Personal Store on the Connection Broker itself, and I am running Server Manager on the Connection Broker. I created a .pfx file which contains the private key of the certificate, and this is what I point to when I try to install the certificate. This same certificate installs for the other roles, but not for RD web access. Does anybody have any idea why this might be happening? Thanks in advance for any help you can provide.

    -Rob

    Thursday, July 30, 2015 1:31 AM

Answers

  • Hi Rob,

    Please ensure that there is no network connectivity issue between terminal servers, you may also disable firewall temporarily to test.

    In addition, you may also check whether any related logs were logged.

    If the issue persist, please recreate the .pfx file to configure again.

    Here is a related blog below for you, within comments, there is a user who had the same issue which got resolved:

    Configuring RDS 2012 Certificates and SSO

    http://ryanmangansitblog.com/2013/03/10/configuring-rds-2012-certificates-and-sso/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Amy Wang_ Friday, July 31, 2015 9:45 AM
    • Proposed as answer by Amy Wang_ Wednesday, August 5, 2015 3:02 AM
    • Marked as answer by Amy Wang_ Thursday, August 6, 2015 6:10 AM
    Friday, July 31, 2015 9:44 AM

All replies

  • Hi Rob,

    Please ensure that there is no network connectivity issue between terminal servers, you may also disable firewall temporarily to test.

    In addition, you may also check whether any related logs were logged.

    If the issue persist, please recreate the .pfx file to configure again.

    Here is a related blog below for you, within comments, there is a user who had the same issue which got resolved:

    Configuring RDS 2012 Certificates and SSO

    http://ryanmangansitblog.com/2013/03/10/configuring-rds-2012-certificates-and-sso/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Edited by Amy Wang_ Friday, July 31, 2015 9:45 AM
    • Proposed as answer by Amy Wang_ Wednesday, August 5, 2015 3:02 AM
    • Marked as answer by Amy Wang_ Thursday, August 6, 2015 6:10 AM
    Friday, July 31, 2015 9:44 AM
  • I am resurrecting this post as it just pisses me off. No, this is not the answer as there literally isn't an answer on the link you sent. The person re-exported their cert and this "resolved" their issue. I am having this exact same issue and the only things I am seeing to resolve it are to re-export the cert or just nuke the whole config from orbit and start over. Neither of these "fixes" work at all. Please do not mark your past as the answer when it is certainly not an answer.

    Tuesday, August 23, 2016 5:08 PM