none
Certificate Missing RRS feed

  • Question

  • Hello,

    I was trying to setup a file with EFS that was able to be accessed by multiple users. We tried sharing the file after encrypting it, and tried adding the user to the list of users who can decrypt the file (In Properties / Advanced / Details) we tried adding a certificate to the machine. When we first were trying to add a user to be able to decrypt it said that there was no valid certificate for the user. So we took the personal certificate of the user from the Windows 7 machine (that was having the file shared to) and added it to the Windows 10 machine certificate manager (for the user that was sharing the file). After trying this we noticed that the personal certificate for the user was gone out of certificate manager on the windows 10 machine, and just showing the windows 7 user certificate. For the Windows 10 user, How do I get a personal certificate back? Also, we do not have a CA.

    Tuesday, June 7, 2016 1:16 PM

Answers

  • Hi rickycrosby111,

    I have made a test on my side and it is available for me to access the encrypted file. There is no need to import the certificates. When we access the shared folder, we will be prompted for the credentials of the Windows 7 machine. We should ensure the username we input has the EFS certificate in the "personal" store.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, June 8, 2016 7:00 AM
    Moderator