locked
Office 2010 on Server 2012 RDS with App-V 5 SP1 RRS feed

  • Question

  • Hi All,

    Is running office 2010 via App-v on Windows Server 2012 RDS Server supported?

    I’ve sequenced Excel 2010 using the following Microsoft Guide: http://support.microsoft.com/kb/2830069 (rubbish guide btw), but when I try to run Excel it states:  “The Operating system is not presently configured to run this application”.

    I sequenced this application from a server 2012 machine & selected all available operating systems. The package can be run from a windows 7 machine.

    Any help would be appreciated.

    Wednesday, May 29, 2013 5:12 AM

Answers

  • Hi 

    Sorry, i up a little bit this thread.
    It works. 

    For your error, that's due to a key in the registry. Control if you have, at the end of sequencing, an entries in virtual registry : 

    "HK_Current_User\Software\Microsoft\Office\" an other directories of "14.0"

    If you have it, delete it and check again on 

    "HK_Current_User\Software\Wow6432Node\Microsoft\Office\" and same controle.

    Normaly that will correct your bug. 

    Sorry for my bad English, I've to learn.

    Regards,

    HanggoveR



    • Proposed as answer by Hanggover Friday, July 19, 2013 9:25 AM
    • Edited by Hanggover Friday, July 19, 2013 9:26 AM Writing correction
    • Marked as answer by Aaron.ParkerModerator Thursday, August 8, 2013 7:18 AM
    Friday, July 19, 2013 8:08 AM

All replies

  • Hello,

    I followed the above guide, the app-v sequencing guide and did not receive that error. Works great

    Yes it is supported on RDS - I do note this though;

    NOTE: Only a single Office 2010 App-V v.50 Package can be deployed to a client machine.  Scenarios involving multiple App-V v5.0 Office 2010 packages deployed on a client are not supported.

    General support statement;
    http://support.microsoft.com/kb/2772509


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, May 29, 2013 8:22 AM
  • Hello,

    I followed the above guide, the app-v sequencing guide and did not receive that error. Works great

    Yes it is supported on RDS - I do note this though;

    NOTE: Only a single Office 2010 App-V v.50 Package can be deployed to a client machine.  Scenarios involving multiple App-V v5.0 Office 2010 packages deployed on a client are not supported.

    General support statement;
    http://support.microsoft.com/kb/2772509


    Nicke Källén | The Knack| Twitter: @Znackattack

    This is the only Office 2010 App-V 5 package that has been published to the RDS server.
    Wednesday, May 29, 2013 10:56 PM
  • Just published the office 2010 package to a non RDS 2012 box, I was able to run the package...

    But I still get the below error when running from a RDS 2012 box:-

    Error when running from 2012 RDS

    This is a picture of the package deployment tab:

    Deployment Tab

    Thursday, May 30, 2013 7:07 AM
  • Hello,

    I googled for APp-V + your error message and this were part of the top 10 hits;

    http://social.technet.microsoft.com/Forums/en-US/mdopappv/thread/80b8cc1f-fa15-44a9-ac13-b1813a83b70b/
    http://santospardos.blogspot.se/2011/01/operating-system-is-not-presently.html
    http://appvirtguru.com/viewtopic.php?p=10205
    http://mytechnology13.blogspot.se/2010/12/operating-system-is-not-presently.html
    http://blogs.technet.com/b/appv/archive/2008/04/09/some-softgrid-enabled-office-applications-may-not-run-if-mcafee-virusscan-8-5i-is-installed.aspx


    Nicke Källén | The Knack| Twitter: @Znackattack


    None of this links mentions RDS…

    I have re-sequenced Office 2010 on a Server 2012 box with RDS installed (was previously sequenced without RDS installed) & then published the app to my RDS box (un-published the old package first) but I still get the same error.

    Thursday, May 30, 2013 8:11 AM
  • Hello,

    The idea of the link is not specific to troubleshooting RDS at all - but rather a generic process on howto leverage the Process Monitor as a tool to assist in troubleshooting and understanding your specific environment.

    Process Monitor will not scream out why an error occurs, but rather it will present all activity the occurs. If one takes the time to understand the activity the Process Monitor presents certain behaviors or oddities can be located - the above posts were a suggestion to understand the process.

    If you do not want to troubleshoot the issue, perhaps going a different direction where a native installation of Office 2010 is the way forward?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, May 30, 2013 8:45 AM
  • Hello,

    The idea of the link is not specific to troubleshooting RDS at all - but rather a generic process on howto leverage the Process Monitor as a tool to assist in troubleshooting and understanding your specific environment.

    Process Monitor will not scream out why an error occurs, but rather it will present all activity the occurs. If one takes the time to understand the activity the Process Monitor presents certain behaviors or oddities can be located - the above posts were a suggestion to understand the process.

    If you do not want to troubleshoot the issue, perhaps going a different direction where a native installation of Office 2010 is the way forward?


    Nicke Källén | The Knack| Twitter: @Znackattack

    What am I meant to be looking for with process monitor? I run the package while process monitor was monitoring & didn't really see any “oddities”.

    I will mention that this is the first App-V infrastructure that I have put in place, so I don’t have the background of using the previous versions of App-V.

    I have also retried the following:-

    Reinstalled the RDS Client (not the issue as I am successfully running other app-v packages)

    Sequenced office 2010 on a 2012 server with RDS installed.  

    Sequenced office 2010 without the Deployment kit for App-V & Office 2010 Sequencing kit for App-V.

    But each time I still get the error: The Operating system is not presently configured to run this
    application.


    Saturday, June 1, 2013 3:23 AM
  • Ok I found the solution, I was sequencing using office 2010 standard, I tried using Office 2010 Professional Plus & it work perfectly.

    • Marked as answer by Billy Goat Saturday, June 1, 2013 8:40 AM
    • Unmarked as answer by Billy Goat Tuesday, June 4, 2013 11:45 AM
    Saturday, June 1, 2013 8:40 AM
  • Ok I found the solution, I was sequencing using office 2010 standard, I tried using Office 2010 Professional Plus & it work perfectly.

    Got the same problem again...

    Was working fine until I did a reboot, than the same: "The Operating system is not presently configured to run this application" error message appeared. There are no error's in any logs.

    Tuesday, June 4, 2013 11:47 AM
  • I have re-sequenced office 2010 again on a 2012 box with remote session host feature installed, but still cannot run the package on my production 2012 RDS box.

    These are the commands I am running pre-sequencing:

    msiexec /i c:\Deploymentkit\OffVirt.msi ADDLOCAL=OSpp,OSpp_Core,OSppWoW64 PROPLUS=1 PIDKEYS=%MAKKEY% USEROPERATIONS=1

    Commands running during sequencing:

    Msiexec /I "c:\SequencingKit\App-V_Seq_Kit.msi" PACKAGEROOT=C:\Office2010

    Commands run during customisation:

    c:\SequencingKit\manifestUpdater.exe LICENSE="PROPLUS=1 PIDKEYS=%MAKKEY% USEROPERATIONS=1"

    Is there something I am missing, can someone please provide me with some guidance?


    • Edited by Billy Goat Saturday, June 8, 2013 3:40 AM First command I am running is pre-sequencing, not during.
    Friday, June 7, 2013 2:27 AM
  • Hello,

    The first command-line should be executed pre-sequencing, (step 2 according to sequencing guide) and not during sequencing.

    http://support.microsoft.com/kb/2830069


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, June 7, 2013 8:21 AM
  • Hello,

    The first command-line should be executed pre-sequencing, (step 2 according to sequencing guide) and not during sequencing.

    http://support.microsoft.com/kb/2830069


    Nicke Källén | The Knack| Twitter: @Znackattack


     Sorry that's my bad, I am running the first command pre-sequencing, I will edit the post 
    Saturday, June 8, 2013 3:38 AM
  • Just reading through the the official App-V 5 Microsoft Office 2010 sequencing guide (http://support.microsoft.com/kb/2830069), which specifies the following prerequisites:

    Microsoft Office 2010 Deployment Kit for App-V: The deployment kit contains the required Office 2010 licensing service(OSPP) and is available here: http://www.microsoft.com/en-us/download/details.aspx?id=10386.

    This points to the download of the Microsoft Office 2010 Deployment Kit for App-V, which was last updated on 26/04/2010, the supported OS is no higher than 2008 R2 and only mentions App-V 4.6.

    So I'll ask again, is office 2010 via App-V 5 on Windows Server 2012 RDS Server supported?

    Friday, June 14, 2013 1:06 AM
  • Hello,

    According the documentation you found - no.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Friday, June 14, 2013 6:05 AM
  • Hi 

    Sorry, i up a little bit this thread.
    It works. 

    For your error, that's due to a key in the registry. Control if you have, at the end of sequencing, an entries in virtual registry : 

    "HK_Current_User\Software\Microsoft\Office\" an other directories of "14.0"

    If you have it, delete it and check again on 

    "HK_Current_User\Software\Wow6432Node\Microsoft\Office\" and same controle.

    Normaly that will correct your bug. 

    Sorry for my bad English, I've to learn.

    Regards,

    HanggoveR



    • Proposed as answer by Hanggover Friday, July 19, 2013 9:25 AM
    • Edited by Hanggover Friday, July 19, 2013 9:26 AM Writing correction
    • Marked as answer by Aaron.ParkerModerator Thursday, August 8, 2013 7:18 AM
    Friday, July 19, 2013 8:08 AM