none
Power Query Hanging/Waiting/Loading RRS feed

  • Question

  • Hello -

    I have a very simple Excel workbook with one sheet and  twelve columns and only 200 rows. I like Power Query and the way I can merge other worksheets, tables, etc.  - however, whenever I build a query reading my twelve-column table, it hangs (spinning circle - Windows 8-64 bit) in such a way I cannot select any columns.

    I've tried "Close & Load To" and going back to edit the query, but it still stalls. Is there something wrong with the source file? I can't imaging the table being so large as to cause this hang up to happen.

    I also thought it was because my source file wasn't in a table format, but I tried changing it to a table and it still hangs in PQ.

    Thank you.

    Clifton


    Monday, May 4, 2015 6:16 PM

Answers

All replies

  • I've compared what is being loaded into Power Query to what's in the original table and empty cells are being truncated and everything is being shifted to the left. (and possibly causing a loop or other error?)

    Is this being done by PQ or by the way the source table is setup? If the latter, how do I fix the source table?

    Monday, May 4, 2015 7:37 PM
  • Would it be possible for you to share your Excel file with us? If it doesn't contain sensitive data, you could send a frown and attach the file containing the problematic table.

    Ehren

    Monday, May 4, 2015 9:53 PM
    Owner
  • I cannot send it - student information.

    I've tried looking at the source table to see if it's formatting but I can't find anything unusual.

    The source file is on a network drive (which I have access to) - but could there be some network setting that is hanging it?


    BTW - the spinning circle is ONLY when the pointer is above the data in the Query Editor. I can access all options in the ribbon, BUT, I cannot select a column due to the spinning circle.
    Tuesday, May 5, 2015 1:27 PM
  • How about creating a copy of the file, manually changing the data to be meaningless/non-sensitive, and seeing if the issue still repros? If so, you could send the scrubbed file to us.

    Ehren

    Tuesday, May 5, 2015 5:02 PM
    Owner
  • Also, what version of PQ are you using?

    Ehren

    Tuesday, May 5, 2015 5:02 PM
    Owner
  • PQ Version2.21.3974.242

    Okay - file is scrubbed. How do I send it to you? (btw - I tried running another PQ and it created the same issue).


    Tuesday, May 5, 2015 6:06 PM
  • You can send us the file over email as an attachment using the built-in "Send-A-Frown" feature in the product. It should be a smiley in the upper left corner of the query editor window.
    Tuesday, May 5, 2015 7:00 PM
    Moderator
  • CMcReynolds, did you send the file?

    Thanks!


    Ed Price, Azure & Power BI Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Sunday, May 10, 2015 5:57 AM
    Owner
  • I did. Last week on 5/5
    Monday, May 11, 2015 1:59 PM
  • Hi CMcReynolds,

    Is your issue still outstanding?

    If so to help identify the root cause, could you; -

    1) Create another Excel file.

    2) Create a new empty PowerPivot model within this Excel file.

    3) Copy your PQ query to the new Excel file.

    4) Execute copied PQ query and see if you get the same issue.

    Kind Regards,

    Kieran.


    Kieran Patrick Wood http://www.innovativebusinessintelligence.com http://uk.linkedin.com/in/kieranpatrickwood http://kieranwood.wordpress.com/


    • Edited by Kieran Patrick Wood Thursday, May 14, 2015 9:18 AM E-mail received, removed e-mail address
    Tuesday, May 12, 2015 8:38 PM
  • Yes, I've already reproduced the issue a couple of times. If I create the read table, there's no issue - but for some reason, this one file causes PQ to hang in the preview window.
    Wednesday, May 13, 2015 1:42 PM
  • Updated to Version: 2.22.4007.242 and the issue of the "waiting" cursor seems to be fixed.
    • Marked as answer by CMcReynolds Monday, May 18, 2015 8:03 PM
    Monday, May 18, 2015 8:03 PM