locked
Error occurred in deployment step 'Add Solution' RRS feed

  • Question

  • Hello,

    When I deploying my project to SharePoint 2010 using vs 2010, I get this error:

    “Error occurred in deployment step 'Add Solution': The process cannot access the file 'C:\inetpub\wwwroot\wss\VirtualDirectories\80\bin\SPProject.dll' because it is being used by another process.”

    Can anyone help me?

    Wednesday, July 6, 2011 3:28 PM

Answers

All replies

  • Hi Jem,

    There is a process using your dll, almost is OWSTimer.exe Process; you can find which process is using your dll; open cmd and write this command: tasklist /M SPProject.dll; then close the process.

    For more information: http://www.chaholl.com/archive/2011/01/31/quick-tip-error-occurred-in-deployment-step-lsquoadd-solutionrsquo.aspx


    • Marked as answer by Jeff GL Wednesday, July 13, 2011 12:44 PM
    Wednesday, July 6, 2011 3:40 PM
  • Hi,

    Easiest option is IISReset. That should free up the Dll.

    Regards

    Ranga


    Regards Ranga www.sharepointfrontier.com
    Wednesday, July 6, 2011 3:41 PM
  • Hi, If OWSTimer.exe process use the dll; iisreset don’t work in this case.

    Regards,

     

    • Marked as answer by Jeff GL Wednesday, July 13, 2011 12:44 PM
    Thursday, July 7, 2011 7:50 PM
  • thank you a alot
    Thursday, July 14, 2011 10:21 PM
  • Thanks Muawiyah, that was exactly my problem. I ran tasklist and indeed OWSTimer was using the DLL. Killed that process via task manager and the deploy worked.

    Ranga I tried iisreset first, thinking the same as you. That did not solve it.

    Brian

    Monday, May 6, 2013 7:17 PM