none
FIM 2010 R2 SP1 install on Server 2012 with Basic Deployment RRS feed

  • Question

  • Hello everyone,

    I wondered if anyone here would be kind enough to help me connect the dots...

    I am new to FIM 2010 and I am trying to get an environment up and running but I keep running into issues.

    My goal is to us FIM for Password Change Management and GALSYNC.

    To start the process I built 4 servers on Windows Server 2012.

    Here is how I planned to build-out the environment;

    Server 1

       SQL 2012 SP1 with Database feature.

       FIM 2010 R2 SP1 Synchronization Service and Sync Database.

    Server 2 & 3

       FIM Service, portal, password registration and password reset.

       SharePoint 2013 Foundation (FARM)

       NLB setup with 3 virtual IP addresses ( my goal is to have two external accessible servers for redundancy to help support the change password features.

          IP1: portal.company.com (dns record)

          IP2: passwordregistration.company.com (dns record)

          IP3: passwordreset.company.com (dns record)

    Server 4

       SQL 2012 sp1 with Database, Reporting and Analisys features

    So for server 2&3, I installed SP2013 foundation, removed the default web site on both servers and followed the internet resources on how to create a new 2010 site using powershell and I ran the powershell commands needed to support FIM2010 R2 SP1 on Server 2012 with SharePoint 2013 Foundation.

    During my sharepoint installed, I used SERVER 4 as my database server and I also used my internal CA to assign certificates for; portal.company.com, passwordreset.company.com and passwordregistration.company.com

    At this point I can run the sharepoint sites from servers 1 & 2 and I can login to the just fine using HTTPS.

    Here is where things start to get ugly for me...

    Now, I Installed FIM2010 R2 SP1 using SERVER 4 as my database server. The installation completes and everything seem ok.

    But if I go to: https://portal.company.com/identitymanagement it says that the page could not be displayed. I can get to https://portal.company.com and I get the login and it gets me into the SP site just fine. I can also bring up https://passwordreset.company.com and https://passwordregistration.company.com

    Can anyone point out any issues with my deployment efforts? At this point I ran the uninstall, deleted the FIM database and I back tracking my steps but I have been on this for days (HARD) and I cant seem to find out whats going on.

    I would really appreciate any sort of feed back on this.

    Monday, January 27, 2014 5:12 AM

All replies

  • Hi!

    I cant tell you the exact problem with your installation but after a few of my own installations all I can say is stick to the Deployment Guide and you will find the problem.

    If I would guess what the problem is than i would say that the installation of SharePoint Foundation 2013 is wrong and need to be fixed by re installing.

    /Robert

    Tuesday, January 28, 2014 2:56 PM
  • Thanks for taking the time to respond Robert, I really do appreciate it.

    I have since found other articles that appear to better describe the deployment process.

    As for SharePoint, I downloaded SharePoint Foundation 2013 from the Microsoft site.  From a SharePoint point of view, everything looks solid. I can login to the central administration site and to the “Fim Portal” site at : https://firmportal.contoso.com just fine from both NLB servers.

    The issue is when I install FIM, the setup completes without any errors but when I go to: https://fimportal.contoso.com/identitymanagement  it prompts for a login but then it kicks back an error that says:

    Could not load type 'Microsoft.IdentityManagement.WebUI.Controls.Site'.

    This is the article that I am using a as a reference at this time: http://www.harbar.net/articles/fimportal.aspx

    I have read the guides from Microsoft but they assume that I am only doing FIM on one box. In my setup I am using a dedicated sync server, two dedicated fim service/portal/passwordregistration and password reset servers and a dedicated sql server.

    Tuesday, January 28, 2014 3:05 PM